Cookies are disabled. This site requires cookies turned on to run properly. Please enable cookies and reload this page.

Best noise reduction
for digital video
Logo

Quick Start Guide — VirtualDub

This guide is for Neat Video v5 plug-in for VirtualDub being used with VirtualDub2.

If you use another Neat Video plug-in or another video editing application, please select the corresponding quick start guide.

1. Installing the plug-in

1.1. To install the Neat Video plug-in for VirtualDub

  1. Make sure you have started VirtualDub at least once before installing the plug-in. If you have not done it yet, start VirtualDub and exit it.
     
  2. Download the EXE installer of Neat Video for VirtualDub:
  • If you already purchased the product and have a current license for the Home or Pro plug-in, please download the corresponding Home or Pro plug-in from My Products page
  • If you want to try Neat Video before purchase, please download the Demo plug-in from Download page
  1. Double-click the downloaded EXE file to start the installer.
  2. Proceed through the steps of the installation.
    When you install Neat Video, Setup asks you to specify VirtualDub’s ∖plugins∖ subfolder to install the plug-in there.
     
  3. Start VirtualDub and find Neat Video in the list of filters: Video > Filters… > Add… > Neat Video 5.

In case the plug-in was not installed into the right folder, you still can manually install it into VirtualDub using the guidelines below.

1.2. To manually install Neat Video plug-in into VirtualDub

  1. Copy the NeatVideo5.vdf file from the Neat Video installation folder
    (usually, C:∖Program Files∖Neat Video v5 for VirtualDub∖ )
    into the ∖plugins∖ subfolder inside the VirtualDub folder
    (usually, C:∖Program Files∖VirtualDub2∖plugins)
     
  2. If you install the 64-bit version of Neat Video, please make sure you specify the plugins folder
    (or plugins64 in newer versions of VirtualDub) of the 64-bit version of VirtualDub.

    For the 32-bit Neat Video, specify the plugins folder (or plugins32 in newer versions of VirtualDub)
    of the 32-bit version of VirtualDub.
     
  3. Then start VirtualDub and find Neat Video in the list of filters: Video > Filters... > Add... > Neat Video 5.
If Neat Video has not become available in VirtualDub, please contact Neat Video support for assistance.

2. Running Neat Video on a sample video clip

Please download the test-kit prepared to help you start using Neat Video. Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mp4. This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start VirtualDub and go through the steps below to clean the clip using Neat Video.

2.1. Open the sample clip

1. Configure a new project in VirtualDub

Use the File > Open Video file … menu in VirtualDub to open the SampleClip.mpg file:

The VirtualDub preview window will display the sample clip and you will see that there is strong noise in it. The task of Neat Video is to reduce this noise.
 

2.2. Add Neat Video to the composition

  1. Use the Video > Filters... menu item to open the list of used filters:

 

  1. Click the Add... button to open the list of available filters:

 

  1. Select the Neat Video 5 filter in the list and click the OK button:

VirtualDub will add the Neat Video filter and will open the frame selection window.
 

2.3. Configure Neat Video

1. Open Neat Video plug-in window

Click the Build Noise Profile button to open the main Neat Video plug-in window.
(If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further).

The Neat Video plug-in window will open and display the current frame from the clip.

At this point Neat Video will ask to specify the scan type of the clip. Please select Progressive.

 

2. Build a noise profile for the clip

To reduce noise in this frame and in the whole clip, Neat Video needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

  1. In the Prepare Noise Profile tab       click   

 

Neat Video will automatically find an area without details and will analyze noise in that area to build a new noise profile:

  1. Visually inspect the selected area. It should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, then move the selection to a featureless area or simply draw a new selection in such an area (the selection must be at least 32x32 pixels large). Then click the Build Profile button.


 

  1. After that the noise profile is ready and Neat Video can reduce noise in the clip.

 

3. Check Preview
  • Switch to the Adjust and Preview tab 

You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame (see the user guide for more details).

 

4. Apply the changes
 
  • Click    in the bottom of the plug-in window.

Neat Video will save the current settings and close its main window.
(If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point).

Click the Close button in the frame selection window and then click OK in the Filter window to close it as well.

Once that is done, the filter is ready for work.

The preview in VirtualDub now shows the clip with noise reduction applied to it:


 

2.4. Render the video

To apply Neat Video noise reduction
  • Use the File > Save as AVI... menu item in VirtualDub and proceed to render the clip.

This will automatically apply Neat Video noise reduction to the sample clip and save the result to a new video file on the hard drive. You will then be able to open this new file, evaluate the filtration results and adjust the filter settings if necessary.

Please see the User Guide for more details about adjusting the filter settings and other aspects of using Neat Video. These Video Tutorials will also help you to get the most out of Neat Video noise reduction.