Cookies are disabled. This site requires cookies turned on to run properly. Please enable cookies and reload this page.

Best noise reduction
for digital video
Logo

Quick Start Guide — Natron

This guide is for Neat Video v4 plug-in for Natron being used with Natron 2.0.5.

If you use another Neat Video plug-in or another editing application, please select the corresponding quick start guide.

1. Installing the plug-in

To install the Neat Video OFX plug-in:

  1. Make sure you have started Natron at least once before installing the plug-in. If you have not done that yet, start Natron and exit it.
     
  2. Download the installer of Neat Video for OFX hosts:
  • If you already purchased the product and have a current license for the Pro plug-in, please download the Pro plug-in from My Products page
  • If you want to try Neat Video before purchase, please download the Demo plug-in from Download page.
  1. Start the installer:

For Windows:

Double-click the downloaded EXE file to start the installer

For Mac OS X:

a. Double-click the downloaded DMG file to mount the volume
b. In the mounted volume, double-click NeatVideoOFX.Intel.pkg to start the installer
    (you may be prompted to enter the Name / Password of the OSX administrator account)

For Linux:

Double-click the downloaded package Neat VideoOFX.Intel64.tgz to open the archive and extract the installer from it ( NeatVideoOFX.Intel64.run )
(you may be prompted to enter the Name / Password of the administrator account)

  1. Proceed through the steps of the installation process. Use the default settings offered by the installer. This should automatically make the plug-in available to Natron.
     
  2. Start Natron and right-click in the Node Graph panel in the main window of Natron. Then find Neat Video > Reduce Noise  v4 in the list.

In case the plug-in has not become available in Natron, please contact Neat Video support for assistance.

2. Running Neat Video on a sample video clip

Please download the test-kit prepared to help you start using Neat Video. Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mp4. This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start Natron and go through the steps below to clean the clip using Neat Video.

2.1. Add the sample clip to the project

1. Configure a new project in Natron
  1. Go to File > New Project to create a project in Natron:



 

  1. In the Properties window press Settings button to open Project Settings dialog. Select Resolution: HD 1920x1080 pixels; Frame Rate: 25p :



 

2. Add the sample clip file to the project
 

Click the Image button   and then press Read. Navigate to the folder with input clip, select SampleClip.mp4.



 

A node with the sample clip will appear in the Node Graph panel in the bottom of the main window of Natron:

The Natron preview window will display the sample clip and you will see that there is strong noise in it. The task of Neat Video is to reduce this noise.
 

2.2. Add Neat Video to the project

  1. Right-click in the Node Graph panel in the bottom of the window.
  2. Find Neat Video > Reduce Noise v4 in the list:


 

2.3. Configure Neat Video

1. Open Neat Video plug-in window
  1. Select Reduce Noise v4. This will add a node with Reduce Noise v4 into the Node Graph and enable the Controls tab in the Properties panel in the right part of the main window of Natron.
  2. Select Prepare Noise Profile to open the Neat Video plug-in window.
    (If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further).



 

The Neat Video plug-in window will open and display the current frame from the clip.

  1. At this point Neat Video will ask to specify the scan type of the clip. Please select Progressive.
  2. Click the button in the bottom of the Neat Video window select Linear :



 

2. Build a noise profile for the clip

To reduce noise in this frame and in the whole clip, Neat Video generally needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

  1. In the Device Noise Profile tab       click   

Neat Video will then automatically analyze the noise to build a new noise profile:

  1. Visually inspect the selected area — it should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, move the selection to a featureless area or simply draw a new selection in such an area (the selection must be at least 32x32 pixels large). Then click the Auto Profile button again.

  1. After that Neat Video is ready to filter the clip.

     
3. Check Preview
  • Switch to the Noise Filter Settings tab 

You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame.



 

4. Apply the changes
 
  • Click    in the bottom of the plug-in window.

Neat Video will save the current settings and close its main window.
(If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point).

Once this step is completed and Neat Video window is closed, the filter is ready for work.

The Natron preview window now shows the clip with noise reduction applied to it:


 

2.4. Render the video

To apply Neat Video noise reduction
  • Render the clip in the regular Natron way: the menu Render > Render All Writers.

This will automatically apply Neat Video noise reduction to the sample clip and save the result to a new video file on the hard drive. You will then be able to open this new file, evaluate the filtration results and adjust the filter settings if necessary.

Please see the User Guide (Win), User Guide (OS X) and User Guide (Linux) for more details about adjusting the filter settings and other aspects of using Neat Video. These Video Tutorials will also help you to get the most out of Neat Video noise reduction.