Neat Video
noise reduction plug-in for Final Cut (Mac)

To make video cleaner.

User guide

Document version 4.6, 25-Aug-2017
# Table of contents

1 Introduction 3  
   1.1 Overview 3  
   1.2 Features 3  
   1.3 Requirements 3  

2 Key concepts 5  

3 Installing the plug-in 6  

4 Running Neat Video on a sample video clip 7  
   4.1 Add the sample clip to the project 7  
   4.2 Add Neat Video effect 7  
   4.3 Configure Neat Video 8  
   4.4 Render the clip 9  

5 Filtration process details 10  
   5.1 Stage I. Add the Reduce Noise effect 10  
   5.2 Stage II. Select a frame for noise analysis 10  
   5.3 Stage III. Open Neat Video plug-in window 10  
   5.4 Stage IV. Check input frame 11  
   5.5 Stage V. Prepare a device noise profile 11  
   5.6 Stage VI. Adjust filter settings 14  
   5.7 Stage VI (a). Beginner Mode 15  
   5.8 Stage VI (b). Advanced Mode 18  
   5.9 Stage VII. Save and apply 29  
   5.10 Stage VIII. Render the clip 30  

6 Additional tools 31  
   6.1 Variants of filtration 31  
   6.2 Skip Neat Video processing 32  
   6.3 Alternative modes of image viewer 32  

7 Device noise profiles 33  
   7.1 Building a profile for a device mode (standard profiling procedure) 33  
   7.2 Using noise profiles 39  

8 Preferences 40  
   8.1 General preferences 40  
   8.2 Defaults 41  
   8.3 Profiling preferences 41  
   8.4 Performance preferences 42  
   8.5 Folders preferences 43  

9 Examples 44  
   9.1 Building a noise profile 44  
   9.2 Filtration results 45  

10 Questions and answers 46  
   10.1 General questions 46  
   10.2 Filtration-related questions 46  

11 Information 48  
   11.1 Issues and bugs 48  
   11.2 Plans 48  
   11.3 Detailed feature map 48  
   11.4 Contacts 48  
   11.5 Legal information 49  
   11.6 Registration 50  
   11.7 Acknowledgments 51  

Index 52
1. Introduction

1.1. Overview

Neat Video is a filter designed to reduce noise and grain in digital video.

Neat Video detects, analyzes and reduces noise. The quality of noise reduction provided by Neat Video is higher than that of other methods because Neat Video incorporates the most advanced noise reduction algorithms in the industry and takes into account specific characteristics of particular video capturing devices – video camera, camcorder, computer TV-tuner, etc., – making the filtration customized and more accurate.

In addition, Neat Video can make video look sharper without any degradation of quality. The combination of the sharpening and noise filter makes such effect possible.

Neat Video plug-in for Final Cut (Mac) is available in three editions: Demo, Home, Pro.

- Demo plug-in is a free edition of the software with limited functionality
- Home plug-in works with up to 1920x1080 pixel large frames; for non-commercial use only
- Pro plug-in has no frame size limitations

1.2. Features

**Noise Reduction and Smart Sharpening**

- **Advanced noise filters** to reduce noise and grain in digital footage
  - **Temporal filter** to reduce noise, dust, scratches, etc. using data from consecutive frames
  - **Spatial filter** to further reduce noise and artifacts within each single frame
- **Complete control** over the noise filter to achieve the desired level of noise reduction
- **Smart sharpening filter** to make video look sharper without amplification of noise
- **High-bitdepth rendering** to fully support professional applications
- **CUDA and OpenCL acceleration** to speed up processing using computation-capable GPUs

**Device Noise Profiles**

- **Custom noise profiles** to make noise reduction device-specific and more accurate
- **Auto Profile function** to build noise profiles for custom video-capturing devices

Some features are only available in the Home or Pro plug-in. [Detailed feature map](page 48) explains the differences between Neat Video Demo, Home and Pro plug-ins in details.

1.3. Requirements

Recommended system configuration is:

- Intel i7 / i5 / Xeon; single or multi-processor
- Mac OS X 10.7.5 or newer

Optional CUDA acceleration (64-bit applications only) requires:

- NVIDIA GPU with CUDA compute capability 2.0 or higher;
• CUDA driver for MAC version 6.5.46 or newer installed.

If you experince a problem with the latest version of the driver, please check the known issues page for possible solutions:
https://www.neatvideo.com/support/known-issues

You can download the latest and archive versions of the video drivers from http://www.nvidia.com/object/mac-driver-archive.html.

Optional OpenCL acceleration (64-bit applications only) requires:
• Mac OS X 10.7.5 or newer
• Supported video card:
  ■ ATI Radeon HD 5770/5870;
  ■ AMD Radeon HD 6750M/6770M/6970M;
  ■ AMD Radeon HD 7950;
  ■ AMD FirePro D300/D500/D700;
  ■ AMD Radeon R9 270X/280X/290X;
  ■ AMD Radeon R9 M290/M290X/M295X;
  ■ AMD Radeon R9 M370X/M380/M390/M395/M395X;
  ■ AMD Radeon Pro 450/455/460;
  ■ AMD Radeon Pro 555/560/570/575/580;
  ■ some other models of AMD/ATI cards (contact support or try Demo to verify).

System requirements for practical use of Neat Video depend on frame size and length of video. Processing larger frames and longer clips takes proportionally more time than smaller and shorter ones. The processing speed is determined primarily by the processor speed, GPU speed and memory speed.

The Neat Video plug-in can process any RGB video clip supported by Final Cut (or Motion).

Neat Video v4 plug-in for Final Cut (Mac) is compatible with the following hosts:
• Final Cut Pro X / 7 / 6
• Motion 5 / 4 / 3
• Final Cut Express 4

The plug-in may be compatible with other hosts as well.
2. Key concepts

Neat Video is a digital video filter. Its main function is to reduce noise in digital video.

Neat Video can work with video clips produced by any video recording devices – video cameras, camcorders, computer TV-tuners, film digitizers, etc. The software can be adjusted to a particular device by means of a device noise profile, which describes the noise characteristics of the device working in a certain mode.

A device noise profile is built by analyzing those areas of a video frame that contain no visible or important details. Usually, Neat Video can find such featureless areas completely automatically. In a difficult case, you can assist it and select a featureless area manually. Finding such areas is very easy for human eyes but may sometimes be a bit difficult for software.

By analyzing featureless areas in a frame, Neat Video’s noise analyzer builds a profile which describes the noise in these areas. With this profile, Neat Video can efficiently reduce noise in the frame and in the whole video clip.

The noise filter processes video data in several spatial frequency ranges. This makes possible reducing noise in one frequency range even if details are present in other ranges. The filter can also selectively process any of the color channels.

Besides spatial filtration, Neat Video also applies temporal (inter-frame) filtration to video data. Neat Video uses several consecutive frames to better reduce noise and preserve more true details in each frame. This improves the overall quality of noise reduction.

Neat Video also offers specialized tools to deal with dust, scratches, artifacts, damages to details caused by in-camera noise reduction and sharpening, repeated frames, etc.

In addition to that, Neat Video includes a smart sharpening filter, which only sharpens important details without increasing the level of noise. This filter also uses the noise profile to tell noise from details, so applying the noise and sharpening filters together saves time and produces better overall results.
3. Installing the plug-in

To install the Neat Video v4 plug-in for Final Cut (Mac)

1. Make sure you have started Final Cut at least once before installing the plug-in. If you have not done it yet, start Final Cut and select Quit from Final Cut’s menu;
2. Close Final Cut;
3. Download the DMG install package that matches your version of Final Cut;
   - if you already purchased the product and have a current license for the Home or Pro plug-in, please use the download instruction supplied with the license to download the corresponding plug-in from the download area specified in that instruction;
   - if you want to try Neat Video before purchase please download the installer of the Demo version from this page: https://www.neatvideo.com/download
4. Double-click the downloaded file to mount the DMG volume;
5. In the mounted volume, double-click NeatVideoFC.Intel.pkg to start the installer;
6. Follow the steps of the installer wizard to complete the installation process;
   (you may be prompted to enter the Name / Password of the OSX administrator account);
7. Start Final Cut and find the plug-in:
   FCP 7/6: in the Effects > Video Filters > Neat Video > Reduce Noise v4…
   FCP X: in the panel Effects > Neat Video > Reduce Noise v4
   Motion: in the panel Library > Filters > Neat Video > Reduce Noise v4.

If Neat Video has not become available in Final Cut, please contact Neat Video support for assistance.
4. Running Neat Video on a sample video clip

There is a test-kit prepared to help you start using Neat Video. You can download the test-kit via this direct link: https://www.neatvideo.com/project/resources/testkit.zip (MPEG1 readable by FCP 7/6) or via https://www.neatvideo.com/project/resources/testkit-mp4.zip (MPEG4; readable by FCP X).

Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mpg (SampleClip.mp4). This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start Final Cut, create a new project and go through the stages below to clean the clip:

4.1. Add the sample clip to the project

1. Adjust the settings of a new sequence in the project (FCP 7/6) or of a new project (FCP X)
   
   - In FCP 7/6: Use the Sequence > Settings... menu item to open the Sequence Settings dialog. Select the HDV/HDTV 1080p 25 preset or manually set: Frame Size: 1080p25 pixels; Editing Timebase: 25 fps; Pixel Aspect Ratio: Square; Field Dominance: None. Then press OK to apply.
   
   - In FCP X: In the Browser window select target project and then in the Inspector window on the Info tab press Modify Settings button to open Project Settings dialog. Select Format: 1080p; Resolution: 1920x1080 pixels; Rate: 25p. Then press OK to apply.

2. Add the sample clip file to the project / event

   - In FCP 7/6: Use the File > Import > Files... menu in Final Cut to import the SampleClip.mpg file into the project.
   
   - In FCP X: Use the File > Import > Media... menu in Final Cut Pro X to import SampleClip.mp4 file into the target event.

3. Add the sample clip to the sequence / timeline

   - In FCP 7/6: Select the sample clip in the project panel in the Browser window and drag-n-drop the clip into the sequence in the Timeline window.
   
   - In FCP X: Select the sample clip in the target event in the Browser window and drag-n-drop the clip into the Timeline of the target project.

You will then see that there is noise in the sample clip (see the clip preview in the Canvas window). The task of Neat Video is to reduce this noise.

4.2. Add Neat Video effect

   - 1. Select the sample clip in the Timeline window (double-click the clip there);
   
   - 2. In FCP 7/6: use the Effects > Video Filters > Neat Video > Reduce Noise v4... menu item in FCP X: use the panel Effects > Neat Video > Reduce Noise v4 to add the Neat Video effect to the clip;
   
   - 3. Open the Filters panel in the Viewer window in Final Cut (in FCP X: go to Inspector > Video > Effects) to see all filters added to the clip. You will see that Reduce Noise v4 has been added there.
4.3. Configure Neat Video

1. Open Neat Video plug-in window

   - In the clip in the Timeline window, select a frame with large flat featureless areas; the selected frame will be used for noise analysis in the next stages.
   - Open the Neat Video plug-in window using the Options... button in the Reduce Noise v4 section in the Filters or Effects panel (in FCP X: use the Options window popup menu);
     (If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further.)

   The Neat Video plug-in window will open and display the current frame from the clip.

2. Build a noise profile for the clip

   To reduce noise in this frame and in the whole clip, Neat Video generally needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

   - In the Device Noise Profile tab click Auto Profile.

   The Auto Profile function will find and select an area for main analysis. Neat Video will then automatically analyze the noise in that area to build a new noise profile.

   Neat Video is then ready to filter the sample clip.

3. Check preview

   - Switch to the Noise Filter Settings tab.

   You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

   You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame.

4. Apply the changes

   - Click Apply in the bottom of the plug-in window.

   Neat Video will save the current settings and close its main window.
   (If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point.)
4.4. Render the clip

Use Final Cut controls to render the clip (for example, in FCP 7/6 the menu Sequence > Render Selection > Both or in FCP X the menu Modify > Render All).

Final Cut will then apply Neat Video noise reduction to the whole sample clip to help you evaluate the filtration results (and adjust the filter settings if necessary). You will see that the noise in the resulting clip is significantly reduced while the true details are preserved.

You can also find that the resulting noise-free clip can be compressed better (the file size is smaller) than the original noisy clip (this depends on Final Cut’s compression settings).

The next sections – Filtration process details, page 10, and Device noise profiles, page 33, – describe the Neat Video workflow and filter settings in more details.
5. Filtration process details

This section explains in more details how to apply the Neat Video noise reduction to a video clip included in a Final Cut project.

5.1. Stage I. Add the Reduce Noise effect

To add the Neat Video noise reduction to a video clip in a Final Cut project:

1. In the Timeline window, select a clip to be filtered.
2. Select the Effects > Video Filters > Neat Video > Reduce Noise v4... menu item or use the Effects tab (drag and drop the Neat Video > Reduce Noise v4... effect to the clip)

5.2. Stage II. Select a frame for noise analysis

Neat Video filter uses a frame (or a field\(^1\)) from the video clip to analyze noise and build a noise profile necessary to reduce noise in the clip. This frame should include flat featureless areas that contain no visible details, but do contain noise. To build a noise profile you need to manually find such a frame in the video clip using the Final Cut controls. If there are many frames that contain flat featureless areas then select one with larger and most noisy flat featureless areas without visible details.

In the clip in the Timeline window, select a frame with large flat featureless areas; the selected frame will be used for noise analysis in the next stages.

5.3. Stage III. Open Neat Video plug-in window

Click the Options... button in the Reduce Noise v4 section in the Filters or Effects panel (in FCP X: use the Options window popup menu);

(If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further.)

The Neat Video plug-in window will open and show the selected frame (for progressive video) or one field (upper or lower; for interlaced video) from it. This frame or field will be used to build a noise profile necessary to filter the whole clip.

\(^1\) The term “frame” will be used to refer to either a frame (in progressive video) or a field (in interlaced video).
5.4. Stage IV. Check input frame

**Viewer controls**

To inspect the content of the frame (this will be used a lot in the next sections) you can use the controls and shortcuts described below.

- **To change zoom level**
  - use the mouse wheel when the mouse pointer is over the viewer;
  - use the zoom control under the viewer;
  - use theCmd-Plus, Cmd-Minus, Cmd-0, Cmd-Alt-0keyboard shortcuts.

- **To scroll and pan the frame**
  - press the spacebar and the left mouse button and then drag the frame using the mouse;
  - press the middle mouse button and then drag the frame using the mouse.

5.5. Stage V. Prepare a device noise profile

To filter the noise in the clip, Neat Video needs to know the characteristics of noise produced by the input device (video camera, TV-tuner, etc.) the video comes from. The noise characteristics of a device working in a certain mode constitute a **device noise profile**.

There are two ways to prepare a device noise profile for the clip:

- To build a new profile using a suitable frame from the clip;
- To select a suitable profile from a pre-built set of profiles (when you already have such a set).

The first option is often the easiest one provided the selected frame contains sufficiently-large uniform featureless areas that include noise and no visible or important details. Neat Video can try to automatically find such areas in the frame and analyze noise in them to build a noise profile. When the selected frame contains featureless areas suitable for analysis, this way of preparing a noise profile is the most accurate and therefore recommended.

The second option is available once you have already built and saved several profiles for various modes of your video capturing device. You can then re-load the profile corresponding to the current clip (the current clip must show the same noise as that used to build that profile) and use it to process the clip.

**To build a new profile using the selected frame from the clip**

- **Make sure you use the Device Noise Profile tab:**

- **Click** (the **Auto Profile** button).

  **Auto Profile** function will find and select an area for main analysis. Neat Video will then automatically analyze the noise in that area (and then in the whole frame too; however, the most important part of the analysis is the area highlighted by the selection) to build a new noise profile.
In difficult cases, Neat Video may be not able to find a large enough uniform featureless area in the frame. You will then notice that the area selected by Auto Profile, for example, contains some details, not just noise. In such cases, Neat Video also warns you that the area is not very suitable for analysis. It may say that the selected area is not uniform in one or more channels, or is too small, or contains clipping in one or more channels.

One way to address that is to manually move the selection (or resize, or draw a new one) to an area that does not contain any visible details and then click the same Auto Profile button again. To find the most suitable area, use the Assist mode of the image viewer to better see weak details that may be present in the candidate image areas. The Assist mode emphasizes the weak details present in Luminance (Y), Cr, Cb channels, as shown in the example below:

The top image shows the original frame where details around the sun are barely visible, while the channels in the bottom part display the image data in such a way as to emphasize those weak details. That helps to visually verify that the selected area contains no useful details, which is very important for accurate noise analysis.

Alternatively, you can just ignore those warnings about possible non-uniformity, clipping or size of the area, but the quality of the resulting noise profile may be lower than it could in principle be with that frame. The filter will still work though.

After the profile is built, check the Quality indicator in the Device Noise Profile box. A profile built using a uniform and featureless area will usually show a high value in this indicator. If the profile quality is high (for example, higher than 60%), then you can be sure that the noise profile is accurate. In this case, proceed to Stage VI. Adjust filter settings, page 14.

If the quality is not high or you clearly see that the area used for analysis contains some details, try to find another uniform and featureless area and click Auto Profile again. It is usually best to select
the most noisy area for analysis. That may not help still, especially if the selected frame contains only small featureless areas. Then consider using another frame from the same clip. You may be able to find a better frame for analysis in the set of adjacent frames shown in the thumbnails under the viewer. Click one of those thumbnails to select the corresponding frame.

The newly selected frame is then displayed in the main viewer where it can be used to build a noise profile and/or to check the preview.

If there is no suitable frame among the adjacent ones, try to find a better frame in another part of the clip. To do that you need to close the Neat Video plug-in window and return to Stage II. Select a frame for noise analysis, page 10.

You can also try to build a profile in manual mode. However, this will anyway require some featureless areas to be available for analysis. You can find more details on automatic and manual profiling in the Device noise profiles section, page 33.

To select a noise profile from your pre-built profile set

If you have already built some noise profiles earlier and saved them to the disk, you can re-load one of them to use with the current clip. You need to make sure you select the right noise profile from the set of profiles: it should be for the same noise as that present in the current clip. If the current clip and clip used to build that profile were produced by the same camera working in the same shooting mode, then the noise in both clips was most likely the same.

- Click (the Load Profile button). Then select a profile in the Open Device Noise Profile dialog.

or

- Click (the drop-down button) in the Device Noise Profile box to open the popup menu showing all profiles (currently available in Neat Video’s Profile folder) and then select one of the available profiles.

Please note that you have either to pre-build your own profiles or download some pre-built profiles and place them to the Profile folder to make this drop-down button and popup menu truly work.

By default, the Profile folder is located in your Documents folder:

/Users/<username>/Documents/Neat Video v4 for Final Cut/Profiles/

If you build or download some pre-built profiles, save them to that folder and Neat Video will show those profiles in the popup menu to help you quickly load any of them.

To select a noise profile from generic Neat Video profile set

There may be some cases when frames of the clip you are working on have no featureless areas suitable for building a noise profile, no pre-built profiles available for particular device and noise characteristics. For such cases Neat Video has a set of generic pre-built noise profiles that can provide a solution when other options are not available. Of course it is better to use the regular solution (Auto Profile) when that is possible, because that delivers the most accurate results.

- To use one of the generic profiles click (the Load Profile button). Then select a profile from the Generic Profiles folder.

or

- Click (the drop-down button) in the Device Noise Profile box to open the popup menu showing all profiles (currently available in Neat Video’s Profile folder), click on Generic Profiles and select one of the available profiles.

By default, Generic Profiles are located in your Documents folder:

/Users/<username>/Documents/Neat Video v4 for Final Cut/Profiles/Generic Profiles/

There are seven profiles available in the Generic Profiles folder: Generic-1 (weak noise), Generic-2 (weak noise), Generic-3 (medium noise) . . . . . . . . . and Generic-7 (strong noise). They have been ranked

¹ You can check and adjust the location of that folder in the menu: Tools > Preferences > Folders > Profile folder

25-Aug-2017 Neat Video © 1999-2017 Neat Video team, ABSoft. All rights reserved. 13
according to the noise level they have been designed to deal with. *Generic-1 (weak noise)* noise profile designed to work with video clips that do not have much noise, while *Generic-7 (strong noise)* noise profile has been created for very noisy videos.

Try different generic profiles to find one that delivers the best results in preview in the **Noise Filter Settings** tab:

**To additionally fine-tune the loaded profile**

You may want to additionally fine-tune the pre-built profile you have just loaded. Fine-tuning the profile in such a situation usually makes it more accurate and better matching the noise in the current clip.

- Click **Auto Fine-Tune** (the *Auto Fine-Tune* button) to fine-tune the loaded profile to the current clip.

  There is no need to select any area in the frame because the *Auto Fine-Tune* automatically analyzes the whole frame.

  Please note that you do not need to fine-tune a profile if you have just built it using *Auto Profile*. *Auto Profile* automatically applies fine-tuning so you do not need to repeat it.

**5.6. Stage VI. Adjust filter settings**

- Make sure you use the **Noise Filter Settings** tab:

  The Neat Video filters have several adjustable settings. The default settings usually produce good filtration results (provided the noise profile is accurate). You may want to additionally vary the settings to achieve the filtration results that look best to your eyes.

**5.6.1. Use preview when adjusting filter settings**

The viewer in the **Noise Filter Settings** tab shows a part or whole frame processed by the filters currently enabled in Neat Video. When you change any filter settings, the preview is automatically updated. You can zoom in and out, drag, scroll and pan the frame in the viewer to see how the Neat Video processing affects different parts of the frame. If you manually select an area in the frame, then only the selected area will be processed for preview.

When the preview is ready (the preview area shows "Filtered" in the top right corner), you can click inside the preview area to temporarily switch back to the original frame for comparison.

You can also select one of the adjacent frames from the same clip to see how it is processed by the filter. To do that click one of the available thumbnails shown under the viewer.

The selected frame (highlighted with a blue border) will then be displayed in the main viewer.

The orange border highlights the thumbnails of adjacent frames used by the temporal filter.
5.6.2. Beginner Mode and Advanced Mode

Neat Video has two sets of controls available in Beginner Mode and Advanced Mode. You can select the mode using the Tools > Beginner Mode and Advanced Mode menu items or using the dedicated Beginner Mode / Advanced Mode menu in the top right corner of the plug-in’s window.

The Beginner Mode provides a simple control set recommended for beginners who have just started using Neat Video. The Advanced Mode provides the most complete control set with maximum manual control over the noise profiling and filtration processes. The Advanced Mode is recommended for power users.

Adjusting filter settings in Beginner Mode and Advanced Mode is described below in two separate sub-sections.

For the Beginner Mode please follow the sub-section Stage VI (a). Beginner Mode below.

If you want to use the most complete control set in Advanced Mode then please instead follow the sub-section Stage VI (b). Advanced Mode, page 18.

5.7. Stage VI (a). Beginner Mode

5.7.1. Beginner Mode: Temporal filter settings

Neat Video can apply both temporal and spatial noise reduction to video data. Neat Video’s temporal filter uses information from several consecutive frames to reduce noise and better preserve details in each frame. In this sub-section, the available settings of the temporal filter are described.

You can adjust the temporal filter using the controls in the Temporal tab in the Filter Settings panel.

Temporal Filter

In Beginner Mode, the temporal noise reduction filter itself has one main setting: Radius.

The Radius setting determines the number of consecutive frames used for temporal filtration. Higher values of this setting lead to stronger (but somewhat slower) temporal filtration based on a larger number of consecutive frames. Lower values lead to weaker (but faster) filtration. The default value of Radius is 2, which means five consecutive frames (the current one, two frames before and two frames after the current one) are used for temporal filtration.

Use the Temporal Filter > Radius control in the Temporal tab.

Dust and Scratches

Neat Video also includes a dedicated sub-section - Dust and Scratches - of the temporal filter that reduces or fully removes certain defects of analog nature introduced into video data before or during its conversion to the digital representation.

The Dust and Scratches filter reduces such defects as:

• corrupted scan lines: a whole scan line of a video frame is incorrect;
• random short lines affecting only a small part of a scan line;
• spots, dots, lines of relatively large size.

In the example images on the right, the areas containing such defects are marked by blue boxes.
These defects are usually caused by:

- inaccurate recording/playing back of VHS materials;
- damaged VHS film;
- interference in analog TV transmission;
- physical dust and scratches present in original video film.

The common property of these defects is that each particular defect element is present in a single frame rather than in a series of frames. This allows Neat Video to use information from adjacent frames to eliminate the defects present in the current frame.

For accurate reduction of such defects by the Dust and Scratches filter, make sure you do not include these defects into an analysis area during profiling (visually inspect the area selected by Auto Profile to ensure that). If you include these defects into an analysis area, then the regular noise reduction may become less accurate. The best profiling approach is to include only regular random noise in the sample area used by Auto Profile for analysis.

² Use the Temporal Filter > Dust and Scratches > Enable checkbox to enable or disable that filter.

Use preview

While adjusting the settings, use the available preview facilities to evaluate the corresponding changes in the results of Neat Video filtration:

- Click inside the preview area to temporarily switch back to the original frame for comparison;
- Move from one frame to another (using the thumbnails available in the bottom of Neat Video window) to see how the Neat Video processing affects the adjacent frames;
- Create several alternative variants of filtration, compare results and select the best variant. For more details please see the Variants of filtration section, page 31.

5.7.2. Beginner Mode: Spatial filter settings

In addition to temporal noise reduction, Neat Video can also apply its spatial filter to further reduce the remaining noise (if necessary). While the temporal filter uses data from several consecutive frames, the spatial filter works within one frame only.

In this sub-section, the available settings of the spatial filter are described. To adjust the spatial filter settings please switch to the Spatial tab in the Filter Settings panel.

Spatial Filter

The spatial filter itself has two main settings when working in Beginner Mode: Noise Level and Noise Reduction Amount.

The Noise Level setting is a threshold determining which image elements are considered noise and which elements are considered true details. The Noise Reduction Amount setting determines how much reduction is applied to the elements identified as noise.

² Use the Noise Reduction Amount: Luminance control

to adjust the amount of noise reduction applied to the noise in the luminance component of the video data.

This control is the most important and most frequently adjusted setting of the spatial filter. The higher this setting, the more of the detected noise is removed in the luminance component. Be careful,
setting the noise reduction amount too high may lead to loss of fine details and unnaturally looking
(over-smooth, plastic-like) results. Too low amounts may be not enough to sufficiently reduce the
objectionable part of the noise. The default value of 40% usually provides a good balance between
noise removal and preserving natural (not over-processed) appearance of filtered footage. Try to adjust
the setting to get the result that looks best to your eyes.

- Use the **Noise Level** control to adjust the setting *(only when necessary).*

Please note that if the noise profile is accurate,¹ then it is **not necessary** to adjust this setting. However,
if the noise profile is not accurate, then the noise filter may need an adjusted estimation of the actual
noise level to be able to deliver good results. By adjusting the **Noise Level** setting, you provide the
filter with such an adjusted estimation. Use the preview to visually guide yourself when making such
adjustments. The right adjustment will leave no noise elements in the image yet will not destroy the
actual details.

**Sharpening (optional)**

The sharpening filter in Neat Video increases sharpness of the details in the video clip without increasing
the noise strength.

The sharpening filter is disabled by default. You can enable it and adjust the sharpening amounts separately
for three typical scales of details: fine, medium-sized and large.

Like any sharpening method, try to balance the sharpening amounts to avoid over-sharpening.

- Use the **Sharpening: Fine, Medium and Large** sliders
to adjust the amount of sharpening applied to the details
of the corresponding sizes.

It is best to start with adjusting the **Fine** sharpening
amount. If sharpening the fine details alone is not
sufficient to make the image look sharp, then try to increase the **Medium** and **Large** settings too.

**Use preview**

While adjusting the filter settings, use the available preview facilities to evaluate the corresponding
changes in the results of Neat Video noise reduction and sharpening.

5.7.3. Beginner Mode: Optimize performance settings (optional)

Before applying the filter to the clip, you may want to check the speed of Neat Video on that clip and
potentially improve the speed by optimizing the performance settings. The processing speed often
depends on the filter settings: enabling more filters and their sub-sections makes processing slower
because Neat Video has to do more work. Also, if you significantly change the filter settings, then
the optimal performance settings (for example, the number of CPU cores and/or GPUs used for processing)
may change as well, so it may be useful to optimize those settings before starting a long render. This is
entirely optional but in some cases, the optimization may appreciably reduce the render time.

To check the current speed and to optimize the performance settings switch to the **General** tab in the
**Filter Settings** box.

¹ Use the **Quality** indicator in the **Device Noise Profile** box (in the **Device Noise Profile** tab) to estimate the accuracy of the profile.
The indicator shows how accurate and complete is the noise analysis itself. Higher values usually lead to more accurate noise reduction.
To measure the filter speed click on the bottom of the **General** tab.

Neat Video will run a speed test and will then display the measured processing speed based on the current filter settings and frame size (as shown in the box above in the same **General** tab).

Please note that it is the **speed of Neat Video alone**, without any other effects that may be used in your project and without any Final Cut processing overhead. The speed of the final render in Final Cut is going to be lower because of that overhead.

To optimize the performance settings click on to open the **Performance** tab in Neat Video **Preferences**. In that tab, you can inspect the available and current CPU and GPU settings.

Then use to open a specialized dialog designed to measure video processing speeds achieved with different combinations of the CPU and GPU settings. It allows to automatically benchmark all possible combinations of settings and to identify the best combination (for the current frame size and current filter settings). You can then just click on to apply the found optimal combination achieving the best performance.

Once you have completed this step, please proceed to the sub-section **Stage VII. Save and apply**, page 29.

Or if you want to switch to the **Advanced Mode** and adjust the filters using the most complete set of controls please proceed to the next sub-section dedicated to the **Advanced Mode**.

### 5.8. Stage VI (b). Advanced Mode

If you want to use the full set of filter settings offered by Neat Video, you can switch to **Advanced Mode** via the **Tools > Advanced Mode** menu item or the dedicated **Beginner Mode / Advanced Mode** menu in the top right corner of the plug-in’s window.

### 5.8.1. Advanced Mode: Temporal filter settings

Neat Video can apply both temporal and spatial noise reduction to video data. Neat Video’s temporal filter uses information from several consecutive frames to reduce noise and better preserve details.

You can adjust the temporal filter using the controls in the **Temporal** tab in the **Filter Settings** panel.
Temporal Filter: Quality Mode

The first setting available in the Temporal tab is the Quality Mode. This setting determines whether Neat Video’s temporal filter should work faster (but slightly less accurately) or slower (but somewhat more accurately).

By default, Quality Mode is set to Normal, which provides the best processing speed and good visual quality of results. There is also High (slower) mode, which can produce somewhat better results with more details being preserved at expense of longer processing time (could take about x2 longer to render).

- Use the Quality Mode control to select the preferred processing mode.

Temporal Filter: Radius

In Advanced Mode, the main setting of the temporal noise reduction filter is Radius. The Radius setting determines the number of consecutive frames used for temporal filtration. Higher values of this setting lead to stronger (but somewhat slower) temporal filtration. Lower values lead to weaker (but faster) filtration. The default value of Radius is 2, which means five consecutive frames (the current one, two frames before and two frames after the current one) are used for temporal filtration.

- Use the Temporal Filter > Radius control in the Temporal tab to adjust the setting.

Temporal Filter: Noise Level

If the noise profile is accurate, then the temporal filter of Neat Video will work well and will evenly reduce all detected noise elements.

However, if the noise profile does not correctly reflect the properties of the noise (for example, if it was built using a less noisy part of the frame) then the temporal filter may leave some noise particles untouched or not sufficiently reduced.

One way to avoid that is to re-build the noise profile using a more noisy area.

Another way is to adjust the value of the Temporal Filter > Advanced Settings > Noise Level parameter to compensate for the inaccuracy of the noise profile. This parameter allows to adjust the balance between sufficient noise reduction and preservation of details in such a way as to not leave any noise elements untouched. In particular, if the noise level of the video is underestimated (or overestimated) by the noise profile, then increasing (or decreasing) the Noise Level parameter from its default value of +0% to the optimum level improves the quality of temporal filtration: more noise gets reduced with more details preserved. However, setting the Noise Level to a very high value may blur moving objects, while setting it to a very low value makes the temporal filtration less effective which may cause a noticeable flicker in the output video.

1 Please note that some sections of Temporal Filter such as Dust and Scratches and Slow Shutter may require using higher values of Radius.
It may be generally difficult to find the optimum value of the **Noise Level** because the influence of that parameter on the preview may be masked by other filters of Neat Video. To cope with that Neat Video includes a dedicated tool – **Temporal Filter > Advanced Settings > Noise Level Tuning Assist** – designed to simplify the adjustment process. If the **Noise Level Tuning Assist** tool is used, the filters are temporarily reconfigured in such a way as to emphasize the influence of **Noise Level** adjustments using a special preview mode. That makes it easier to visually find the right balance based on the preview.

To use the **Noise Level Tuning Assist** tool please follow these steps:

1. Click the **Noise Level Tuning Assist > Begin** button to start the tuning process. The preview image may then look unnaturally plastic, but that is just a temporary effect that will go away once tuning is complete.

2. Adjust **Noise Level** while watching how the preview is changing. Move the slider to a position where no noticeable noise remains in the image (pay special attention to areas around edges of objects where noise may be more stubborn), but the fine details are still preserved. The goal of the tuning process is to find that balance point. If **Noise Level** needs to be set relatively high (for example, +50% or higher) to achieve that balance, then that may indicate that the noise profile is not accurate and needs to be fine-tuned or re-built completely.

   Please note that changing **Temporal Filter > Advanced Settings > Noise Level** (when **Noise Level Tuning Assist** tool is used) sets **Spatial Filter > Noise Level** in the **Spatial** tab to the same value. This is done for convenience: both parameters usually need to be changed to compensate for the inaccuracy of the noise profile.

3. Click the **Noise Level Tuning Assist > Finish** button to complete the tuning process. Please note that some noise will return to the preview image after that. This is normal. The amount of noise reduction can be adjusted using other filter settings if required.

Once the tuning is completed and the right value of **Noise Level** is found, the temporal filter will work more accurately.

**Temporal Filter: Amount**

The **Amount** setting determines how much reduction is applied by the temporal filter to the elements identified as noise.

- Use the **Temporal Filter > Advanced Settings > Amount** control in the **Temporal** tab. Amount can be in the range from 0% (none of the detected noise is removed) to 100% (all the detected noise is reduced). By default, the noise filter reduces 100% of the detected noise. This should only be adjusted if noise reduction is too strong (the resulting image is too smooth) for the selected value of **Radius**. Another way to make noise reduction less aggressive could be to reduce **Radius** itself.
Dust and Scratches (optional)

Neat Video also includes a dedicated sub-section – Dust and Scratches – of the temporal filter that reduces or fully removes certain defects of analog nature introduced into video data before or during its conversion to digital representation.

The Dust and Scratches filter is designed to reduce such defects as:

- corrupted scan lines: a whole scan line of a video frame is incorrect;
- random short lines affecting only a small part of a scan line;
- spots, dots, lines of relatively large size.

In the example images on the right, the areas containing such defects are marked by blue boxes.

These defects are usually caused by:

- inaccurate recording/playing back of VHS materials;
- damaged VHS film;
- interference in analog TV transmission;
- physical dust and scratches present in original video film.

The common property of these defects is that each particular defect element is present in a single frame rather than in a series of frames. This allows Neat Video to use the data from adjacent frames to eliminate the defects present in the current frame.

For accurate reduction of such defects by the Dust and Scratches filter, make sure you do not include the defects into an analysis area during profiling (visually inspect the area selected by Auto Profile to ensure that). If you include the defects into an analysis area, then the regular noise reduction may become less accurate. The best profiling approach is to include only regular random noise in the sample area and exclude any scratches and dust particles.

In Advanced Mode, Neat Video offers the following settings in the Dust and Scratches filter:

- Use the Mode selector to choose between the Normal and Aggressive modes of the filter. Identification and reduction of dust and scratches is more exhaustive (and somewhat slower) in the Aggressive mode.

- Use the Threshold control to adjust the threshold of the filter. Higher values of the threshold lead to more aggressive filtration with less attention to actual details; lower values lead to less aggressive filtration better preserving details.

- Use the Amount control to adjust how much reduction is applied to the elements identified as dust and scratches.
Slow Shutter (optional)

Neat Video offers special support for clips with repeated frames. Repeated frames are present, for example, in clips produced by certain models of video cameras working in “slow shutter” or “night” mode. In such clips, some of the frames are repeated two or more times. The repeated frames are exact or almost exact copies, and that requires special treatment in Neat Video.1

There can be different reasons why repeated frames may be present in clips:

- a camera working in “slow shutter” or “night” mode;
- re-encoding a “normal” clip into a new clip with a higher frame rate;
- in-camera noise reduction used in some cameras can make the noise being repeated while the useful content of the frames changes normally.

Repeated frames complicate the job of the noise filter because such frames do not carry additional information needed for noise reduction yet still require processing and potentially confuse the filter.

Repeated frames also slow down the apparent speed of the clip, which means its effective frame rate is lowered by their presence.

Neat Video has a dedicated Slow Shutter mode to work with such clips. When you know that a specific clip contains repeated frames2 you can enable the Slow Shutter section in the Temporal tab to engage that mode:

- Use the Enable checkbox to enable or disable the Slow Shutter mode.

Neat Video will try to estimate the amount of repeated frames in the clip and will display the estimated effective frame rate. This estimation may not be entirely precise so it is best to check the frames directly to verify that estimation.

- Use the Mode selector to choose between Manual (default) and Adaptive processing modes.
  
  In Manual mode, you can directly specify the effective frame rate, which is useful when you know the exact amount of unique and repeated frames in advance.

- Use the thumbnails in the bottom of Neat Video window to check the percentage of unique frames, estimate the effective frame rate and specify it using the (effective) Frame Rate control.

Some typical values are:

- 100% - all frames are unique (then you do not need to enable the Slow Shutter mode at all);
- 80% - each 5th frame repeats the preceding 4th frame (so 20% of all frames are repeated);
- 50% - every odd frame repeats the preceding even frame (a half of all frames are repeated);
- 33% - every second and third frames repeat the preceding first frame.

1 Please note when those repeated frames are exact copies, Neat Video can resolve the situation on its own and does not require using the Slow Shutter mode described in this sub-section. You only need to use this option when those copies are not exact. Neat Video helps to differentiate these two cases (more details below).

2 If you do not know whether the clip contains repeated frames, you can check that using, for example, the thumbnails in the bottom of Neat Video window: try to move from one frame to the next one several times. If you see that the frame content is actually changing (in the main preview area of Neat Video window) every time you are making a step, then the clip is likely normal, it has no repeating frames. However, if you see that the frame content (the whole content or just the noise component) is sometimes remaining static when you are making a step, that most likely indicates that some frames are in fact repeated in the clip.

Neat Video tries to automatically detect repeated frames that are exact or almost exact copies in the stream of frames and marks them accordingly. The detected exact copies are marked with the white "Copy" label in the corresponding thumbnails. The almost exact copies are marked with the yellow "Rep" label. Only "Rep" frames require using the Slow Shutter mode in Neat Video. Please note that this automatic detection may not work with all clips, so the visual inspection using the thumbnails and full resolution preview remains the most reliable test method.

You can also use the Slow Shutter Tuning Assist function to check if the clip contains any repeated frames.
In **Adaptive** mode, Neat Video will try to detect repeated frames on its own and will update its estimation during rendering. That may be useful when the percentage of repeated frames changes along the timeline, from one scene to another. This detection may not be entirely precise so it is best to use the **Manual** mode whenever applicable.

When working with clips that contain repeated frames ("Copy" or "Rep"), we also generally recommend to increase the **Temporal Filter > Radius** to let the temporal filter gather enough information to accurately reduce noise and preserve actual details.

You can also use the **Slow Shutter Tuning Assist** tool for easier tuning of **Slow Shutter** mode settings. This function will temporarily adjust the filter in such a way as to make the effect easier to see in preview: if repeated frames are present, all unfiltered parts of the current frame will become clearly visible in preview.

To use the **Slow Shutter Tuning Assist** tool please follow these steps:

1. Click **Slow Shutter Tuning Assist > Begin** to start the tuning process.
   
   The preview image may then look unnaturally plastic, but that is just a temporary effect that will go away once tuning is complete.

2. Make sure **Mode** is set to **Manual**.

3. Start with the **Frame Rate** of 100% and, if the noise is noticeable in preview, gradually reduce the **Frame Rate** until the noise disappears completely, while details are still preserved. You might need to increase **Radius** if a warning message is displayed under the **Frame Rate** control.
   
   If no noise is visible at the **Frame Rate** of 100%, it is likely that the video does not contain repeated frames and thus the **Slow Shutter** mode needs to be disabled.

4. Click **Slow Shutter Tuning Assist > Finish** button to complete the tuning process.
   
   Please note that some noise will return to the preview image after that. This is normal. The amount of noise reduction can be adjusted using other filter settings if required.

**Adapt to Changing Noise (optional)**

The noise properties of the video data may slightly vary in different parts of the clip, for example if the lighting conditions change during shooting. Neat Video can automatically adjust its processing to the changing noise.

Enable the **Adapt to Changing Noise** option to let Neat Video automatically adjust its processing to the temporal changes in the clip’s noise.

Please note that if the noise is not changing its properties in different parts of the clip, then this option should better be left disabled. Use it only when it is actually needed.

**Use preview**

While adjusting the settings, use the available preview facilities to evaluate the corresponding changes in the results of Neat Video filtration:

- Click inside the preview area to temporarily switch back to the original frame for comparison;
- Move from one frame to another (using the thumbnails available in the bottom of Neat Video window) to see how the noise reduction affects adjacent frames;
- Create several alternative variants of filtration, compare results and select the best variant. For more details please see the **Variants of filtration** section, page 31.
5.8.2. Advanced Mode: Spatial filter settings

In addition to temporal processing, Neat Video can also apply spatial noise reduction to further reduce the remaining noise (if necessary). While the temporal filter uses information from several consecutive frames, the spatial filter works within one frame only.

To adjust the spatial filter settings please switch to the Spatial tab in the Filter Settings panel.

Spatial Filter: Quality Mode

The first setting available in the Spatial tab is the Quality Mode. This setting selects whether Neat Video’s spatial filter should generally work faster (but slightly less accurately) or slower (but somewhat more accurately).

By default, Quality Mode is set to Normal, which provides the best processing speed and good visual quality of results. There is also High (slower) mode, which can produce somewhat better results with more details being preserved at expense of longer processing time (could take about x2-x3 longer to render).

- Use the Quality Mode control to select the preferred processing mode.

Spatial Filter

In Advanced Mode, the main spatial filter has separate settings for all (spatial) frequency and channel components of the video data. There are pairs of noise level – noise reduction amount controls for each of these components. You have access to eight such pairs – three for channel components (Luminance, Cr, Cb) and five for spatial frequency components (High, Mid, Low, Very Low, Ultra Low) of the video data.

The meaning of each noise level – noise reduction amount pair is the following:

- a noise level control adjusts the threshold determining which elements of the corresponding video component are considered noise and which elements are considered true details;
- a noise reduction amount control determines how much reduction is applied to the elements identified as noise in that component.

Thus, with a noise level – noise reduction amount pair of settings you can adjust what should be considered noise in a component of the video data and how much of that noise should be reduced.

The noise level settings are relative to the noise levels of the current noise profile, which have been measured during profiling. Because the noise level controls are relative to the device noise profile, their default settings usually produce good results as long as the noise profile is accurate.²

¹ See “What is frequency” question in page 46.
² Use the Quality indicator in the Device Noise Profile box (in the Device Noise Profile tab) to estimate the accuracy of the profile. The indicator shows how accurate and complete is the noise profile itself. Higher values usually lead to more accurate noise reduction.
Noise Reduction Amount

Noise reduction amounts are the most frequently adjusted settings of the spatial filter.

- Use the Noise Reduction Amount > Luminance; and Noise Reduction Amount > Components > Cr, Cb; High, Mid, Low, Very Low, Ultra Low sliders.

You can vary the noise reduction amount for each frequency and channel component of the video data. The higher a certain noise reduction amount, the more of the detected noise is removed in the corresponding component.

Noise reduction amounts can be in the range from 0% (none of the detected noise is removed) to 100% (all the detected noise is removed). By default, the noise filter removes 100% of detected noise in most components except the Luminance channel where only 40% of the detected noise is removed.

Be careful, setting the noise reduction amounts too high, especially in the Luminance channel, may lead to loss of fine details and unnaturally looking (over-smooth, plastic-like) results. Too low amounts may be not enough to sufficiently reduce the objectionable part of the noise. Try to balance the noise reduction amounts (most importantly, the amount of noise reduction in the Luminance channel) to get the result that looks best to your eyes.

Decreasing the noise reduction amounts can have a positive effect if the video clip contains some natural noise. For example, when you filter a clip including asphalt, sand, or anything else that contains fine natural noise-like features, it may be helpful to reduce amounts down to 0-30%.

By default, the noise reduction amounts in the very low and ultra low frequency components are set to 0%, which effectively disables noise reduction in those components (you can always change the defaults if necessary²). If the clip contains strong very low and ultra low frequency noise (like large color blobs sometimes produced by compression), then you may want to enable the noise reduction in those components by increasing the Noise Reduction Amount > Very Low and Ultra Low settings.

It may also be useful to disable the sharpening filter when adjusting the spatial noise filter to make the influence of adjustments easier to see.

Filter Tuning Assist (optional)

Filter Tuning Assist is a special tool, which facilitates adjustment of other spatial filter settings by emphasizing the influence of those settings on image in preview. It is not necessary to use this tool, but it may help to speed up the adjustment process as a whole.

When you use Filter Tuning Assist, all noise reduction amounts are temporarily increased to a higher Amount value (the specific value of that special Amount can be set here as well). That makes it easier to see in preview the influence of such filter settings as Quality Mode, Noise Level, Artifact Removal and other filter settings available in Advanced Mode and described further in this section.

To use the Filter Tuning Assist tool please follow these steps:

- 1. Click Filter Tuning Assist > Begin to start the tuning process.
   The preview image may then look unnaturally plastic, but that is just a temporary effect that will go away once tuning is complete.

- 2. Adjust the highlighted filter settings so that no noise is visible in preview, but details are still preserved.

- 3. Click Filter Tuning Assist > Finish button to complete the tuning process.

² See more about that in the description of the Default Filter Preset setting in Neat Video Preferences, page 41.

25-Aug-2017 Neat Video © 1999-2017 Neat Video team, ABSoft. All rights reserved.
Please note that some noise will return to the preview image after that. This is normal. The amount of noise reduction can be adjusted using other filter settings if required.

**Noise Level (optional)**

*Usually it is not necessary* to change the noise levels if the noise profile is accurate. You only need to adjust the noise levels if you see that some noise elements are not reduced at all. Such incomplete reduction of noise elements is usually caused by an inaccurate noise profile providing inaccurate noise level estimations to the noise filter. This may be compensated by adjusting (increasing) the noise levels in the filter settings.

- Use the **Noise Level > Luminance, Cr, Cb; High, Mid, Low, Very Low, Ultra Low** sliders.

The noise filter is applied to five frequency components and three channel components of the video data. Corresponding sliders adjust the estimated noise levels for each of these components.

The higher a certain noise level, the more elements in the corresponding component are considered noise. Be careful, adjusting a noise level setting too high can lead to removal of true details. Adjusting a noise level setting too low can lead to incomplete filtration: residual noise and compression artifacts can stay in the filtered clip.

It may be helpful to enable **Filter Tuning Assist** when adjusting the **Noise Level** controls because then it is much easier to see if some noise elements are not reduced. If there are such elements that are not reduced, try to increase the corresponding **Noise Level** settings.

As a rule, if the device noise profile has been built properly, it is not necessary to increase the noise levels by more than 50%. If the clip contains strong surges of noise in the high frequency range, it is recommended to increase the high frequency noise level up to +20 to 40% and/or use the artifact filter (see below).

If the clip contains strong color noise, it is recommended to increase the Cr and Cb noise levels to +30%. In some cases, it may be useful to increase these noise levels up to +100%.

If adjusting noise levels still does not help and some noise elements remain in the filtered clip, probably the device noise profile is not good at all. Return to **Stage V. Prepare a device noise profile**, page 11, and additionally fine-tune the device noise profile or simply rebuild the profile from scratch.

**Artifact Removal (optional)**

Neat Video has an additional filter to remove residual dot-like and line-like noise elements that may remain in video even after applying Neat Video’s regular noise filters. Such residual noise elements / artifacts are typically created by in-camera noise reduction and compression or by other post-processing. Neat Video’s **Spatial Filter** can make those elements more visible if the noise levels are under-estimated during profiling.

You can see an example of such digital artifacts in the first picture on the right. The second picture shows the results of noise reduction with the **Artifact Removal** filter enabled.

Such artifacts are usually of digital nature. They are typically of very small size unlike the analog defects treated by the **Dust and Scratches** filter described earlier. Since these noise elements are different than the regular random noise, they require special treatment provided by the **Artifact Removal** filter.

You can adjust this filter using the following controls in the **Spatial > Artifact Removal** section:
Use the **Dots** control to adjust the dot removal threshold. Higher values lead to stronger reduction of dot-like artifacts (less attention to details); lower values lead to weaker reduction (more attention to details).

Use the **Lines** control to adjust the line removal threshold. Higher values lead to stronger reduction of line-like artifacts (less attention to details); lower values lead to weaker reduction (more attention to details).

The artifact filter additionally offers separate thresholds for three frequency components (in other words, for three typical size scales) in the **Frequencies** sub-section: high, mid, low.

Use the **High**, **Mid** and **Low** controls to adjust the artifact removal thresholds in the corresponding frequency components. Higher values lead to stronger reduction of artifacts (less attention to details); lower values lead to weaker reduction (more attention to details).

**Edge Smoothing (optional)**

This option of the noise filter makes smoother the edges of the objects in the video. This can be useful when edges are significantly degraded by the noise (or by the in-camera noise reduction and sharpening) and it is preferable to restore them.

Enable the **Edge Smoothing** section to enable this option in general.

Use the **High**, **Mid** and **Low** controls to adjust the strength of edge smoothing in the corresponding frequency components of the video. Higher values lead to stronger smoothing of edges; lower values lead to less smoothing.

**Sharpening (optional)**

The sharpening filter in Neat Video increases sharpness of the details in the video clip without increasing the noise strength.

The sharpening filter is disabled by default. You can enable it and adjust the sharpening amounts separately for three frequency components (for three typical size scales): **High**, **Mid**, **Low**.

Use the **Sharpening**: **High**, **Mid** and **Low** sliders to adjust the amount of sharpening applied to the details of the corresponding size.

0% will not sharpen the component at all. 100% is the normal and 250% is the maximum strength of sharpening in each component.

It is best to start with adjusting the **High** sharpening amount. If sharpening is not sufficient, try to increase the **Mid** and **Low** settings too.

Like any sharpening method, try to balance the amount of sharpening to avoid over-sharpening.

You can also adjust sharpening amounts separately for three channel components – **Luminance** and **Cr** / **Cb** (chrominance components):

Use the **Sharpening > Channels** > **Luminance**, **Cr** and **Cb** sliders to adjust the amount of sharpening applied to the corresponding channel components.

You can also select to sharpen in higher quality:

Use the **Sharpening > Prevent Over-Sharpening** option to use a higher-quality sharpening method, which tries to prevent over-sharpening and to avoid creating a halo around details.
Use preview

- While adjusting the filter settings, use the available preview facilities to evaluate the corresponding changes in the results of Neat Video noise reduction and sharpening.

5.8.3. Advanced Mode: Optimize performance (optional)

Before applying the filter to the clip, you may want to check the speed of Neat Video on that clip and potentially improve the speed by optimizing the performance settings. The processing speed often depends on the filter settings: enabling more filters and their sub-sections makes processing slower because Neat Video has to do more work. Also, if you significantly change the filter settings, then the optimal performance settings (for example, the number of CPU cores and/or GPUs used for processing) may change as well, so it may be useful to try optimizing those settings before starting a long render. This is entirely optional but in some cases it may appreciably reduce the render time.

To check the current speed and to optimize the performance settings switch to the General tab in the Filter settings box.

- To measure the filter speed click Check Speed in the bottom of the General tab.

Neat Video will run a speed test and will then display the measured processing speed based on the current filter settings and frame size (as shown in the box above in the same General tab).

Please note that it is the speed of Neat Video alone, without any other effects that may be used in your project and without any Final Cut processing overhead. The speed of the final render in Final Cut is always lower because of that overhead.

- To optimize the performance settings click Preferences... to open the Performance tab in Neat Video Preferences. In that tab, you can inspect the available and current CPU and GPU settings.

Then use Optimize Settings... to open a specialized dialog designed to measure video processing speeds achieved with different combinations of the CPU and GPU settings. It allows to automatically benchmark all possible combinations of settings and to identify the best combination (for the current frame size and current filter settings). You can then just click Accept Best Combination to apply the found optimal combination achieving the best performance.

Additional settings

Mix with Original

In Advanced Mode, you can additionally enable the global Mix with Original group to blend the final result of Neat Video processing with the original unprocessed frame. That may sometimes be useful to weaken the overall effect of Neat Video. For example, that may help to preserve the natural-looking results or to intentionally preserve some part of the original noise to make the output compression by lossy video codecs work better: if the final frame is very clean and smooth, some lossy compression may create a very noticeable banding during encoding. That problem can be avoided by leaving some of the noise in.
Use the **Enable** checkbox in the **Mix with Original** group.

Use the **Mix** control to adjust the overall mixing of the filtered and original frame. For example:
- **100%**: only the filtered frame is used;
- **50%**: an equal mix of the original and filtered frames;
- **0%**: only the original unprocessed frame is used.

Use the **Luminance**, **Cr** and **Cb** controls to adjust the mixing of the filtered and original image in individual channels.

### 5.9. Stage VII. Save and apply

#### 5.9.1. Save filter settings into a preset (optional)

This sub-step is entirely optional yet you may want to consider saving the current filter settings into a preset on the disk. You will then be able to re-load the same settings in another clip, in the same or another project.

**To save the filter settings into a preset**

- Click (the **Save current filter settings as a preset...** button) in the **Filter Settings** box.

Then in the **Save Filter Preset As** dialog box, specify the name of the file to save the preset. The filter presets are stored in *.nfp* files.

The saved filter preset includes all settings of the temporal and spatial noise filters, all their specialized sub-sections and options, as well as the sharpening settings. By re-opening a preset later on, you can reproduce exactly the same filter settings. Together, a device noise profile and a filter preset can be used to accurately reproduce the filtration results.

You can also add some text comments to your custom preset using the **Preset Description** dialog:

- Use **** to open the **Preset Description** dialog and add or edit the description of the preset.

The text comments are also saved into the preset on the disk when you use ****.

**To load a previously saved filter preset**

- Click (the **Load filter settings from a preset...** button) in the **Filter Settings** box. In the **Load Filter Preset** dialog box, locate and select the filter preset to be loaded.

or

- Click (the drop-down button) in the **Filter Settings** box to open the popup menu with all available presets and then select one of them.

There are several pre-written filter presets in your Documents folder:

```
/Users/username/Documents/Neat Video v4 for Final Cut/Presets/
```

Please try to load those presets to see what combinations of the filter settings and their values can be used to solve typical tasks. The names of the groups of presets and presets themselves explain those tasks. Also, when loading any of the pre-written filter presets supplied with Neat Video, the **Preset Description** dialog opens automatically to display the description of the preset being loaded. The description is intended to help you get a better understanding of the purpose, applicability and possible side effects of the preset.

---

1 You can check and adjust the location of that folder: use the menu **Tools > Preferences > Folders > Preset folder**.

2 You can disable displaying that dialog using the checkbox in the bottom of the **Preset Description** dialog (and re-enable it later in Neat Video **Preferences** if necessary).
There are two main groups of pre-written presets: General and Advanced. The presets in the first group can be used in both Beginner mode and Advanced Mode. The presets in the second group can only be used when Neat Video is in Advanced Mode, so loading such a preset will switch Neat Video to Advanced Mode (if you work in Beginner Mode).

5.9.2. Apply filter settings

After you have prepared a noise profile and adjusted the filter settings in the previous stages, you are now ready to apply those changes to the clip.

To apply filter settings

- Click (the Apply button in the bottom of the plug-in window).

The Neat Video plug-in window will be closed and the plug-in will automatically save the device noise profile and filter preset in the Final Cut project you work with. You can later re-open the Neat Video plug-in window in that clip to further adjust the noise profile and/or filter settings.

5.10. Stage VIII. Render the clip

To apply Neat Video noise reduction

- Render the clip in the regular Final Cut way. This will automatically apply Neat Video noise reduction to the clip.

Neat Video is a very processor-intensive filter, so it may take significant amount of time to render the clip. Using fast hardware (a fast CPU and/or GPU) is recommended.
6. Additional tools

6.1. Variants of filtration

When adjusting the Neat Video filter settings, you may want to compare different adjustments and select one that delivers the best visual results. You can of course manually make the adjustments and check preview after each adjustment, but it would be easier if you could prepare several variants of such adjustments and then quickly switch between their corresponding previews. Then it would be much simpler to visually evaluate and compare the results.

That is exactly what variants of filtration do in Neat Video. You can create up to four variants, each with its own set of filters settings, and quickly switch between them to evaluate their previews.

Here is how you can use variants of filtration (make sure the Noise Filter Settings tab is open):

1. To create a new variant, press the button in the toolbar and select one of the available choices:
   a. Duplicate
      a new variant will be a copy of the current variant (the current filter settings);
      you can then modify this new variant by adjusting the filter settings however you like, potentially
      making the new variant very different than the original one;
   b. Default Preset
      a new variant will be based on the filter settings obtained via the Default Filter Preset setting in
      Neat Video Preferences;
   c. Select Preset
      a new variant will be based on the filter preset you select from the presets available on the disk (you
      select one of them using the context menu);
   d. Load Preset...
      a new variant will be based on the filter preset you select from the presets available on the disk (you
      select one of them using the regular preset loading dialog).

   The new variant is added to the toolbar as a new button with the corresponding name, for example
   [Variant #2].

   The new variant automatically becomes current: it receives a special shading on its button.

   When you make any adjustments to the filter settings, they are applied and kept within the current
   variant. So if you want to change filter settings in any other variant, then you need to select that variant
   first and only then make any adjustments of the filters.

2. To select one of the existing variants (to make it current) click the corresponding variant’s button in
   the toolbar. This will change the filter settings and preview to the selected variant.

   If you now change any filter settings, then the changes will be applied to the current variant.

3. To compare two variants (their previews) you can simply click their buttons to select them alternatively.

   There is also an easier and quicker way. If you right-click another (not the current) variant’s button
   instead of doing a regular left-click, then the clicked variant is only temporarily selected and the
   selection returns to the previous variant once you release the right mouse button. This can be used
   to quickly switch between any two variants (the current one and an alternative one) for comparison
   purposes: the preview will change from one variant to another and you can easily compare them to
   decide which one is better.

4. To delete an unneeded variant use its corresponding remove button ( ).

5. When you are happy with one specific variant simply keep it current and it will then be used by
   Neat Video for actual processing.
6.2. Skip Neat Video processing

When editing a complex project with multiple clips and multiple effects including many instances of Neat Video, it may be useful to temporarily skip Neat Video processing to speed up editing in the host application.

Neat Video is a very computation-intensive filter, so it may slow down the preview and affect the responsiveness of the host application because Neat Video may be asked (by the host application) to re-calculate preview many times. Temporary skipping Neat Video processing in these settings can make the host application’s graphic interface more responsive.

Of course, you should re-enable Neat Video processing before the final render or when you want to check the host-side preview that includes noise reduction results provided by Neat Video.

- To skip Neat Video processing by all instances of the filter open the Neat Video plug-in window in one of those instances and use the menu command: Effect > Skip Neat Video Processing.

  This will skip processing by all instances of Neat Video filters currently used in all clips in the current project.

Once that command is used, Neat Video will inform you about the skipped processing status. It will remind about that when you re-open the plug-in window to make sure you do not forget that Neat Video processing is being intentionally skipped. Neat Video will offer a way to re-enable its processing too, so you always can either keep Neat Video processing skipped or re-enable it, for example before the final render.

- To re-enable Neat Video processing uncheck that menu item – Effect > Skip Neat Video Processing again or use the corresponding button in the information dialog shown by Neat Video.

If you restart the host application, Neat Video processing will be re-enabled automatically.

If the host application uses a render cache where it keeps earlier rendered frames, then it is best to clear/reset that cache (after re-enabling Neat Video processing) to make sure all those cached frames are fully processed.

6.3. Alternative modes of image viewer

The image viewer in Neat Video can show the frame in several alternative modes to enable detailed examination of both channel and frequency components. Examining the components helps to find flat featureless areas for noise analysis. Also, that allows to visually compare the original and filtered version of each component and to find optimum filter settings for the corresponding component easier and faster.

- Use (Viewer mode button) in the viewer toolbar to select the desired viewer mode.

  The viewer mode will change accordingly and will display the image components separately or as one composite image.

  Examine individual channel and frequency components of the frame, check the presence of noise in individual components. Working in the Noise Filter Settings tab, you can use the separately displayed components to identify those components that do not receive enough (or receive too much) noise reduction and adjust the corresponding filter settings.

You can also adjust the brightness of the viewer to easier see details and noise in very dark or very bright areas of the frame:

- Use (the viewer brightness controls) in the viewer toolbar to adjust and/or reset the viewer brightness to better see the noise and details in very dark or very bright areas of the frame.

  Please note that this adjustment does not change the underlying video data in any way. The adjustment only affects the viewer, i.e., the way the frame is displayed in it.
7. Device noise profiles

A *device noise profile* (or *noise profile*, or simply *profile*) describes the properties of visible noise produced by a video capturing device (e.g., a video camera, camcorder, computer TV-tuner, film digitizer, etc.) working in a certain mode. Several noise profiles corresponding to different modes of a device constitute a *profile set* for this device. Neat Video can use a profile from a profile set to process a video clip produced by a device working in the corresponding device mode.

Earlier in *Stage V. Prepare a device noise profile*, it was briefly explained how to build noise profiles automatically, using *Auto Profile*. This chapter describes that process in more details and also introduces semi-automatic and manual profiling procedures. In addition, techniques for documenting and re-using profiles are explained.

7.1. Building a profile for a device mode

*(standard profiling procedure)*

This subsection explains how to build a single noise profile for a video clip produced in a certain device mode.

Building a new noise profile generally includes three stages:

Stage I. Building a profile;
Stage II. Documenting the profile;
Stage III. Saving the profile.

7.1.1. Stage I. Building a profile

To build a noise profile for a video clip you need to make these steps:

Step 1. Selecting a frame suitable for noise analysis;
Step 2. Analyzing the noise.

Step 1. Selecting a frame suitable for noise analysis

To build an accurate noise profile, Neat Video needs to analyze a specific frame from the video clip. This frame should include uniform featureless areas containing only noise without real details.

A uniform area (with minor variation in all color channels) may be overcast sky, clear sky (without clouds and birds), or any other part of a suitable frame, where there are no visually perceptible details (except the noise, which should still be visible). Neat Video needs to analyze a uniform featureless area of around 128x128 pixels (the minimum size is 32x32 pixels). If noise strength is different from frame to frame then it is better to select a frame with the strongest noise.

Use Final Cut preview to find a frame that contains such flat featureless areas. Then use this frame to build a noise profile:

1. Use the Timeline to find a frame with large flat featureless areas; selected frame will be used for noise analysis in the next steps.
2. Click the Options... button in the Reduce Noise v4 section in the Filters or Effects panel (in FCP X: use the Options window popup menu).

(If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further.)

The Neat Video plug-in window will open and display the selected frame.

Step 2. Analyzing the noise (profiling)

Analyzing noise (profiling) is the main part of building a noise profile. This version of Neat Video offers three ways of conducting the noise analysis: automatic, semi-automatic and manual one. Using automatic profiling is easier and therefore recommended for beginners. In difficult cases (for example if Neat Video is unable to automatically find a uniform featureless area in the analyzed frame), automatic profiling may not work or produce less than optimal results. You can always override automatics and use semi-automatic or manual profiling.
Make sure you use the Device Noise Profile tab:

**Case of automatic profiling**

To analyze the noise properties of the video clip, Neat Video uses uniform areas of the frame. Such areas should contain noise but no visible or important details. With automatic profiling, Neat Video tries to find one such area automatically and then it analyzes the noise in that area as well as in the rest of the frame.

Click ![Auto Profile](Auto Profile button). Neat Video will automatically find and show the frame area selected for analysis and will analyze it automatically. If the selected area shown in viewer indeed contains no visible details, then the resulting noise profile will be accurate.

In difficult cases, Neat Video may be unable to find a sufficiently-large uniform featureless area in the frame. You will notice that the selected area, for example, contains some important details. In such a case, use the semi-automatic profiling instead (see below).

If you see that the area automatically selected for analysis is indeed uniform and featureless, then the resulting noise analysis is accurate. To be sure, check the Quality indicator in the Device Noise Profile box. A profile built using a uniform and featureless area will usually show a high value in this indicator.

If the profile quality is high (for example, higher than 60%), then you can be sure that the noise profile is accurate. In this case, proceed to **Stage II. Documenting the noise profile**, page 37.

If the quality is not high, try to use the semi-automatic profiling instead (see below).
Besides the **Quality** indicator, Neat Video offers a few more tools to help you build accurate noise profiles.

When you build a noise profile, the viewer is set to the **Assist** mode by default. That mode allows to emphasize the weak details present in Luminance (Y), Cr, Cb channels, as shown in the image below:

![Assist mode](image.png)

The top image shows the original frame where details around the sun are barely visible, while the channels in the bottom part display the image data in such a way as to make any weak details more visible.

That can help to verify that the selected area contains no useful details, which is very important for accurate noise analysis. If you see that some details are present in the selected area then try to use the semi-automatic profiling instead (see below).

Also, the **Device Noise Profile** box displays a histogram of the measured noise levels of the current profile’s frequency components. (In **Beginner Mode**, the histogram is shown in **Profile Viewer** only: menu **Profile > Profile Viewer**).

Normally, the histogram bars are shaded in green, which means likely-accurate measurements. Yellow or red shadings are used to indicate likely-inaccurate measurements of the corresponding components.

It may happen that the lowest frequencies are measured inaccurately (especially when the analysis area is small). The analysis area may seem featureless, but may actually contain some gradient-like details. Their presence in the analysis area may cause the noise levels to be measured inaccurately: the noise levels may be estimated higher than they really are. An example of such a profile with inaccurate measurements is shown in the top picture on the right.

A more accurate profiling (perhaps using a larger analysis area) could potentially produce a better profile. Such a better profile would show a histogram like one shown in the lower picture on the right.

If a noise profile with inaccurately measured lowest frequencies is used to process a video clip, then those inaccurate measurements may lead to loss of details in the corresponding frequency components. If you disable processing those frequency components (by setting the **Noise Reduction Amounts** of those frequency components to 0% in the **Spatial Filter** settings), this profile can be still used to filter the other frequency components.

**Case of semi-automatic profiling**

1) Find a uniform featureless area

- Manually find and select an area that contains no visible details.\(^1\)

  The area should be as large as possible (up to the maximum of 512x512 pixels). Using a large area is preferred because that allows to more accurately measure the properties of the noise. Using smaller areas is possible too, but the accuracy may be reduced. The absolute minimum size is 32x32 pixels.

  You can resize the selection and check its size using the **W** and **H** indicators in the bottom of the window. Also, Neat Video will indicate which frequency components can be measured using the

---

\(^1\) You can see some examples of uniform featureless areas in the **Examples** section, page 44.
selected area. For example, **Good (Low Freq)** would mean that all frequency components up to **Low** (specifically, **High**, **Medium**, and **Low**) can be measured using the selected area.

Scroll, pan, zoom the image to find a uniform featureless image area. Use the **Assist** mode of the viewer to better see the weak details and choose an area without details.

If the noise strength varies in different parts of frame, it is better to select an area with the strongest noise.

When you select an area in the frame, the indicator on top of the selection displays the noise level measured in the currently selected area. That can help to find the most noisy area for profiling. Please note that if you include any actual details in the selection then the figure will be inaccurate. It is accurate when you select an area containing only noise.

In **Advanced Mode**, the noise levels measured in the currently selected area as well as in the area used to build the current profile are also shown by the **Noise Levels** indicators in the **Device Noise Profile** panel. The **Selection** indicator shows the overall noise level of the currently selected area. The **Main Sample** indicator shows the noise level of the analysis area of the current profile (if any).

Scroll, pan, zoom the frame to find a uniform area. Set the selection to the found uniform area.

If you cannot find a uniform area in the frame, try to use another frame from the same video clip.

2) Analyze selected area

- **Click** (the **Auto Profile** button).

Neat Video will automatically analyze the manually selected area and build a noise profile.

At this point the profile is ready. Proceed to **Stage II. Documenting the noise profile**, page 37.

### Case of manual profiling

This method is available in **Advanced Mode** only. You can switch to **Advanced Mode** using the menu **Tools**.

1) Find a uniform featureless area

- **Manually find and select an area that contains no visible details.**

  The area should be as large as possible (up to the maximum of 512x512 pixels). Using a large area is preferred because that allows to more accurately measure the properties of the noise. Using smaller areas is possible too, but the accuracy may be reduced. The absolute minimum size is 32x32 pixels.

  Scroll, pan, zoom the image to find a uniform featureless image area. Use the **Assist** mode of the viewer to better see the weak details and choose an area without details.

  If noise strength is different in different parts of frame, it is better to select an area with the strongest noise. Use the noise level indicator on top of the selection to find such an area.

2) Analyze selected area

- **Click** (the **Auto Profile** button).

Neat Video will automatically analyze the selected area and build a noise profile.

3) Additionally manually fine-tune the profile

Fine-tuning uses additional flat featureless frame areas to make the noise profile more accurate. You need to manually select and analyze several such areas one after another.
1) Find and select a uniform featureless area

- Scroll, pan, zoom the frame in the viewer in the Device Noise Profile tab to find and select a new uniform area.

The size of an area may be from 16x16 to 512x512 pixels. Using larger areas makes fine-tuning more accurate. Please notice that the edges of the selection box change their thickness as the size reaches certain size thresholds. That is meant to help you select a sufficiently large area.

2) Analyze selected area with Manual Fine-Tune

- Click (the Manual Fine-Tune button) or select the Profile | Fine-Tune Using Selected Area menu item.

The analysis results will be shown in the noise profile equalizer: the graphs of the equalizer will change some of the values (see the picture on the right). You can switch from one channel to another in the equalizer to better see a specific channel’s graph, or select to show them all together.

The goal of manual fine-tuning is to fill the equalizer with measured values (shown as knots filled with the color of the corresponding graph) in all points of the graphs. The previous steps (specifically, the Auto Profile function) may have already filled some of the values. Manual fine-tuning can further improve the analysis by filling out the still missing or interpolated values (shown as yellow knots) and/or making some of already measured values more precise.

3) Repeat 1-2 above with other uniform areas of different brightness

To make a device noise profile more accurate, fine-tune it using several uniform areas of the frame. Select areas of different brightness for best results. Try to choose and analyze uniform areas to cover all or most elements of the equalizer in all its color channels. The more elements of profile are analyzed, the higher is the quality of the profile.

4) Complete fine-tuning using Auto Complete

- Click (the Auto Complete button) or select the Profile | Auto Complete menu item to automatically complete the fine-tuning by adjusting the unmeasured values using interpolation based on the measured data.

At this point the profile is ready. Proceed to Stage II. Documenting the noise profile.

7.1.2. Stage II. Documenting the noise profile

At this point the noise analysis is done and all important noise characteristics are gathered in the profile. If you are going to use this profile more than once, then you may want to additionally document the profile by describing the video capturing device and its mode.

- Use the Device Name and Mode fields in the Device Noise Profile box to specify the model of the video capturing device and describe the device mode used to capture the profiled clip.

It is recommended to specify these details to keep record of devices, device modes, and corresponding device noise profiles that you use.

The noise characteristics of any two devices can be extremely different. Even a single device can produce significantly different noise when working in different modes. Therefore, it is always better
to use separate noise profiles for different devices and device modes to avoid inaccurate filtration, insufficient noise reduction and/or artifacts. Commenting on the device name and device mode parameters will help you re-use a noise profile later when you look for a suitable profile to process a video clip.

There may be many device parameters, but not all of them influence noise and those that do differ by the strength of their influence. It makes sense to document only those parameters that appreciably affect noise. In the tables below, those parameters are described that usually appreciably affect noise characteristics (from the most to the less important ones) for video capturing devices:

| Video capturing device parameters in the order of decreasing importance |
|---------------------------|--------------------------------------------------------------------------|
| **Sensitivity of light-capturing device** | Film type and sensitivity (for digitized analog video), effective sensor sensitivity (for digital video), etc. | More sensitive light-capturing devices / media usually produce stronger noise. |
| **Compression of video clip** | Video compression method / mode used. | Stronger compression typically produces more artifacts and destroys details; weaker compression preserves more details. It is preferable to use the lowest amount of compression possible for the best results. |
| **Resolution/frame size** | 1920x1080, 1366x768, 1280x720, 720x576, 512x384, 352x288, etc. | Video clips in different resolutions usually have very different noise characteristics. |

If two video clips were produced by the same device in the same or similar conditions (most of the above device mode parameters are the same), then the noise of these two clips should be very similar. If you have built a device noise profile using one of these clips, you can use this profile to filter both clips with good results. If however, the conditions were different, then the noise in two clips could be significantly different. In this case, cross-use of the noise profile is not recommended. Instead, two different profiles should be built and used to filter these two clips.

### 7.1.3. Stage III. Saving the noise profile

![Image](https://example.com/image.png)

Use (the **Save Device Noise Profile As...** button) in the **Device Noise Profile** box.

In the **Save Device Noise Profile As...** dialog box, specify a meaningful file name and save the profile to the hard drive. Device noise profile are saved in `.dnp` files.

**File naming considerations**

If you are going to re-use the device noise profile, select a good file name explaining the device name and mode so that you could easily recognize this profile by its file name later on. You can also use some folder structuring to keep many device noise profiles arranged into sub-folders according to the device modes.

Saved noise profile includes a complete noise analysis. Therefore, by re-opening the noise profile with another clip, you can reproduce exactly the same conditions for noise reduction later on. Please note that you also need to keep a copy of the used filter preset to be able to reproduce the same noise reduction.
7.2. Using noise profiles

When you have a set of profiles for different modes of your video capturing device, you can directly use those profiles to process clips using Neat Video. Usually such a set contains only one profile that is most suitable to process a given clip. Therefore it is very important to select the right profile, which would provide the closest match between the profile and the clip. To achieve such a match, the device mode of the chosen profile should be the same or very close to the device mode used to capture the clip. So you need to manually select a device noise profile that matches the video clip based on profile descriptions and file names.

Obviously it is preferable to build a new noise profile for each clip, because such a profile would perfectly match the noise of that clip. Nevertheless, any noise profile can, with some degree of accuracy, be used to process other clips captured by the same device working in the same or similar mode. This is less accurate than building a profile for each clip but saves time because building a new profile usually takes more time than re-using a ready-made one. Also, re-using an existing profile may be the only solution in a situation when the current clip contains absolutely no uniform areas suitable for analysis.
8. Preferences

There are several preferences that adjust the behavior of the Neat Video plug-in.

Use the Tools > Preferences... menu item to open the Preferences dialog box.

8.1. General preferences

On opening plug-in window

Do not change viewer zoom and window size

Select this option to make Neat Video do nothing (like adjusting the window size and zoom level) when opening the plug-in window. The Neat Video window will remember its size from the last time and will not try to adjust its size and viewer zoom to show the whole frame. The initial zoom level will be 100%.

Adjust viewer zoom to fit frame to window

Use this option to make the Neat Video viewer automatically adjust the zoom level to fit the whole frame into the viewer window, without modifying the window size. The Neat Video window will remember its size from the last time.

Adjust window size to accommodate whole frame

Use this option to make the Neat Video windows automatically adjust its window size (and if necessary, the viewer zoom level as well) to accommodate the whole frame when opening the Neat Video plug-in.

Color theme

Normal brightness

Neat Video will display its interface elements using the current color theme of the OS.

Reduced brightness

Select this option to switch Neat Video to a custom color theme with reduced brightness.

Updates

Periodically check for software updates

Neat Video can automatically access the Internet to check whether an updated version of the plug-in is available on the webpage of Neat Video.

Unless this option is disabled, Neat Video will automatically look for updates every few days.

You can also manually run such a check using the Check Now button available there.

Neat Video will display the currently installed version of the software as well as the latest available version of the product that can be downloaded. When a newer version is available you can use the provided download link to visit the download area to download and install the updated version.

Show hints over interface controls

This option switches on/off the hints explaining the purpose of Neat Video controls (like a button, slider, etc.). The hints are displayed when the mouse pointer is placed over controls in the Neat Video interface.
8.2. Defaults

Default Device Noise Profile

This setting selects how a noise profile should be prepared by Neat Video when a new instance of the filter is created (for example, when you add Neat Video to a clip). There are two possible ways:

Do not prepare noise profile automatically

When this option is selected, Neat Video does not automatically prepare a new noise profile. You then should prepare a noise profile manually, for example, by building it using Auto Profile.

Use specified default profile

When this option is selected, Neat Video automatically loads the specified noise profile from the disk. This may be useful when you work with many clips shot by the same camera in the same shooting mode when the noise is the same in all clips. In such a situation, you can simply build a quality noise profile for one of those clips, save it to the disk, specify it here in this option and then add Neat Video to all other clips. All the newly created instances of Neat Video will automatically load and use the profile.

Default Filter Preset

This setting selects the filter preset to be used when a new instance of the filter is created (for example, when you add Neat Video to a clip) or when you reset the filter settings (in the Noise Filter Settings tab).

Program’s default settings

When this option is selected, Neat Video will use the defaults pre-programmed in the plug-in.

Specified custom preset

When this option is selected, Neat Video automatically loads the specified filter preset from the disk. Using this option, you can make any existing filter preset to work as default in Neat Video. You can also save your own preset and make it default.

8.3. Profiling preferences

Save noise samples in profiles

Enable this option to make Neat Video save a noise sample from the analyzed frame area into device noise profile (*.dnp file). This will increase the size of the *.dnp file but will also improve the compatibility with the future versions of the software (Neat Video will be able to re-build the profile using the saved noise sample).

Show warnings about selected frame areas

Enable this option to let Neat Video display warnings about selected frame areas during profiling. For example, Neat Video may warn you about clipping or non-uniformity detected in the selected area, thus helping you select a better area for profiling. If you do not need such kind of assistance you can always disable this option.
8.4. Performance preferences

The first group of settings in this tab selects the computing devices to be used for video processing. This group of settings is optional: it is shown only if at least one supported GPU (graphic processing unit) is available along with the regular CPU (central processing unit, or processor). This group includes the following items:

Use CPU only

This option makes Neat Video perform all video processing using the CPU only.

Use GPU only

This option makes Neat Video perform all video processing using the GPU only.

Use CPU and GPU

If you select this option, then Neat Video will process video data using the CPU and GPU.

Depending on individual performance of each computing device (CPU and GPU), each of the above options may be the most efficient. You can try different settings and measure the resulting speed using the Check Speed tool below.

CPU

Number of used cores

This option adjusts the number of CPU cores used by Neat Video for processing. The number of used cores can go up to the total number of cores in all CPUs in your computer (like 2 cores in Core Duo, 4 cores in Core Quad, 8 cores in a desktop version of i7 with enabled hyperthreading, etc.). If the computer includes two physical CPUs, then the number of cores is correspondingly higher. Ideally, using all cores should provide the best overall performance. In some cases however, processing speed may be even higher if only some of cores are used (especially on CPUs with hyperthreading). For example, using fewer than all 8 virtual cores of some i7 CPUs is in some cases faster. You may want to test different values of this setting. Use the Optimize tool described below to find the best number of cores.

GPU

In this box, you can specify which of the available computation-capable GPU devices (CUDA-capable NVIDIA cards and/or OpenCL-capable AMD/ATI cards) should be used (in addition to the CPU or instead of the CPU) for video processing. When you have one or more GPUs, you can let Neat Video use them and specify how much of the available GPU memory may be used by Neat Video for its processing. If another application or another filter also uses the GPU at the same time, you may want to reserve only a part of the GPU memory for Neat Video and leave the rest free for other purposes. In any case, you can try different values and see which setting gives the best results.

Check Speed

Use the Check Speed button to measure the speed of Neat Video processing with the current filter settings and current performance settings specified in the CPU and GPU boxes.

Optimize

Use the Optimize... button to open a specialized dialog designed to measure Neat Video’s processing speeds achieved with different combinations of the CPU and GPU settings. This tool allows to automatically benchmark all possible combinations of settings and to identify the best combination. This is the easiest way to optimize the performance of Neat Video for specific CPU and GPU hardware.
8.5. Folders preferences

**Profile Folder**

Select the folder where Neat Video must store and look for its device noise profiles. This should be the topmost folder of all the (sub)folders with device noise profiles. Neat Video will display all profiles (stored in all subfolders of the specified folder) in the popup menu in the **Device Noise Profile** panel of the plug-in window to help you quickly load those profiles.

By default, the **Profile Folder** is located in your Documents folder:

/\Users/\<username>/\Documents/Neat Video v4 for Final Cut/Profiles/

You can select another location to store and use noise profiles if you like.

**Preset Folder**

Select the folder where Neat Video will look for filter presets. This should be the topmost folder of all the (sub)folders with filter presets. Neat Video will display all presets (stored in all subfolders of the specified folder) in the popup menu in the **Filter Settings** panel of the plug-in window to help you quickly load those presets.

By default, the **Preset Folder** is located in your Documents folder:

/\Users/\<username>/\Documents/Neat Video v4 for Final Cut/Presets/

You can select another location to store and use filter presets if you like.

**Show preset description on load**

When you manually load a filter preset from the disk, Neat Video automatically opens the **Preset Description** dialog to display the description of the preset being loaded.

This is very useful with the pre-written presets supplied with Neat Video: their descriptions are shown to help you get a better understanding of the purpose, applicability and side effects of the corresponding preset.

You can disable displaying that dialog if you want. In that case, you can still access the **Preset Description** dialog using in the **Filter Settings** box.

**Folder History**

You can adjust the way the file dialogs work in Neat Video using the settings available in this subsection:

**Use independent folders for profiles and presets**

When this option is enabled (default), Neat Video will use separate current folders for the file dialogs that work with noise profiles and with filter presets.

If you disable this option (it is enabled by default), then Neat Video will use the same common folders for the file dialogs working with both profiles and presets.

**Use independent load and save folders**

If you enable this option (it is disabled by default), Neat Video will use separate current folders for the load and save dialogs (for example, the profile loading and profile saving dialogs).

When this option is disabled (default), Neat Video will use only one current folder for the load and save dialogs.
9. Examples

9.1. Building a noise profile

See the picture below for examples of areas that are good and bad for building device noise profiles. Here, the areas suitable for profiling are highlighted in green; those that should not be used are highlighted in red. Note that a frame area suitable for building a device noise profile should be at least 32x32 pixel large (preferably more than 128x128 pixels).

Additional comments regarding these areas are available in the next page.
These areas **can be used** to build device noise profiles, as they contain no visible details:

- **GOOD**, because this area contains no important details

- **GOOD**, no important details (this area is from another frame)

The following areas **should not be used** to build device noise profiles, because they contain details:

- **BAD**, because this area contains a detail: corner – junction of wall and ceiling

- **UNACCEPTABLE**, because this area contains many details

- **BAD**, because this area contains some details: clouds (this area is from another frame)

### 9.2. Filtration results

Please see examples of noise reduction applied to video clips in the Neat Video web page:

[https://www.neatvideo.com/examples](https://www.neatvideo.com/examples)
10. Questions and answers

10.1. General questions

**Q** What is the difference between Neat Video Demo, Home and Pro plug-in?

**A** The Demo plug-in has some functional limitations. For example, it can only process short video clips and it will filter only a limited area inside the frame. Please see the Detailed feature map, page 48, for more details.

**Q** Should I uninstall Demo plug-in prior to installing the Home / Pro plug-in?

**A** This is not necessary. You can install the Home / Pro plug-in over the Demo plug-in. Please make sure the host application is completely closed when you install the Home / Pro plug-in.

**Q** Should I uninstall the older version of Neat Video prior to installing a newer one?

**A** This is not necessary. You can simply install a newer version of Neat Video. It will either replace the old one or will be available along with the old one (depending on the version).

**Q** I think I have found a bug. How can I submit a bug report?

**A** Please use the online bug report form: [https://www.neatvideo.com/support/report-bug](https://www.neatvideo.com/support/report-bug). Please fill it out to let us know all the details necessary to reproduce the problem. See more information about bugs in the Known issues section in Neat Video webpage ([https://www.neatvideo.com/support/known-issues](https://www.neatvideo.com/support/known-issues)) and about bug fixes in the WhatsNew.txt file supplied with the software (also see the history section on the web page for the most up to date information: [https://www.neatvideo.com/features/version-history](https://www.neatvideo.com/features/version-history)).

10.2. Filtration-related questions

**Q** Why do I receive some crystal-like artifacts in the filtered frame?

**A** The crystal-like artifacts (usually these are the residual compression artifacts or residual noise) look like thin lines in the filtered frame. They can be eliminated by increasing the high frequency noise level in the filter settings or by using the dedicated Artifact Removal filter described in page 26.

Note: presence of many residual artifacts may be caused by using a poorly built, inaccurate noise profile or a profile built for another device and/or device mode.

**Q** Filtered frame looks ‘plastic’. Why?

**A** The reason is that too much filtration was applied. Let Neat Video keep some noise to have natural-looking results. Adjust the noise reduction amounts; for example, reduce the noise reduction amount in the Luminance channel to 10-30% or even to 0% (in the Spatial section). Also, make sure the device noise profile does match the video clip processed. Using an incorrectly chosen or poorly built profile can either produce plastic-looking results or leave residual artifacts (see the previous question).

**Q** What is frequency?

**A** The term (spatial) frequency is used in Neat Video to denote elements of a video clip (both important details and noise/grain) of certain size. High frequency corresponds to elements of smallest size. Medium (mid) frequency corresponds to elements of medium size. Low, Very Low and Ultra Low frequency correspond to elements of correspondingly larger sizes.

For reference, see the noise samples of different frequencies in the Noise Filter Settings tab of the Neat Video plug-in window.

**Q** The filtration process is not very fast, is this normal?

**A** This is normal, because the Neat Video noise reduction algorithms are quite complex. We work on further optimization to provide better performance.
Q How to filter only the color noise (not the brightness noise)?
A Set the value of the Luminance channel noise reduction amount to 0%. This will disable the spatial filter in the luminance (brightness) channel.

Q What is YCrCb?
A YCrCb is the name of a family of color spaces widely used in digital imaging, television, video, etc. In ‘YCrCb’, ‘Y’ corresponds to the luminance channel, ‘Cr’ - to the Cr chrominance channel covering the red to blue-green color range, ‘Cb’ - to the Cb chrominance channel covering the blue to yellow color range. Because this space separates the luminance and chrominance information, it is used for noise reduction where different processing is required in the luminance and chrominance channels.

Q Is processing via Neat Video best done before or after any other processing (i.e. tonal/color correction)?
A Such operations as tonal/color correction are quite conservative from the standpoint of noise, i.e., they do not significantly change the noise characteristics of the video clip. Therefore, filtering before or after makes little difference – as long as the noise profile is built and applied at the same stage of your workflow. For example, do not use a device noise profile built with an unprocessed (the color correction is not yet applied) clip to filter the same clip with the color correction already applied.

On the other hand, certain effects, like sharpening or resampling, applied to a noisy video clip may considerably change its noise properties. In this sense, it is generally better to use Neat Video filtration before applying such effects.
11. Information

11.1. Issues and bugs

Please report any bugs or issues you encounter while working with Neat Video. Use the online bug report form: https://www.neatvideo.com/support/report-bug.

Your feedback will greatly help us to improve the software and provide you with newer and better versions of Neat Video.

11.2. Plans

The current version of Neat Video is the result of our ongoing research on noise filtration. We continue to work on the core noise reduction algorithms to improve the quality and speed of noise reduction.

Please let us know if you have ideas that can make Neat Video better. Please participate in the discussions taking place in the Neat Video forum: express your opinion, make suggestions and ask questions.

11.3. Detailed feature map

<table>
<thead>
<tr>
<th>Use for commercial purposes</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Demo plug-in</td>
</tr>
<tr>
<td></td>
<td>not allowed</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Video data</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File formats supported</td>
</tr>
<tr>
<td></td>
<td>8/16/32 bits/channel rendering</td>
</tr>
<tr>
<td></td>
<td>Maximum size / length of filtered video data</td>
</tr>
<tr>
<td></td>
<td>Neat Video watermark added to filtered clip</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Spatial and temporal filters, all modules</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>+</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Noise reduction</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel components (Luminance, Cr, Cb)</td>
<td>+</td>
</tr>
<tr>
<td>Frequency components (High, Mid, Low, Very Low, Ultra Low)</td>
<td>+</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Smart sharpening</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel components (Luminance, Cr, Cb)</td>
<td>+</td>
</tr>
<tr>
<td>Frequency components (High, Mid, Low)</td>
<td>+</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device noise profiles</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic and semi-automatic profiling of any video-capturing device</td>
<td>+</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Filter presets (reusable filter settings)</th>
<th>Neat Video</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>+</td>
</tr>
</tbody>
</table>

11.4. Contacts

We really appreciate your opinion of Neat Video. Please let us know what you think about the software. Feel free to ask questions regarding Neat Video. You can contact us using the following means:

**E-mails**

- info@neatvideo.com for general inquiries about Neat Video
- finalcut@neatvideo.com for any inquiries regarding use of Neat Video v4 plug-in for Final Cut (Mac)
- sales@neatvideo.com for any inquiries regarding purchase of Neat Video software
Forum

Register in the Neat Video community forum (https://www.neatvideo.com/nvforum/) and participate in discussions related to the use and development of Neat Video. Such topics are covered in the forum as:

- announcements of new and updated version of the software;
- questions about use of Neat Video;
- examples of using Neat Video with comments and suggestions;
- feedback from the users: suggestions of new features and improvements;
- general comments;
- backup contacts.

Web page

https://www.neatvideo.com/

11.5. Legal information

Copyright

Neat Video © 1999-2017 Neat Video team, ABSoft. All rights reserved.

License agreement

By downloading and/or in any way using the Neat Video v4 plug-in for Final Cut (Mac) (called “Neat Video” hereunder in this agreement) software you indicate that you do accept this license agreement. If you are unable or unwilling to accept this license agreement, then you may not use the Neat Video software and must return and/or destroy all copies of Neat Video in your possession.

You may

Use the Demo edition of Neat Video free of charge for non-commercial purposes only.

Copy and distribute the Demo edition of Neat Video.

Run the Home edition of Neat Video on one (or more, up to the number specified in your license) computer (computers) at a time only for non-commercial purposes provided you are a registered user and you have a valid license for the Home edition of Neat Video.

Run the Pro edition of Neat Video on one (or more, up to the number specified in your license) computer (computers) at a time for commercial and other purposes provided you are a registered user and you have a valid license for the Pro edition of Neat Video.

You may not

Sublicense, rent, lease and sell any version of Neat Video or any portion of it including the license data without the explicit written permission from the Neat Video team, ABSoft.

Copy, share and distribute the Home and Pro edition of Neat Video or any portion of it including the license data without the explicit written permission from the Neat Video team, ABSoft.

Decompile, disassemble, reverse engineer, modify, clone and emulate any version of the Neat Video software or any portion of it including the license data.

Use the Home and Pro edition of Neat Video if you are not registered user.
Term and termination

If you are a registered user of the Home or Pro edition of Neat Video and you have purchased a license for a specific major of Neat Video, then you may use this major version (including all minor updates of the same major version) and edition of the software without time limitations provided you observe this license agreement.

A license for a certain major version of Neat Video may be extended to a higher major version. By decision of the Neat Video team, ABSoft, this extension may be automatic and free or may involve an upgrade fee.

You may terminate this license agreement at any time by returning or destroying all copies of Neat Video in your possession and notifying the Neat Video team.

Your rights derived from this license agreement will terminate immediately if you infringe upon the Neat Video team, ABSoft’s copyrights or breach the terms of this agreement. Copyright infringement or breaching this agreement may also result in criminal or civil prosecution.

Disclaimer of warranty

The authors make no warranty or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided “as is”, and you, its user, assume the entire risk as to its quality and accuracy.

Distribution

The Demo edition of Neat Video may be distributed unmodified provided any charge is to cover distribution costs only.

The Demo edition of Neat Video may be placed on magazine CDs/DVDs as long as the Neat Video team is informed.

11.6. Registration

To become a registered user and to get a fully functional copy of Neat Video Home or Pro plug-in for Final Cut (Mac) you need to purchase a license (a single- or multi-user license). Please find the detailed information in the Purchase section of the Neat Video web page: https://www.neatvideo.com/purchase

After purchasing a license, you receive an e-mail from the Neat Video team with detailed download and registration instructions. Using those you will be able to download, install and register the software on your computer.

By becoming a registered user of Neat Video Home or Pro plug-in for Final Cut (Mac) you will:

- Encourage the authors to further develop and improve the software;
- Get access to all functions of Neat Video Home or Pro plug-in for Final Cut (Mac) (see the Detailed feature map, page 48);
- Pro plug-in only: be able to use Neat Video for Final Cut (Mac) for commercial purposes;
- Get free updates of the software (minor modifications with the same major version number, for example, updates from the version v4.0 to any v4.x);
- Enjoy reduced upgrade prices for new major future modifications of Neat Video Home or Pro plug-in for Final Cut (Mac);
- Receive the primary attention of Neat Video support group;
- Receive the primary attention of Neat Video development group (tell us what you want to see in the next version).

Message from Neat Video team

By purchasing our product you are helping us to further develop and improve the software.

Become a registered user and we will make Neat Video better for YOU!
11.7. Acknowledgments

Thank you very much to all the people who contribute by proposing improvements and new features.

Thank you very much to all the people who help us to find bugs in Neat Video.

Thank you very much to those who stimulate the development of Neat Video by word and deed.

*Neat Video team, ABSoft*
## Index

<table>
<thead>
<tr>
<th>Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adapt to Changing Noise, 23</td>
</tr>
<tr>
<td>Apply filter, 30</td>
</tr>
<tr>
<td>Artifact Removal, 26</td>
</tr>
<tr>
<td>Auto Complete, 37</td>
</tr>
<tr>
<td>Auto Fine-Tune, 14</td>
</tr>
<tr>
<td>Auto Profile, 11, 34, 36</td>
</tr>
<tr>
<td>Check Speed, 18, 28</td>
</tr>
<tr>
<td>Dust and Scratches, 15, 21</td>
</tr>
<tr>
<td>Edge Smoothing, 27</td>
</tr>
<tr>
<td>Filter Tuning Assist, 25</td>
</tr>
<tr>
<td>Load Profile, 13</td>
</tr>
<tr>
<td>Manual Fine-Tune, 37</td>
</tr>
<tr>
<td>Mix with Original, 28</td>
</tr>
<tr>
<td>Mode</td>
</tr>
<tr>
<td>Advanced Mode, 15, 18</td>
</tr>
<tr>
<td>Beginner Mode, 15</td>
</tr>
<tr>
<td>Noise Level, 16, 24, 26</td>
</tr>
<tr>
<td>Noise Reduction Amount, 16, 24, 25</td>
</tr>
<tr>
<td>Optimize, 18, 28</td>
</tr>
<tr>
<td>Quality Mode, 19, 24</td>
</tr>
<tr>
<td>Sharpening, 17, 27</td>
</tr>
<tr>
<td>Slow Shutter, 22</td>
</tr>
<tr>
<td>Spatial Filter, 16, 24</td>
</tr>
<tr>
<td>Temporal Filter, 15, 19</td>
</tr>
<tr>
<td>adapt to changing noise, 23</td>
</tr>
<tr>
<td>apply filter, 30</td>
</tr>
<tr>
<td>artifact removal, 26</td>
</tr>
<tr>
<td>color noise, 26, 47</td>
</tr>
<tr>
<td>color space</td>
</tr>
<tr>
<td>chrominance, 47</td>
</tr>
<tr>
<td>luminance, 47</td>
</tr>
<tr>
<td>YCrCb, 47</td>
</tr>
<tr>
<td>compatibility</td>
</tr>
<tr>
<td>Final Cut, 4</td>
</tr>
<tr>
<td>componet viewer, 32</td>
</tr>
<tr>
<td>contacts, 48</td>
</tr>
<tr>
<td>e-mails, 48</td>
</tr>
<tr>
<td>forum, 49</td>
</tr>
<tr>
<td>web page, 49</td>
</tr>
<tr>
<td>device noise profile, 11</td>
</tr>
<tr>
<td>building, 33</td>
</tr>
<tr>
<td>automatic, 11, 34</td>
</tr>
<tr>
<td>manual, 36</td>
</tr>
<tr>
<td>semi-automatic, 35</td>
</tr>
<tr>
<td>standard procedure, 33</td>
</tr>
<tr>
<td>documenting, 37</td>
</tr>
<tr>
<td>parameters, 38</td>
</tr>
<tr>
<td>quality indicator, 12, 34</td>
</tr>
<tr>
<td>saving, 38</td>
</tr>
<tr>
<td>using, 39</td>
</tr>
<tr>
<td>dust and scratches, 15, 21</td>
</tr>
<tr>
<td>mode, 21</td>
</tr>
<tr>
<td>edge smoothing, 27</td>
</tr>
<tr>
<td>examples, 44</td>
</tr>
<tr>
<td>feature map, 48</td>
</tr>
<tr>
<td>features, 3</td>
</tr>
<tr>
<td>filter preset, 29, 30</td>
</tr>
<tr>
<td>description, 29</td>
</tr>
<tr>
<td>load, 29</td>
</tr>
<tr>
<td>save, 29</td>
</tr>
<tr>
<td>frequency, 46</td>
</tr>
<tr>
<td>high, 26, 46</td>
</tr>
<tr>
<td>low, 46</td>
</tr>
<tr>
<td>mid, medium, 46</td>
</tr>
<tr>
<td>ultra low, 25</td>
</tr>
<tr>
<td>very low, 25</td>
</tr>
<tr>
<td>frequency range, 5, 45</td>
</tr>
<tr>
<td>globally disable, 32</td>
</tr>
<tr>
<td>license agreement, 49</td>
</tr>
<tr>
<td>mix with original, 28</td>
</tr>
<tr>
<td>night mode, 22</td>
</tr>
<tr>
<td>noise, 5</td>
</tr>
<tr>
<td>noise level</td>
</tr>
<tr>
<td>spatial filter, 24, 26</td>
</tr>
<tr>
<td>temporal filter, 19</td>
</tr>
<tr>
<td>noise reduction amount, 24, 25</td>
</tr>
<tr>
<td>performance settings</td>
</tr>
<tr>
<td>optimize, 17, 28</td>
</tr>
<tr>
<td>plug-in</td>
</tr>
<tr>
<td>install package, 6</td>
</tr>
<tr>
<td>installation, 6</td>
</tr>
<tr>
<td>main window, 10</td>
</tr>
<tr>
<td>preferences, 40</td>
</tr>
<tr>
<td>preview, 16, 23</td>
</tr>
<tr>
<td>quality mode</td>
</tr>
<tr>
<td>spatial filter, 24</td>
</tr>
<tr>
<td>temporal filter, 19</td>
</tr>
<tr>
<td>registration, 50</td>
</tr>
<tr>
<td>repeated frames, 22</td>
</tr>
<tr>
<td>sharpening, 17, 27</td>
</tr>
<tr>
<td>skip processing, 32</td>
</tr>
<tr>
<td>slow shutter, 22</td>
</tr>
<tr>
<td>effective frame rate, 22</td>
</tr>
<tr>
<td>mode, 22</td>
</tr>
<tr>
<td>spatial filter, 16, 24</td>
</tr>
<tr>
<td>noise level, 16, 24</td>
</tr>
<tr>
<td>noise reduction amount, 16, 24</td>
</tr>
<tr>
<td>quality mode, 24</td>
</tr>
<tr>
<td>spatial filter settings, 16, 24</td>
</tr>
<tr>
<td>spatial filter tuning, 25</td>
</tr>
<tr>
<td>system requirements, 3</td>
</tr>
<tr>
<td>temporal filter, 19</td>
</tr>
<tr>
<td>amount, 20</td>
</tr>
<tr>
<td>noise level, 19</td>
</tr>
<tr>
<td>quality mode, 19</td>
</tr>
<tr>
<td>radius, 15, 19</td>
</tr>
<tr>
<td>test-kit, 7</td>
</tr>
<tr>
<td>variants of filtration, 31</td>
</tr>
</tbody>
</table>

---

25-Aug-2017 Neat Video © 1999-2017 Neat Video team, ABSoft. All rights reserved. 52