Cookies are disabled. This site requires cookies turned on to run properly. Please enable cookies and reload this page.

Best noise reduction
for digital video
Logo

Quick Start Guide — Resolve 15

This guide is for Neat Video v5 plug-in for Resolve being used with DaVinci Resolve 15.

If you use another version of Neat Video plug-in or another video editing application, please select the corresponding quick start guide.

1. Installing the plug-in

To install the Neat Video plug-in for Resolve:

  1. Make sure you have started Resolve at least once before installing the plug-in. If you have not done it yet, start Resolve and exit it.
     
  2. Download the installer of Neat Video plug-in for Resolve:
  • If you already purchased the product and have a current license for the Pro plug-in, please download the Pro plug-in from My Products page
  • If you want to try Neat Video before purchase, please download the Demo plug-in from Download page
  1. Start the installer:

For Windows:

Double-click the downloaded EXE file to start the installer

For MacOS:

a. Double-click the downloaded DMG file to mount the volume
b. In the mounted volume, double-click the PKG to start the installer
    (you may be prompted to enter the Name / Password of the MacOS administrator account)

For Linux:

a. Double-click the downloaded TGZ file to open the archive
b. Extract the contents of the archive to the desktop and then double-click the extracted RUN file on the desktop to start the installer
    (you may be prompted to enter the Name / Password of the administrator account)

  1. Proceed through the steps of the installation process. Use the default settings offered by the installer. This should automatically make the plug-in available to Resolve.
     
  2. Start Resolve, go to the Color tab, then to the OpenFX panel and then to Library > Neat Video > Reduce Noise v5.

If Neat Video has not become available in Resolve, please contact Neat Video support for assistance.

2. Running Neat Video on a sample video clip

Please download the test-kit prepared to help you start using Neat Video. Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mp4. This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start Resolve and go through the steps below to clean the clip using Neat Video.

2.1. Add the sample clip to the project

1. Configure a new project in Resolve

Go to Preferences to set up the Media Storage locations where all media files are stored:

 

Resolve will then display a Media Storage dialog to specify the folder where all media files would be kept. Select folder and click Save.

 

2. Add the sample clip file to the project
  1. Select File > Import File > Import Media…  and navigate to the folder with SampleClip.mp4. Double-click the selected clip to add it to the project.

 

  1. If Resolve says “The clip(s) have a different frame rate than the current project settings” and asks “Would you like to change your timeline frame rate and video format to match?” select Change.

 

  1. Drag-n-drop the clip from the Media Pool tab to the timeline (to V1).

The Resolve preview window will display the sample clip and you will see that there is strong noise in it. The task of Neat Video is to reduce this noise.
 

2.2. Prepare to add Neat Video to the clip

  1. Go to the Color Page.
  2. Use the timeline controls to select a frame with large flat featureless area; the selected frame will be used for analysis in the next stages.
  3. Click the OpenFX button at the upper right-hand corner of the OpenFX panel (to display the  OpenFX panel).
  4. In the OpenFX panel navigate to Library > Neat Video > Reduce Noise v5 in the list:

 

2.3. Configure Neat Video

1. Open Neat Video plug-in window
  1. Drag-n-drop Reduce Noise v5 to the node of the clip in the Nodes Editor panel. This will enable the Settings tab in the OpenFX  panel.
  2. Click Prepare Noise Profile in the Settings panel to open the Neat Video plug-in window.
    (If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further).

 

The Neat Video plug-in window will open and display the current frame from the clip.

  1. At this point Neat Video will ask to specify the scan type of the clip. Please select Progressive.
  2. Click the Input Data Type button in the bottom of the Neat Video window and select Linear:


2. Build a noise profile for the clip

To reduce noise in this frame and in the whole clip, Neat Video needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

  1. In the Prepare Noise Profile tab       click   

 

Neat Video will automatically find an area without details and will analyze noise in that area to build a new noise profile:

 

  1. Visually inspect the selected area. It should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, then move the selection to a featureless area or simply draw a new selection in such an area (the selection must be at least 32x32 pixels large). Then click the Build Profile button.

  1. After that the noise profile is ready and Neat Video can reduce noise in the clip.
 
3. Check Preview
  • Switch to the Noise Filter Settings tab 

You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame (also see note below).

 

4. Apply the changes
 
  • Click    in the bottom of the plug-in window.

Neat Video will save the current settings and close its main window.
(If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point).

Once this step is completed and Neat Video window is closed, the filter is ready for work.

The Resolve preview window now shows the clip with noise reduction applied to it:

 

2.4. Render the video

To apply Neat Video noise reduction
  • Use the output of the Reduce Noise v5 node in your project further.

You can now use the output of the Reduce Noise v5 node in your further workflow within the project. The noise reduction is automatically applied to the video data produced by that node.

Please see the User Guide for more details about adjusting the filter settings and other aspects of using Neat Video. These Video Tutorials will also help you to get the most out of Neat Video noise reduction.