Cookies are disabled. This site requires cookies turned on to run properly. Please enable cookies and reload this page.

Best noise reduction
for digital video
Logo

Quick Start Guide — Nuke

This guide is for Neat Video v5 plug-in for OFX hosts being used with Nuke 10.5.

If you use another Neat Video plug-in or another video editing application, please select the corresponding quick start guide.

1.Installing the plug-in

To install the Neat Video OFX plug-in:

  1. Make sure you have started Nuke at least once before installing the plug-in. If you have not done it yet, start Nuke and exit it.
     
  2. Download the installer of Neat Video for OFX hosts:
  • If you already purchased the product and have a current license for the Pro (or Studio) plug-in, please download the Pro (Studio) plug-in from My Products page
  • If you want to try Neat Video before purchase, please download the Demo plug-in from Download page
  1. Starting the installer:

For Windows:

Double-click the downloaded EXE file to start the installer

For MacOS:

a. Double-click the downloaded DMG file to mount the volume
b. In the mounted volume, double-click the PKG to start the installer
    (you may be prompted to enter the Name / Password of the MacOS administrator account)

For Linux:

a. Double-click the downloaded TGZ file to open the archive
b. Extract the contents of the archive to the desktop and then double-click the extracted RUN file on the desktop to start the installer
    (you may be prompted to enter the Name / Password of the administrator account)

  1. Proceed through the steps of the installation process. Use the default settings offered by the installer.
     
  2. Start Nuke and right-click in the Node Graph panel in the main window of Nuke. Then find Neat Video > Reduce Noise v5 in the list.

If Neat Video has not become available in Natron, please contact Neat Video support for assistance.

2.Running Neat Video on a sample video clip

Please download the test-kit prepared to help you start using Neat Video. Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mp4. This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start Nuke and go through the steps below to clean the clip using Neat Video.

2.1. Add the sample clip to the project

1. Create a new project in Nuke

Go to File > New Project to create a project in Nuke.

2. Importing a media file
  1. Right-click in Node Graph tab to open the popup menu and select Image > Read.
  2. Navigate to the folder with input clip, select SampleClip.mp4 .
  3. Make sure the frame rate is set to 25fps.


 

A node with the sample clip will appear in the Node Graph panel in the bottom of the main window of Nuke:

  1. Connect the Read1 SampleClip.mp4 node to the Viewer1 node to see the preview.
    The Nuke preview window will display the sample clip and you will see that there is strong noise in it. The task of Neat Video is to reduce this noise.

 

2.2. Add Neat Video effect to video clip

  1. Right-click Read1 node.
  2. Find Neat Video > Reduce Noise v5 in the list:

 

2.3. Configure Neat Video

1. Open Neat Video plug-in window
  1. Select Reduce Noise v5. This will add a node with Reduce Noise v5 into the Node Graph and enable controls in the Properties panel in the right part of the main window of Nuke.
  2. Select a frame for noise analysis using the selector in the timeline range.
  3. Click Prepare Noise Profile in the Properties panel to open the Neat Video plug-in window.
    (If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further).

 

The Neat Video plug-in window will open and display the current frame from the clip.

  1. At this point Neat Video will ask to specify the scan type of the clip. Please select Progressive.
  2. Click the Input Data Type button in the bottom of the Neat Video window and select Linear:

 

2. Build a noise profile for the clip

To reduce noise in this frame and in the whole clip, Neat Video needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

  1. In the Prepare Noise Profile tab       click   


 

Neat Video will automatically find an area without details and will analyze noise in that area to build a new noise profile:

  1. Visually inspect the selected area. It should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, then move the selection to a featureless area or simply draw a new selection in such an area (the selection must be at least 32x32 pixels large). Then click the Build Profile button.


 

  1. After that the noise profile is ready and Neat Video can reduce noise in the clip.

 

3. Check Preview
  • Switch to the Adjust and Preview tab 

You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame (see the user guide for more details).

 

4. Apply the changes
 
  • Click    in the bottom of the plug-in window.

Neat Video will save the current settings and close its main window.
(If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point).

Once this step is completed and Neat Video window is closed, the filter is ready for work.

The Nuke preview window now shows the clip with noise reduction applied to it:


 

2.4. Further steps inside Nuke

To apply Neat Video noise reduction
  1. Create a write node (menu Image > Write), link it (after) to the Reduce Noise v5 node, set up the parameters of the write node and then start render using the Render button.
  2. Go to menu Render > Flipbook Selected.

This will automatically apply Neat Video noise reduction to the sample clip and save the result to a new video file on the hard drive. You will then be able to open this new file, evaluate the filtration results and adjust the filter settings if necessary.

Please see the User Guide for more details about adjusting the filter settings and other aspects of using Neat Video. These Video Tutorials will also help you to get the most out of Neat Video noise reduction.