Cookies are disabled. This site requires cookies turned on to run properly. Please enable cookies and reload this page.

Best noise reduction
for digital video
Logo

Quick Start Guide — SR plug-in for Premiere Pro

This guide is for Neat Video v4 (SR) plug-in for Premiere being used with Premiere Pro CC 2017.

If you use another Neat Video plug-in or another editing application, please select the corresponding quick start guide.

1.Installing the plug-in

To install the Neat Video (SR) plug-in for Premiere:

  1. Make sure you have started Premiere Pro at least once before installing the plug-in. If you have not done that yet, start Premiere Pro and exit it.
     
  2. Download the installer of Neat Video (SR) for Premiere:
  • If you already purchased the product and have a current license for the Home or Pro plug-in, please download the corresponding Home or Pro plug-in from My Products page
  • If you want to try Neat Video before purchase, please download the Demo plug-in from Download page
  1. Starting the installer:

For Windows:

Double-click the downloaded EXE file to start the installer

For Mac OS X:

a. Double-click the downloaded DMG file to mount the volume
b. In the mounted volume, double-click NeatVideoPRSR.Intel.pkg to start the installer
    (you may be prompted to enter the Name / Password of the OSX administrator account)

  1. Proceed through the steps of the installation process. Use the default settings offered by the installer. If the installer does not automatically find the location of the host application (in the "Additional tasks" step of the installation), please specify the right location manually and then complete the installation process. This should make the plug-in available to the host application.
     
  2. Start Premiere Pro and find Neat Video > Reduce Noise v4 (SR) in the Premiere Pro’s Effect menu. Please do that manually, not using the built-in Search, since it may work incorrectly.
In case the plug-in has not become available in Premiere Pro, please contact Neat Video support for assistance.

2.Running Neat Video on a sample video clip

Please download the test-kit prepared to help you start using Neat Video. Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mpg. This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start Premiere Pro and go through the steps below to clean the clip using Neat Video.

2.1. Add the sample clip to the project

1. Configure a new project in Premiere Pro
  1.  Go to FIle > New > Project... to create a new project in Premiere Pro:

 

  1. Then go to File > New > Sequence :

 

Select AVCHD > AVCHD 1080p25 and click OK. Premiere Pro will open the Project, Effects, Effect Controls, Timeline and Program Monitor windows for the newly created project with a new sequence.

 

2. Add the sample clip file to the project
 

Use the File > Import... in Premiere Pro to import the SampleClip.mpg file into the project:

 

3. Add the sample clip to the sequence
 
  • Select the sample clip in the Project window and drag-n-drop the clip into Sequence 01 / Video 1 in the Timeline window. Then select Sequence 01 > Video 1 .

The Premiere Pro preview window will display the sample clip and you will see that there is strong noise in it. The task of Neat Video is to reduce this noise.


 

2.2. Add Neat Video effect

  1. In the Effects window, select Video Effects | Neat Video | Reduce Noise v4 (SR) ... and drag-n-drop it into Video 1 in the Sequence 01 / Video 1 in the Timeline window:

This will add the Reduce Noise v4 (SR) effect to the Video Effects list in the Effects Controls window.

 

  1. Make sure Program Monitor is set to Highest Quality: right-click frame in Premiere Pro’s preview and in the popup menu select Playback quality > Full:

 

Paused Resolution > Full:


 

2.3. Configure Neat Video

1. Open Neat Video plug-in window
  1. In the video clip in the Timeline window, use the Current Time Indicator to select a frame with large flat featureless areas; the selected frame will be used for noise analysis in the next stages.
  2. Press the Prepare button (below Reduce Noise v4 (SR) effect name) in the Effect Controls window in Premiere Pro and wait for a moment.

 

c. Open Neat Video plug-in window using the Build... button.
    (If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further).

 

The Neat Video plug-in window will open and display the current frame from the clip:

 

2. Build a noise profile for the clip

To reduce noise in this frame and in the whole clip, Neat Video generally needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

  1. In the Device Noise Profile tab       click   

The Auto Profile function will find and select an area for main analysis. Neat Video will then automatically analyze the noise in that area to build a new noise profile:

  1. Visually inspect the selected area — it should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, move the selection to a featureless area or simply draw a new selection in such an area (the selection must be at least 32x32 pixels large). Then click the Auto Profile button again.

  1. After that Neat Video is ready to filter the clip.

 

3. Check Preview
 
  • Switch to the Noise Filter Settings tab 

You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame.

 

4. Apply the changes
 
  • Click    in the bottom of the plug-in window.

Neat Video will save the current settings and close its main window.
(If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point).

Once this step is completed and Neat Video window is closed, the filter is ready for work.

The preview in Premiere Pro now shows the clip with noise reduction applied to it:


 

2.4. Render the video

To apply Neat Video noise reduction
  • Use the Sequence > Render Effects in Work Area menu item in Premiere Pro.

Premiere Pro will then apply Neat Video noise reduction to the whole sample clip to help you evaluate the filtration results (and adjust the filter settings if necessary). You will see that the noise in the resulting clip is significantly reduced while the true details are preserved.

Please see the User Guide (Win) and User Guide (OS X) for more details about adjusting the filter settings and other aspects of using Neat Video. These Video Tutorials will also help you to get the most out of Neat Video noise reduction.