Cookies are disabled. This site requires cookies turned on to run properly. Please enable cookies and reload this page.

Best noise reduction
for digital video
Logo

Quick Start Guide — Magix

This guide is for Neat Video v4 plug-in for Magix being used with Magix Pro X7.

If you use another Neat Video plug-in or another editing application, please select the corresponding quick start guide.

1. Installing the plug-in

To install the Neat Video plug-in for Magix:

  1. Make sure you have started Magix at least once before installing the plug-in. If you have not done that yet, start Magix and exit it.
     
  2. Download the EXE installer of Neat Video for Magix:
  • If you already purchased the product and have a current license for the Home or Pro plug-in, please download the Pro plug-in from My Products page
  • If you want to try Neat Video before purchase, please download the Demo plug-in from Download page
  1. Double-click the downloaded EXE file to start the installer.
  1. Proceed through the steps of the installation process. Use the default settings offered by the installer. This should automatically make the plug-in available to Magix.
     
  2. Start Magix and find Neat Video > Reduce Noise v4 in the Magix's Effects tab.

In case the plug-in has not become available in Magix, please contact Neat Video support for assistance.

2. Running Neat Video on a sample video clip


Please download the test-kit prepared to help you start using Neat Video. Having downloaded, please unzip it to a new folder on the hard disk.

The test-kit includes a sample video clip: SampleClip.mpg. This is a typical video clip captured by a digital video camera in high-gain mode. Some technical information about the sample clip is available in the SampleClipInfo.txt file.

Please start Magix and go through the steps below to clean the clip using Neat Video.

2.1. Add the sample clip to the project

1. Configure a new project in Magix

Click File > New project... to create a new project:





Magix will then display the new project with the Project, Media Pool, Project monitor and other windows:



 

2. Add the sample clip file to the project

Navigate to the Import tab in Media Pool window and select SampleClip.mpg on disk to import it into the project:




3. Add the sample clip to the timeline

Select the sample clip in the Project media window and drag-n-drop the clip into Timeline:

Magix may warn that the current movie and the imported file have different resolutions. If you want to align the movie and video movie settings to the file you wish to import, please click on Adjust.

The Magix preview window will display the sample clip and you will see that there is strong noise in it. The task of Neat Video is to reduce this noise.
 

2.2. Prepare to add Neat Video to the clip

  1. Click the sample clip in the Timeline to highlight it.
  2. Use the timeline controls to select a frame with large flat featureless area; the selected frame will be used for analysis in the next stages.
  3. Navigate to the Effects tab in Media Pool window, then find Neat Video > Reduce Noise v4 in the list:



 

2.3. Configure Neat Video

1. Open Neat Video plug-in window
  1. Click the Reduce Noise v4 in the list of effects.
  2. Magic will add the effect to the clip and open Neat Video plug-in window.
    (If you run the Demo plug-in, click OK in the popup splash screen of the plug-in to proceed further).

The Neat Video plug-in window will open and display the current frame from the clip:



 

2. Build a noise profile for the clip

To reduce noise in this frame and in the whole clip, Neat Video generally needs a noise profile describing the noise properties of the clip. You can prepare such a profile using the Auto Profile function:

  1. In the Device Noise Profile tab       click   

The Auto Profile function will find and select an area for main analysis. Neat Video will then automatically analyze the noise in that area to build a new noise profile:

  1. Visually inspect the selected area — it should contain no visible details, only noise; otherwise the noise profile and subsequent noise reduction may be inaccurate.

If the selected area does contain any details, move the selection to a featureless area or simply draw a new selection in such an area (the selection must be at least 32x32 pixels large). Then click the Auto Profile button again.

  1. After that Neat Video is ready to filter the clip.

 

3. Check Preview
  • Switch to the Noise Filter Settings tab 

You will notice that Neat Video has already applied noise reduction based on the default filter settings and the preview shows a clearly visible difference: there is less noise than in the original frame.

You can try to adjust the filter settings and see how that affects the results. For example, try to adjust the Temporal Filter > Radius setting (in the Temporal tab in the Filter Settings box in the right part of the window) from 2 to 1 or to a higher value. This will apply weaker or stronger temporal noise reduction to the frame.



 

4. Apply the changes
 
  • Click    in the bottom of the plug-in window.

Neat Video will save the current settings and close its main window.
(If you run the Demo plug-in, it will also describe the limitations of the Demo version at this point).

Once this step is completed and Neat Video window is closed, the filter is ready for work.

The Magix preview window now shows the clip with noise reduction applied to it:


 

2.4. Render the video

To apply Neat Video noise reduction
 
  • Render the clip in the regular Magix way: use the File > Export movie... menu item in Magix.

This will automatically apply Neat Video noise reduction to the sample clip and save the result to a new video file on the hard drive. You will then be able to open this new file, evaluate the filtration results and adjust the filter settings if necessary.

Please see the User Guide for more details about adjusting the filter settings and other aspects of using Neat Video. These Video Tutorials will also help you to get the most out of Neat Video noise reduction.