Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bugs in Assimilate Scratch

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
zillo



Joined: 11 Dec 2013
Posts: 5

PostPosted: Wed Dec 11, 2013 9:49 pm    Post subject: Bugs in Assimilate Scratch Reply with quote

Hi,

Iīd like to use NeatVideo in Assimilate Scratch and bought a Pro-Version.

Adding NeatVideo to a Scaffold in Scratch does work but there a several problems:

1. The Noise Reduction Amounts are not displayed in Scratch (everything working in NeatVideo Window but after hitting apply the Amounts are not rendered)

2. When applying NeatVideo on a scaled Clip (Example 4096x2304 to
1920x1080)only a cropped image is showing up in the NeatVideo Window.

3. If you want to readjust NeatVideo the original image in the Noise Filter Settings Tab is not the original image but the denoised one. Itīs not possible to see the real original rather than making adjustments to the image. It seems that not the original image is loaded into NeatVideo but the denoised output. Itīs like a feedback loop.

All issues are irrespective of the used footage and 100% reproducible. The problems occure with NeatVideo Version 3.4 and 3.5 in Assimilate Scratch 6 and 7 (no other Versions tested).

All in all NeatVideo for Scratch can only be used for one denoise action without the use of Noise Reduction Amounts or readjustments (therefore you have to delete the whole scaffold and build up an complete new setup).

I wonder if I am the only one who has this problems and would be very happy if anyone could help me!

Greetings
zillo
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Thu Dec 12, 2013 3:30 pm    Post subject: Re: Bugs in Assimilate Scratch Reply with quote

zillo wrote:
1. The Noise Reduction Amounts are not displayed in Scratch (everything working in NeatVideo Window but after hitting apply the Amounts are not rendered)

I understand that the Noise Reduction Amounts are inside Neat Video window, that is by design. But what exactly do you mean by the last part - "the Amounts are not rendered"? Please clarify.

zillo wrote:
2. When applying NeatVideo on a scaled Clip (Example 4096x2304 to 1920x1080)only a cropped image is showing up in the NeatVideo Window.

Please note that what is given to Neat Video is determined by the host application itself. Apparently, Scratch/project settings make Scratch send a crop instead of the whole original frame or scaled down frame. Please check the Scratch/project settings related to that.

zillo wrote:
3. If you want to readjust NeatVideo the original image in the Noise Filter Settings Tab is not the original image but the denoised one. Itīs not possible to see the real original rather than making adjustments to the image.

If you click the image in the Noise Filter Settings tab, does it show the original image? Does the Device Noise Profile show the original image too? That is how it is designed to work at least.

zillo wrote:
All issues are irrespective of the used footage and 100% reproducible. The problems occure with NeatVideo Version 3.4 and 3.5 in Assimilate Scratch 6 and 7 (no other Versions tested).

We will try to reproduce the above problems on our computers. So far they seem rather abnormal: we did not see anything like that before and not received reports from other users either. If you can create a small reproducible test case (a small test project) that allows to demonstrate the above issues, it would greatly help if you sent such a test case to our support [at] neatvideo.com

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
zillo



Joined: 11 Dec 2013
Posts: 5

PostPosted: Thu Dec 12, 2013 4:07 pm    Post subject: Reply with quote

1. If I change the Noise Reduction Amounts in the NeatVideo Window I can see the changes. After hitting apply they are not visible in Scratch.

Example: I do a noise reduction and view the result in the NeatVideo Window. All noise is perfectly gone. Now I pull the Noise Reduction Amount Sliders to 0%. All the noise is now visible as it should. If I now hit apply, Scratch shows me the 100% denoised image.

2. Itīs a bit confusing but I get a cropped image in the NeatVideo Window but after hitting apply the noise reduction is working on the whole image. All other OFX plugins are working on the whole image, too. There is just this special thing with NeatVideo that it has its own window where the cropping occures.

3. No, thatīs the problem. The Device Noise Profile tab shows the denoised image and if I click on the image in the Noise Filter Settings tab I see 100% the same as if I do not click it.

I try to make a short Video that shows the problems and send you a project file.

Thanks so far!
zillo
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Thu Dec 12, 2013 4:26 pm    Post subject: Reply with quote

1. Please set the temporal filter radius to 0 (to disable the temporal filter) and check if you still see no difference in Scratch preview.

2. It may look like it is NV who crops but it is much more likely that it is Scratch doing that. We will be able to tell once we reproduce the problem.

3. Does the viewer say "Original" when you click the image? And still that image looks like it has been processed? That would be abnormal. Also, having a denoised image in the Device Noise Profile tab would be abnormal too. That means Scratch served processed frames to Neat Video instead of originals.
Again, we need to be able to directly reproduce this in a test case. Then we could report this problem to Assimilate as a bug.

When preparing a test case please make sure you use the latest version of Scratch (please update it if necessary). Make sure the test project opens in Scratch and reproduces the problems. If we have to do take any special steps to see the problems please describe them.

Thank you for your help.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
zillo



Joined: 11 Dec 2013
Posts: 5

PostPosted: Thu Dec 12, 2013 10:06 pm    Post subject: Reply with quote

1. When I set the radius to 0, I see the non-filtered image in Scratch.

3. Yes, the viewer shows "Original" and the image looks like it has been processed.

Iīm using the latest Version of Scratch and NeatVideo. Iīm going to build the test scene tomorrow.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Fri Dec 13, 2013 2:35 pm    Post subject: Reply with quote

We could partially reproduce the problems (item 1 but not 3 from your original post above) with Scaffold and we keep studying that.

Do you observe any of those issues if you do not use Scaffold?

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
zillo



Joined: 11 Dec 2013
Posts: 5

PostPosted: Fri Dec 13, 2013 3:06 pm    Post subject: Reply with quote

To 2.: Problem occures only on Footage from the RED Camera if itīs not set on full resolution preview in Scratch (I show that in the video)

I have to precise point 3: The viewer SAYS "Original". (I wrote it "shows". Thatīs a bit mistakeble)

Meanwhile a co-worker of mine spotted, that the Noise Reduction Amount Problem is the same in After Effects CS6 (with NeatVideo 3.0). Setting the sliders to 0% does not result in a non filtered image.

Here is my Scratch Project with footage and the screencapture I took: Link

You should be able to reproduce everything. If not let me now.

Thanks for your help!
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Fri Dec 13, 2013 3:18 pm    Post subject: Reply with quote

Thank you, we will download the file and run the tests.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
zillo



Joined: 11 Dec 2013
Posts: 5

PostPosted: Tue Mar 18, 2014 7:00 am    Post subject: Reply with quote

Any news on the topic? Iīm still not able to use NeatVideo in Scratch effectively.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Tue Mar 18, 2014 8:19 am    Post subject: Reply with quote

Unfortunately we haven't received a reply from the developers of Scratch about that problem. We contacted them and asked to investigate the issue from the side of the host application. It seems to be a bug so they need to take a look.

The developers of Scratch have just promised to speed up their work. I hope to have some further information soon.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group