Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Insufficient memory issue using NV within Virtualdub
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
RobertP



Joined: 01 Aug 2013
Posts: 33

PostPosted: Mon Aug 05, 2013 11:29 pm    Post subject: Reply with quote

jpsdr wrote:
What is the configuration of VDub ? Input/ouput color depth,
"Option->Preference" configuration (specialy threading/3D). You filter chain, codec output. Configuration of NV (radius, number of processor used, GPU used ?)
Personnaly, i've always used latest version (actualy i'm using latest 1.10.4) without issue on WindowsXP SP3 with 3GB of memory.


Color depth is 24 bit

NV is the only filter being used.

I've tried DV and Huffyuv as both input and output.

NV Radius 5 frames, threshold 0, 4 cores - (Core2 Quad 9550)

I actually hadn't seen the preferences page before. Should I have CPU and GPU enabled?
Back to top
View user's profile Send private message
barney



Joined: 08 Jun 2012
Posts: 28

PostPosted: Tue Aug 06, 2013 12:22 am    Post subject: Re: Insufficient memory issue using NV within Virtualdub Reply with quote

RobertP wrote:


Hi Barney, where would I find these settings? So far looking under preferences I don't see this.

Thanks.


Under options/preferences you have disk I/O; choose unbuffered asynchronous.

Options/performance has the buffer settings.

Sounds like you haven't increased them from default.

I won't bother you with what I've set mine for 64GB memory, I wouldn't recommend the same for 4GB.
Back to top
View user's profile Send private message
RobertP



Joined: 01 Aug 2013
Posts: 33

PostPosted: Tue Aug 06, 2013 2:24 am    Post subject: Re: Insufficient memory issue using NV within Virtualdub Reply with quote

barney wrote:
RobertP wrote:


Hi Barney, where would I find these settings? So far looking under preferences I don't see this.

Thanks.


Under options/preferences you have disk I/O; choose unbuffered asynchronous.

Options/performance has the buffer settings.

Sounds like you haven't increased them from default.


They're currently at Avi output buffering 2 megs, Wave input 64k audio, render pipelining 32 buffers, audio buffering 2 secs.

What would you recommend?
Back to top
View user's profile Send private message
barney



Joined: 08 Jun 2012
Posts: 28

PostPosted: Tue Aug 06, 2013 3:05 am    Post subject: Re: Insufficient memory issue using NV within Virtualdub Reply with quote

RobertP wrote:
barney wrote:
RobertP wrote:


Hi Barney, where would I find these settings? So far looking under preferences I don't see this.

Thanks.


Under options/preferences you have disk I/O; choose unbuffered asynchronous.

Options/performance has the buffer settings.

Sounds like you haven't increased them from default.


They're currently at Avi output buffering 2 megs, Wave input 64k audio, render pipelining 32 buffers, audio buffering 2 secs.

What would you recommend?


Well, I really doubt that it's your issue now. It's well below what I've set mine, and since you asked where to find them, I assume that's the default. If you had poked around there before and maxed them out, it would certainly impact your memory usage; been there, done that.

Still, since you've documented your current values here, it wouldn't hurt to lower the number of buffers under render pipelining to at or near the minimum (move left) and see if it has an effect. If not, restore them to these current values and reduce the buffer size under AVI output buffering to at or near minimum. If that has no effect, try it with everything set low.

The worst it can do is impact performance as the program waits for data because the buffers are empty. And if these changes don't eliminate the error, all you have to do is set them back to what you have posted here.

And try all the disk I/O options, too. The unbuffered options will use less memory, but try each one to see if it has any impact.

The fact that they seem to have been left at default makes me think it's not likely to help, but it can't hurt to try. There really aren't any equivalent options in the Neat Video plugin, I'd look at the program hosting it.
Back to top
View user's profile Send private message
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Tue Aug 06, 2013 7:42 am    Post subject: Reply with quote

What is the pixel size of your video ? As i personnaly use a radius of 2, never tried 5, so maybe this is the issue... Radius of 5 may use too much memory, but nevertheless just still enough for NV, but quickly not enough left for VD. Don't forget, under XP32, process can't use/allocate more than 2GB of memory. So, instead of changing VD settings, try to lower radius in NV, and see if you still have the issue.
Back to top
View user's profile Send private message
happyguy



Joined: 16 Aug 2013
Posts: 1

PostPosted: Fri Aug 16, 2013 6:23 am    Post subject: Reply with quote

The latest experimental version is 1.10.3 and the latest stable version is 1.9.11. I had the same problem and was running 1.10.3 you have to go back to the stable version of VirtualDub 1.9.11 then the problem you are having should go away.
Back to top
View user's profile Send private message
klastes



Joined: 29 Sep 2015
Posts: 1

PostPosted: Sun Oct 11, 2015 8:20 am    Post subject: Reply with quote

The problem still persists on Neatvideo 4.0.9 for VirtualDub 1.10.4 on Windows 7 Sp1 64 bits.
There is no problem with end of memory on the same hardware, same virtualdub and neatvideo files on Windows 8.1 sp1 64 bit. I use the same videofiles. The problem is related to windows 7.
Back to top
View user's profile Send private message
mathewlisett



Joined: 28 May 2010
Posts: 56

PostPosted: Thu Jan 21, 2016 11:39 pm    Post subject: Reply with quote

3 things that spring to mind.

1. you are rendering to a hdd that you formatted via the compressed option and in doing so you have limited the amount of file that cna be rendered.

2. you have run out of page file memory.

3. virtualdub hasnt been updated for a few years (several i believe) and likelyhood is that it cant cope with the hardware you currently have.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group