Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Neat video final cut pro x 10.0.6 colour glitch bug
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
jrtuckwell@gmail.com



Joined: 12 Nov 2012
Posts: 2

PostPosted: Mon Nov 12, 2012 11:23 am    Post subject: Neat video final cut pro x 10.0.6 colour glitch bug Reply with quote

Just did an interview and applied neat video... every 5 seconds there was a complete colour glitch once rendered... turn the neat video plugin off... it was gone??

it was fine until I upgraded fcpx
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Mon Nov 12, 2012 2:42 pm    Post subject: Reply with quote

> it was fine until I upgraded fcpx

Yes, the problem is caused by a bug in FCPX 10.0.6. FCPX gives such corrupted frames to Neat Video (or another third-party plug-in; the problem is in FCPX so it is not specific to Neat Video) and the plug-in cannot do anything to prevent that. We reported the bug to Apple and they are working to fix FCPX.

In the meantime, we are trying to find a workaround. If you want to test a special build with the current (potentially not perfect yet) workaround, please contact support [at] neatvideo.com

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
jrtuckwell@gmail.com



Joined: 12 Nov 2012
Posts: 2

PostPosted: Wed Nov 14, 2012 10:09 am    Post subject: Reply with quote

No worries...

I will just wait for a fix... FCPX while good is quite annoying with its constant bugs... I will defiantly be more aware of upgrading until my plugins are reporting no issues!

heres to a quick fix hey!

Cheers
Back to top
View user's profile Send private message
deceres



Joined: 19 Nov 2012
Posts: 14

PostPosted: Mon Nov 19, 2012 11:24 am    Post subject: rendering nghtmare Reply with quote

I have the same problem, plus FCPROX stops rendering at all and needs a restart.

This is a huge problem for me because I use neatvideo in many projects and delivering a final clip now become a nightmare.

Do you have a temporary patch to this?

Thank you
Back to top
View user's profile Send private message Send e-mail
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Mon Nov 19, 2012 11:44 am    Post subject: Reply with quote

If the bug was in Neat Video then we would have a patch for Neat Video. Since the bug is in FCPX, we cannot make a patch for FCPX, Apple must make such a patch.

What we are doing on the side of Neat Video is trying to not use the bad frames FCPX gives us. This is a workaround, it may or may not always work. If you want to try it, contact support [at] neatvideo.com.

If you want to fix the actual problem, contact Apple and ask them to fix the bug in FCPX (we already did ask). Please note that Motion 5 does not have it, only FCPX has. So using Motion 5 for noise reduction could be a temporary solution.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
deceres



Joined: 19 Nov 2012
Posts: 14

PostPosted: Mon Nov 19, 2012 11:50 am    Post subject: Thank you Reply with quote

Thank you,
using Motion will increase workflow process... but anyway it could resolve this. Anything helps is welcome...

Apple should stop releasing a bunch of crap with every "main release"!!!!
Back to top
View user's profile Send private message Send e-mail
deceres



Joined: 19 Nov 2012
Posts: 14

PostPosted: Thu Dec 06, 2012 4:31 pm    Post subject: Motion 5 bug too Reply with quote

I've tried what suggested: using neatvideo in Motion 5 and exporting the clip makes the same crappy result with glitching frames.

Do you have some sort of voodoo ritual in order to let us apply neatvideo again?
Back to top
View user's profile Send private message Send e-mail
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Thu Dec 06, 2012 4:41 pm    Post subject: Reply with quote

I haven't observed this problem in Motion 5 so far. Perhaps it is affected too.

The best solution would be to ask Apple to fix the bugs as soon as possible because these problems affect many people.

You can use this form to do that: http://www.apple.com/feedback/finalcutpro.html

Please ask to fix the "flickering" / "colour glitch" / "rogue frame" bug in FCPX and, as it turns out, in Motion 5 too.

The more people will ask the more chance that the bugs will be fixed soon.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
mikeybouchereau



Joined: 16 Dec 2011
Posts: 9

PostPosted: Thu Dec 06, 2012 11:36 pm    Post subject: Reply with quote

Has this issue been fixed with FCPX and version 10.0.7?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Thu Dec 06, 2012 11:48 pm    Post subject: Reply with quote

First tests with 10.0.7 show the same problem.

We are getting some indications that it might be fixed with the upcoming update of OSX itself. The problem may be there, in the system core or in video drivers.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
deceres



Joined: 19 Nov 2012
Posts: 14

PostPosted: Fri Dec 07, 2012 3:26 pm    Post subject: Fantastic Reply with quote

That means that your plug-ins will not be useful until they will update OSX?
You should stop to sell the plug-in if so
Back to top
View user's profile Send private message Send e-mail
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri Dec 07, 2012 7:39 pm    Post subject: Reply with quote

Even if FCPX 10.0.6/10.0.7 are not useful due to that bug (in FCPX or in OSX), FCP 7 and FCP 6 are still good. And so FCPX 10.0.5.

Apple just needs to fix that bug. If you want to make that happen sooner, please ask Apple directly.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
deceres



Joined: 19 Nov 2012
Posts: 14

PostPosted: Fri Dec 07, 2012 7:47 pm    Post subject: Reply with quote

I don't understand why the fix should come from an OS update as seen that what changed is FCPROX.

Anyway I think that you should advice in your website that currently your plug-in is not working with the two recent versions of FCPROX.
Back to top
View user's profile Send private message Send e-mail
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri Dec 07, 2012 7:53 pm    Post subject: Reply with quote

We already advise to keep using 10.0.5 because 10.0.6 is known to cause problems. 10.0.7 is currently under evaluation. We need to check if all three bugs that we identified in 10.0.6 are still present in 10.0.7. One of them seems to be there still. Once we know the status of all bugs we will update the advisory there.

> I don't understand why the fix should come from an OS update

I said "We are getting some indications that it might be fixed with the upcoming update of OSX itself" because a beta version of 10.8.3 did not show flashing frames even with FCPX 10.0.6, unlike 10.8.2 with the same FCPX 10.0.6. "It might", not "it will".

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Sun Dec 09, 2012 3:18 pm    Post subject: Reply with quote

Apple guys have confirmed that the problem is still in FCPX itself, not in OSX. Updated OSX might just reduce the chances of the problem showing up, but the bug itself is still there in FCPX. Apple have a solution, they know how to fix the bug, but the fix has not been included in 10.0.7 (not clear why).

So it looks like we all need to wait for FCPX 10.0.8. Until then, FCPX will not work correctly with plug-ins and perhaps even without any plug-ins. It is general bug in FCPX code, it may show up anytime during rendering.

The safe way to use FCPX for now would be to stay with 10.0.5.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group