Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Left edge black border causes improper filtration

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
VHSobsessive



Joined: 31 Aug 2011
Posts: 16

PostPosted: Fri Feb 17, 2012 2:38 pm    Post subject: Left edge black border causes improper filtration Reply with quote

I have noticed an issue in Virtualdub NV ... if there is a black border of less than 16 pixels at the left of the frame, especially a hard edged border, it causes the temporal filter not to clean the left edge of the image. Even a one pixel wide black border disrupts filtration. The right hand edge of the frame is not affected by this issue at all. I suspect the first 16 pixels on the left are affected; perhaps the NV algorithm works on 16x16 pixel blocks.

NV3.0 also has this problem but it seems the demo version of NV2 does not.

Neatvideo 3.1
Virtualdub 1.10.1, 1.7.7
Temporal filter at default threshold, radius = 2
Spatial filtering OFF

I initially thought the problem was due to the edge of the (VHS) frame being noisier than the rest of the image, but cropping 100 pixels from the left (to eliminate this possibility) and adding a thin black border on the left (using the FILL filter in vdub) still leads to the same problem.

I have noticed that turning down the temporal threshold to -100 reveals some kind of spatial filtering in the image (even though I have spatial filtering always set to zero). I presume this to be a pre-temporal filter stage. The improperly filtered left portion of the image, described above, looks just like this spatial filtering.

While cropping the border eliminates the problem, the size of the border on TV shows can vary from one camera shot to the next, thus it is unrealistic to crop every shot. Also I don't want to crop the full 16 pixels from the left of every video I clean.

I have attached a brief raw VHS avi (huffyuv) file (30MB).

http://www.mediafire.com/?ag5k28f22tz57jr

Same clip processed and showing the problem on the left edge :

http://www.mediafire.com/?vgba7cuec2sh2i7

I don't think the problem is related to the noise profile but I have attached one anyway.

http://www.mediafire.com/?qi93du877jvf4mn

I look forward to your reply.


----------------

EDIT - my workaround is to add a 16 pixel black border to the left of the frame in vdub then crop it off after NV cleans the frame.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Sat Feb 18, 2012 3:48 pm    Post subject: Reply with quote

Thank you for reporting this problem and providing the samples. We have been able to reproduce the issue in NV for VirtualDub and are working on a solution. It will be possible to avoid that problem. I will post an update here.

Kind regards,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Fri Feb 24, 2012 8:45 am    Post subject: Reply with quote

Any news ????
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri Feb 24, 2012 10:49 am    Post subject: Reply with quote

There will be news, please kindly wait a bit.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Sat Mar 24, 2012 7:17 am    Post subject: Reply with quote

Almost a month... Any update ?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Sat Mar 24, 2012 9:29 am    Post subject: Reply with quote

We have been able to fix that problem in the VD plug-in. Please contact support [at] neatvideo.com for a new build that includes this fix.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Mon Mar 26, 2012 5:16 pm    Post subject: Reply with quote

I've run the new build (32 bits version) on video wich have a black border of 3-4 pixel on the left, no problem detected.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group