Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Strange behavior when building profile

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Using Neat Video
View previous topic :: View next topic  
Author Message
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Wed Sep 14, 2011 10:07 am    Post subject: Strange behavior when building profile Reply with quote

Hello.
Files and screenshot are here : http://dl.free.fr/gfrQvSKt6

With v2.2, when manualy building profile, i've noticed that a specific value could only increase, never decrease (except for the 1rst time when value had never been assigned).
Otherwise, for exemple, 1rst value of Red channel, can go the 1rst time to -10%, and after, you can sample others area, value may eventualy increase ,up to +15% for exemple, but afterward, will never decrease, and will in final state stays at +15% if there is no area with more than +15% sampled during manual building.
Logical, in way you are supposed to keep the most noisy value/part.

With 2.6, value can go up and down. During process, your 1rst value of Red channel can go up to +10%, after going to -15%, going after to +30%, and have a final value of -5%...
This behavior is illogical for me, because you can in this way have a final profile with values lower than the most noisy part, even lower than the most representative noisy part.

With 3.0, going more and more strange...
First, when i've 1rst try to manualy build a profile i've noticed :
- Even after a reset of profile, profile viewer said there is clipping in B chanel !! (Image3). How is it possible wihtout even having made a sample ?
- Quality stay at 8% and never change, despite how many areas i'm sampling.
- Values of noise were so HUGE, that i decided to make some test.
I've sampled the exact same area from same picture with v2.2 and v3.0.
In the provided pictures (screenshots), you can see :
- Image1 : Sampling of picture with v2.2
Result was :
R : -68% G : -50% B : -43%
- Image2 : Sampling sampe area with v3.0
Result was :
R : +261% G : +169% B : +1012% !!!!!!!!

You can see both profiles open in the same times with v3.0, both created from the same area of the same picture (Image4).

Is it realy normal ???
Considering these behavior, i consider v2.6 suspect, and v3.0 absolutely untrustable for creating noise profiles, and for now, i'm still using v2.2, wich behavior seems the most realiable.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Wed Sep 14, 2011 11:42 am    Post subject: Reply with quote

- measured noise levels going up and down in consecutive measurements is normal;
- resetting fine-tuning results (shown in the graphs) is not the same as resetting the whole profile; what you see there is the basis analysis without fine-tuning; the basis analysis area (blue gradient) contains clipping in B channel and that is reported by the profile viewer, which brings up the next question:
- why did you use that small area with blue gradient as the main analysis area? that goes against the user guide's recommendations on profiling;
- please try to build a noise profile using Auto Profile, the results will likely be better;
- can you provide the original frame so that we could reproduce any results that you were demonstrating?

So far I see no abnormal behaviour of the program. There are issues in the manual profiling procedures you used though.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Wed Sep 14, 2011 2:16 pm    Post subject: Reply with quote

.... It seems that the way i understood how to build profiles was erroneous...

Until now, i used the "Reset all fine tuning" to restart a profile, and after, search in the video for areas to sample and adjust profile.

It was my mistake. Now, if i understand, i must do :
- Go to a good frame
- Profile -> New
- Autoprofile (in fact, i don't realy have a choice here => This is why i think this state was only when 1rst start of NV).
- And then, afer, adjust my profile by sampling areas using "Manual fine tune".
Didn't understood that the 1rst choice (i mean autoprofile) was so critical and was the founding of profile, i though it was a sampling with no more weight than the others samplings of "Manual fine tune".
So, i thought that "Reset all fine tuning" reseted totaly the profile.
And not :
Load another profile, "Reset all fine tuning", and after, search in the video for areas to sample and adjust profile.

... It seems this time it was my mistake for not properly rtfm...
(I've read it when i've bought v2.2, but i may have misunderstood things and behavior).

Will try again and properly i hope this time (can you confirm).
And so, trash all my profiles... Crying or Very sad
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Wed Sep 14, 2011 2:42 pm    Post subject: Reply with quote

I am glad you have found the correct procedure. It indeed always required building a new profile from scratch (resetting fine-tuning / equalizer data was never enough). In v2.5 and newer, the procedure is somewhat simplified because you must always start with Auto Profile and then optionally additionally fine-tune its results. The most important part of this procedure is to make sure the right area is selected by Auto Profile (or manually selected) because this greatly affects all further fine-tuning and overall results. For Auto Profile, it is best to select an area with clearly visible noise, not very bright area, not very dark, of course without details.

Hope this helps,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Using Neat Video All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group