Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Neat Video Vegas - stutter
Goto page 1, 2, 3, 4  Next
 
Post new topic   Reply to topic    Neat Video community Forum Index -> Using Neat Video
View previous topic :: View next topic  
Author Message
Leigh



Joined: 30 May 2007
Posts: 22

PostPosted: Sat Jun 30, 2007 12:19 am    Post subject: Neat Video Vegas - stutter Reply with quote

In order to stop NV crashing Vegas completely when rendering, I have to apply NV via the media FX. Although I'd like NV to work fully with Vegas' event FX and timeline FX, I'm happy to work like this for now.

However, I'm still experiencing problems on many (possibly all?) of my transitions or simple cross fades. Immediately after the transition has completed, I get a one frame "stutter". It looks to me like it's playing the same frame twice. It's only very brief glitch, but it is noticable; especially on moving objects (people walking etc). Most frustrating... I spent 24+ hours rending an MPEG2 version of my video only to discover these unwanted anomalies. If i disabled NV, the stutter goes away.

Also, I occasionally, but not always, see a kind of flickering in some areas of my rendered movie (iirc, it's bright areas mainly, such as clouds). It looks a little like running a computer monitor on a low Hz; where you can see the flicker. I use VBR MPEG2... Could this be causing problems with NV? I assume NV won't always necessarily render the same frame (variance in noise reduction)?

Any ideas?

I currently find I'm unable to use NV at all due to these unwanted side-effects Sad I'm really disappointed because the noise reduction itself gives superb results!

Perhaps I should have posted this in the bugs/issues forum?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Sat Jun 30, 2007 2:34 am    Post subject: Reply with quote

Generally, in a situation like this, I recommend to contact the support staff (including me) directly by e-mail. Please send in a sample project or projects showing an unwanted effect and we will try to find a solution. It may be something caused by the plug-in, or by compression, or by peculiarities of Vegas plug-in support. In any case, it is more efficient to talk to the developers and support directly.

Anyway, I have been discussing that "stutter" issue within our team. There is certain technical limitation in the current versions of Vegas (a limitation of Vegas itself) regarding what a plug-in can get from Vegas and it seems that limitation may be the root cause of something that would look like a "stutter" as you describe it. One idea that came up in our discussion was to try placing the cross-faded clips with a small overlap over each other so that the first frames of the next clip would be covered by the last frames of the previous clip. This may help avoiding that effect.

Still, it would be good to see some examples, so if you sent some simple sample project then we would try to directly reproduce the effect and check what could be practically done to eliminate it.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Leigh



Joined: 30 May 2007
Posts: 22

PostPosted: Sat Jun 30, 2007 12:40 pm    Post subject: Reply with quote

You suggest that it could be a limitation of Vegas' plug-in support, but none of my other plug-ins have ever caused me problems... And I use them extensively, and have done for years. NV only works for me if it's used via media fx. This can't be right, as I've not had to do this with any other plug-ins. NV is the only plug-in I've ever used that crashed Vegas! The primary reason I use Vegas is because it is rock-solid in use.

The trouble with creating sample projects is that it takes time to create samples that exhibit the problem. I've already created two for you to help identify problems, and this is time I should be spending on my projects. Don't get me wrong, I'm happy to work with you to help to resolve problems, but I thought I was purchasing a mature product (in its 2nd incarnation) that already had such issues ironed out. I posted here in the hope of someone else having experienced the problem with details of possible solutions.

Currently, I have trouble understanding how it can be Vegas' fault. It's in its 7th incarnation, so you'd think they'd have plug-in support working perfectly by now. Admitedly I don't develop for Vegas, so these are assumptions. Also, no other plug-ins have had any problems; and I use and have tried many (both free and purchased).

I appreciate you suggesting a possible work-around to the stuttering, but I shouldn't have to resort to work-arounds. I'm already using work-arounds just to get NV to work (i.e. can't use it on the track or event fx). The work-around you suggest would increase my editing time no-end unfortunately as I have many transitions/cross-fades.

It's a shame that I'm finding NV to be such a frustrating experience, because the noise reduction itself gives superb results. I should also add that, although not resolved completely, your response to my previous issue(s) was very quick and very helpful.

I hope you can appreciate my frustrations...


Last edited by Leigh on Sat Jun 30, 2007 6:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Sat Jun 30, 2007 1:08 pm    Post subject: Reply with quote

I do appreciate your frustrations. Moreover, I do share them because most of these problems are really caused by Vegas itself and we often cannot do much about those problems. Vegas does have certain limitations in its plug-in interface and this is the root of the majority of problems you and me have been discussing so far. We could find certain workarounds to compensate for these Vegas deficiencies but apparently not for all. The fact other plug-ins work without the same problem simply indicates they use only basic services provided by Vegas to plug-ins, while NV has to do more complicated things and that is where Vegas is failing short of providing adequate support. Well, these interactions between plug-in and Vegas are really a matter to be discussed with Vegas developers and that is what we are doing now. Vegas itself it very good, but the plug-in support is rather weak. I can tell that based on our experience with other plug-in hosts such as Premiere, After Effects, VirtualDub (we have versions of NV plug-ins for these hosts). Anyway, I hope we will be able to find some solutions when working together with Vegas engineers.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Leigh



Joined: 30 May 2007
Posts: 22

PostPosted: Sat Jun 30, 2007 1:21 pm    Post subject: Reply with quote

Thanks, as always, for your prompt reply Vlad.

I'll try to get a couple of sample projects done over the weekend.
Back to top
View user's profile Send private message
Leigh



Joined: 30 May 2007
Posts: 22

PostPosted: Fri Jul 06, 2007 7:14 pm    Post subject: Reply with quote

Sorry Vlad - I haven't had time to make a couple of sample projects yet.

Any progress in your dealings with Sony?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Fri Jul 06, 2007 7:33 pm    Post subject: Reply with quote

Unfortunately, they still haven't answered my e-mail sent on Jun 30. They are really slow.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Strat



Joined: 21 Jul 2007
Posts: 12

PostPosted: Mon Aug 13, 2007 12:19 am    Post subject: Stutter Reply with quote

I don't think this is a Sony problem. When I clean up darker clips without any transistions as influence, I get a stutter ... flicker that isn't there in the original clip or does it show up with any other enhancements. I tested 3 short clips with a total of 20 secs, and after about 20 frames into the next clip I get a stutter. I've gone ahead and deleted them, so I can't send them to you at the moment. I'll do a bit more testing but just so you know, I don't think this is a Vegas problem. I was using virtual dub and tried it with VD as a plugin with Avid. I do hope this can be reolved as this an extremely fine product for my work on old films. (16mm & 8mm)
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon Aug 13, 2007 7:36 am    Post subject: Reply with quote

Strat, we more or less know what is causing the problem. It starts in Vegas and that is why we contacted Sony on Jun 30 and then again on Jul 18. They responded on Jul 19 with the following:
Quote:
Thank you for contacting Sony Creative Software. I apologize for the lengthy response time to your technical support inquiry. We have been experiencing an increase in support demands from new product launches and we have
fallen a bit behind on service requests. We have been working diligently to answer as many emails as possible in the order that they were received. I hope you understand and sincerely appreciate your patience.

They have additionally promised to forward my request to their engineers. Unfortunately, I haven't heard from them since then.

The problem starts in Vegas and they are too slow to respond to support issues. Unfortunately.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Strat



Joined: 21 Jul 2007
Posts: 12

PostPosted: Mon Aug 13, 2007 4:37 pm    Post subject: Reply with quote

The only reason I said that I didn't think this was a Sony problem is because I do not use sony. This same thing happens with virtual dub as well.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon Aug 13, 2007 4:45 pm    Post subject: Reply with quote

Yes, and it is caused by the same problem of the plug-in host (Avid+adapter for VD plug-in). Once the host is able to support the required functionality, we can make NV work without such a stutter. It does work correctly with such transitions in plug-in hosts that support the required functionality (for example, After Effects, Premiere) and doesn't in some other hosts (Vegas, Avid+adapter) that don't support that functionality. So, basically the problem is caused by the limitations of the plug-in hosts. One of the plug-in hosts that have this problem is Sony Vegas. At least it looks like it has this problem. Perhaps Sony engineers can prove the opposite and then it will be possible to resolve the problem with Vegas.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Leigh



Joined: 30 May 2007
Posts: 22

PostPosted: Tue Sep 04, 2007 7:50 pm    Post subject: Reply with quote

Have there been any further developments with these issues?

I've been on holiday, and I came back hoping to see these issues resolved. I've abandoned NV at the moment due to these "oddities", and I'd obviously like to use it again. I kinda feel like I paid for a program that doesn't fully work (albeit NV or Sony at fault). Prior to purchasing, there was no mention of potential problems with hosts. I don't feel like I should have to employ numerous workarounds (hacks?) to possibly address problems.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Tue Sep 04, 2007 10:18 pm    Post subject: Reply with quote

Leigh,

Unfortunately, Sony have not replied with any meaningful information to my repeated messages. My most recent request was just two days ago. Nothing from their developers so far. Only one "please wait" reply (dated by Jul 19) from a Sony support person, after 3 weeks of waiting:
Quote:
Thank you for contacting Sony Creative Software. I apologize for the lengthy response time to your technical
support inquiry. We have been experiencing an increase in support demands from new product launches and we have
fallen a bit behind on service requests. We have been working diligently to answer as many emails as possible in the
order that they were received. I hope you understand and sincerely appreciate your patience.

I have passed your inquiry along to the appropriate contact in development and I will get back to you with any
information that I can provide. Thank you again for your patience.

I guess they are too busy with the release of Vegas 8 to think about supporting an independent developer's efforts to provide a workaround for the limitations of the older version of Vegas.

Leigh, you have been able to receive a quick reply from Sony. Please try to contact them again. I did just two days ago. Perhaps they will listen when more people ask to address a problem with Vegas. They could at least acknowledge the limitation in Vegas and then it would be clear if the problem can be resolved in principle. Our investigation clearly indicates that the stutter problem is caused by a specific limitation of a plug-in host. In case of Vegas, this limitation seems to be present in versions 6 and 7 but perhaps there is an undocumented solution (I cannot exclude this possibility, though the Vegas documentation does not give much hope). I would really like Sony engineers to suggest one because it is their product that is limited in this way.

If Sony listened us perhaps they had more time to at least make Vegas 8 free of that problem. As it goes now, the problem may remain in this new version as well..

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
gsimonelli



Joined: 25 May 2007
Posts: 2

PostPosted: Mon Oct 22, 2007 1:50 pm    Post subject: Reply with quote

I've experienced these same issues but I don't think this was always the case. I've been able to render projects without issues in the past using this plugin. I've used it in virtual dub and in vegas. Could it be an unrelated update from another vendor?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon Oct 22, 2007 2:06 pm    Post subject: Reply with quote

No, it is caused by the limitation of the plug-in hosts. Other plug-in hosts do not have that limitation and there is no such problem in filtered output.

To avoid the problem you can disable the temporal filter, that is the part of NV that stumbles on that trouble spot of the plug-in hosts.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Using Neat Video All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group