Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Neat Video + CUDA + iMac (NVidia GTX 660M) = Crash nightmare

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
dia



Joined: 13 Nov 2014
Posts: 2

PostPosted: Thu Nov 13, 2014 6:03 pm    Post subject: Neat Video + CUDA + iMac (NVidia GTX 660M) = Crash nightmare Reply with quote

Running:
OS X 10.10
Final Cut Pro 10.1.3
Neat Video 3.6.0 (64 bit)

This iMac (13,2) has a GeForce GTX 660M with 512MB of VRAM.

According to Nvidia, it supports CUDA.

////

Works fine without CUDA driver installed, though very slow (about 4.5 FPS using all 4 cores of CPU.)

I install the CUDA driver to see if I would get any performance gains.

Driver version: 6.5.18
From Nvidia website.

When I select CPU+GPU in Neat Video preferences, the entire iMac freezes up and then restarts.

Before it crashes, I get weird screen artifacts:



Sometimes, I have to clear the NVRAM and repair disk permissions for the machine to start up again. Yesterday, when I finally got the machine rebooted, I received a dialog box that said:

A graphics problem has been detected. Click "Report" to submit report...
[Ignore] [Report]

If you click Ignore, the box kept coming back. I eventually fixed this issue deleting a GPU Restart error log on my Mac.

///

Anyway, I'd like to use GPU acceleration, but thus far it is not working.

Currently, I have uninstalled the CUDA driver completely, and Neat Video is behaving.

Help.
Back to top
View user's profile Send private message
dia



Joined: 13 Nov 2014
Posts: 2

PostPosted: Thu Nov 13, 2014 6:07 pm    Post subject: Reply with quote

Also, this doesn't seem to be an overheating problem, because after I select CPU+GPU in the preferences, the crash happens very quickly, within 30 seconds.

In that screenshot above, it seems odd that only 7MB was available out of 512. Is that normal? Other times I tried it, I saw different amounts, but never anything close to 512, or even half that.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri Nov 14, 2014 5:13 pm    Post subject: Reply with quote

Sorry to hear about your trouble with the software and hardware.

Yes, that doesn't look like overheating. It looks like a CUDA driver problem. I guess it is just not coping well enough with a situation when (1) FCPX uses the GPU, (2) Neat Video tries to use the GPU through CUDA and (3) there is not much VRAM on the video card.

I recommend to disable that GPU in Neat Video. Besides the stability issue alone, it would most likely not really help to speed up rendering because that GPU is not likely to be faster than the CPU.

You can test that using for example the NeatBench tool described here.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group