Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Noise Removal Changing Color Temperature

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Mon Aug 18, 2014 6:35 pm    Post subject: Noise Removal Changing Color Temperature Reply with quote

Hey All,

Here's my problem.

Have a grade done already in Davinci Resolve. Getting DPX files back from my VFX artist to place back in Resolve and apply the final grade. All is working fine. (So in resolve I have a mix of r3d files and dpx files.)

But, since I'm operating Resolve Lite there is no noise removal. So I want to use Neat Video which I have for After Effects NOT Resolve. (don't have the cash at this point to purchase a license for Resolve as well)

So to do that I'm taking the dpx files that have vfx applied and bringing them into AE. I apply the noise removal, looks fine, then export the dpx file again. I bring back into Resolve and apply the grade and compare it and it's not the same.

It's slightly warmer than it's supposed to be and doesn't match. The reason I believe this is happening is because the noise itself has some color (cooler). So by taking it out, it's making it appear warmer overall.

I tried applying the noise reduction to a graded clip and that seems to work better (less of a warming up of the shot). But does anybody know exactly how to approach this? Is it a technical issue, or is it a settings issue?

I've messed around with the settings quite a bit but nothing seems to fix this.

Any help would be greatly appreciated.

Thanks!
Scott
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Tue Aug 19, 2014 8:07 am    Post subject: Reply with quote

Why do you think the problem is caused by using Neat Video itself and not by some other part of AE involved in the process?

Please try to replace Neat Video with the built-in Gaussian Blur in your AE project and then render to the same output format. Will the problem be reproducible still?

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Tue Aug 19, 2014 6:00 pm    Post subject: Reply with quote

Hi Vlad,

Thanks for the response.

I didn't think it was necessarily Neat Video. Just it's happening when I apply it in AE. I brought in the same DPX VFX file and just exported to make sure it wasn't a setting in AE (for the DPX export). And it worked fine in Davinci when applying the grade.

I did however try what you mentioned with the Gaussian Blur, and it did change the color temp just like NV.

So it's definitely NOT just Neat Video, but apparently any blur type effect I put on it. So I'm assuming there's nothing (settings wise) in Neat Video that would help me avoid this since the grade has already been done?

I guess I can apply Neat Video after I apply the grade, since that seemed to not cause such a noticeable shift in the color temp. Or I guess I'd have to adjust the grade after applying Neat Video?

If for some reason there is a way to get around this using the NV settings, please let me know.

Thanks!
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Tue Aug 19, 2014 6:19 pm    Post subject: Reply with quote

If the problem is reproducible with another filter then it is most likely caused not by filters to begin with. Probably some color space conversion during saving the output file or some change in color profiles used by AE to export the video. It must be something of that sort, not related to the filters applied. It is not like noise reduced and that changes the color, that is impossible.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Tue Aug 19, 2014 6:26 pm    Post subject: Reply with quote

The only issue with that is if I DON'T add any filters, the DPX file (that I export out of AE) doesn't have the color temp change. In fact it's perfectly fine when bringing back in Resolve and reapplying the grade.

It's only when I add the filters that I get this change.

But either way, it looks like I'll have to figure it out somehow.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Tue Aug 19, 2014 6:38 pm    Post subject: Reply with quote

Perhaps AE is simply skipping some of the processing steps (like color space conversions) when not applying any filters. Perhaps those skipped steps are responsible.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Wed Aug 20, 2014 5:51 am    Post subject: Reply with quote

Maybe, I'll check it out. I've posted on some AE boards and Resolve and so far people are stumped. Put a message out to Adobe so we'll see.

In the mean time I downloaded the demo version of Neat for Resolve off the website.

I tried locating it in Resolve 11 and didn't see it in the effects area. I restarted and still didn't see anything.

Is the demo version not compatible with 11? If not, is there any way for a trial version on Resolve just to make sure it works (with my clips and the issue I'm having) before I purchase it?... or am I doing something wrong with the installation?

I didn't want to buy Neat for Resolve then find out the DPX files have some issue and I'll be confronted with the same problem in Davinci that I am right now in AE.

Thanks Vlad.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Wed Aug 20, 2014 8:51 am    Post subject: Reply with quote

The currently available Demo should work with 11.

Please look for Neat Video in Color Toolbox, there should be an OpenFX panel in it. Do you see "Reduce Noise" there?

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Wed Aug 20, 2014 5:41 pm    Post subject: Reply with quote

Hi Vlad,

I downloaded the demo and don't see it in Color Toolbox or when opening the "OpenFX" tab in the edit window.

Is there a folder I should be sure the Neat Video files are being copied to? For example right now it's placing them in the applications folder under "Neat Video for OpenFX".
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Wed Aug 20, 2014 5:52 pm    Post subject: Reply with quote

The installer should place all the necessary files to the necessary placed on the disk automatically, no need to copy anything manually (that could even spoil things).

When you run the installer, does it report any errors in the end of the installation?

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Wed Aug 20, 2014 6:29 pm    Post subject: Reply with quote

It did the first time, so I uninstalled and then redownloaded and installed once again.

This time it seems to have worked fine, no error messages. But it still doesn't show up. I should look again.

You say it's supposed to show up in the color panel? There's a motion button (in the color panel) as well but that brings up Davinci's noise removal which is grayed out (since I'm running the Lite version).

Maybe it's hidden in that and I'm just missing it.
Back to top
View user's profile Send private message
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Thu Aug 21, 2014 7:08 pm    Post subject: Reply with quote

Hi Vlad,

So I checked again last night. And no Noise Reduction shows up in the OpenFX tab.

Any ideas? Not sure if I mentioned this before, but I am running Resolve Lite, not the full version. Not sure if that matters.

Thanks.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri Aug 22, 2014 9:35 am    Post subject: Reply with quote

No, Lite should work just fine. Something else is wrong. Perhaps the disk permissions are not right.

Could you re-install the plug-in and in the end of the installation collect the install log and send it to support [at] neatvideo.com?

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
sohara24



Joined: 17 Aug 2014
Posts: 8

PostPosted: Fri Aug 22, 2014 6:02 pm    Post subject: Reply with quote

Hi Vlad,

Yes I'll send it over right now.

Thanks!
Scott
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group