Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Question about VDub pluggin

 
Post new topic   Reply to topic    Neat Video community Forum Index -> General questions
View previous topic :: View next topic  
Author Message
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Tue May 31, 2016 2:59 pm    Post subject: Question about VDub pluggin Reply with quote

I don't realy know where to ask, so i'm asking here.

Is there a possibility to discuss with a programmer of the Virtual Dub pluggin.
I'm trying to multithread my filter, and encounter some unexplain behaviors. As you've successfuly multi-thread your filter, if possible, i would like to discuss of the strange issue i have, to check if he encountered the same, how basicaly he's doing things.

You can answer me by mail, and things can be done by mail if you don't want to polute this thread.

Thanks.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Wed Jun 01, 2016 5:56 pm    Post subject: Reply with quote

Please describe your question in details and sent it by e-mail to support [at] neatvideo.com

If that is something familiar, we will offer some comments.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
jpsdr



Joined: 11 Aug 2008
Posts: 193

PostPosted: Thu Jun 02, 2016 12:07 am    Post subject: Reply with quote

Thanks for the answer. I've also asked on doom9 (to increase the chances), and someone quickly gave me what was wrong. It was a little tricky, involing copy constructor issues, meaning the fact that i was doing one thing in the Init function instead of the Start function, because a copy constructor was used (meaning the object filter was duplicated). If copy construtor (duplication of the object) wasn't used, it could have worked as it was. Learning everyday... Rolling Eyes
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Thu Jun 02, 2016 7:39 am    Post subject: Reply with quote

I am glad you could find the cause and fix the problem.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> General questions All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group