Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Square artifacts on the upper-left corner

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
XPerienceD



Joined: 22 May 2014
Posts: 3

PostPosted: Thu May 22, 2014 6:14 pm    Post subject: Square artifacts on the upper-left corner Reply with quote

Dear Neat Video-Team,

A few days ago I have purchased the Home Edition of Neat Video for the purpose of noise removal on my digitalized VHS/S-VHS videos using VirtualDub.

While this filter does an outstanding job removing noise, I have encountered occasions where I had blocking artifacts on the upper-left corner that lasted one or two frames. Most of the time the video stays artifact-free, but occasionally I see a squared area containing remains from the previous frame.

I have linked an animated GIF-file to illustrate the problem here:
http://i60.tinypic.com/mhskk1.gif

This problem seems to occur randomly and is not always reproducible. If I filter an identical scene again, the artifacts usually don't occur again - but they might appear at other scenes.

I am not sure if this problem is related to an issue addressed in an older thread: "Left edge black border causes improper filtration"
http://www.neatvideo.com/nvforum/viewtopic.php?t=734

If you look at the GIF file, you will see that there is a black border on the left edge as well, so I wonder if that might be the cause.

I can visually inspect whole video files to spot the artifacts and refilter parts from the original file, but it is time consuming and it would be better to have the confidence that the artifacts don't occur, ever though they are few in numbers.

Has anyone else experienced the problem and came up with a solution?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri May 23, 2014 10:01 am    Post subject: Reply with quote

Please let me see the Performance settings in Neat Video Preferences on your computer. My guess is that the problem might be related to GPU processing.

Please also check the version of the video driver.

I do not think the problem is related to that old (and already fixed) issue described in the other thread.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
XPerienceD



Joined: 22 May 2014
Posts: 3

PostPosted: Fri May 23, 2014 5:01 pm    Post subject: Reply with quote

Hello NVTeam,

Thank you for your response. Since I have selected the option to use both CPU and GPU for processing, I wondered whether it could occur that the CPU and GPU get sort of "out of sync" for a fraction of second, thus producing the artifacts.

Let me provide screenshots of my NV settings and some information about my PC:

AMD Athlon X2 3.6 GHz
4GB RAM
Windows 7 Ultimate 64bit OS
GPU NVidia Geforce GT 430 (1GB RAM) (Driver 335.23)







I will try to run NV using CPU only - maybe that will help. The slight speed penalty is not a big issue for me.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Fri May 23, 2014 5:32 pm    Post subject: Reply with quote

Thank you for the screenshots.

Please try to render using the CPU only.

Please also try to disable Adaptive Filtration setting (it should better be used only when necessary, not just all the time) for a test.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
XPerienceD



Joined: 22 May 2014
Posts: 3

PostPosted: Sun Jun 01, 2014 4:05 pm    Post subject: Reply with quote

I can report that switching the processing mode to CPU only and disabling Adaptive Filtration has fixed the artifacts problem. I don't know in what way each setting contributed to the artifacts, but I am happy that they do no longer show up.

Speaking about Adaptive Filtration, you mentioned that it should not be used just all the time. I actually thought there would be nothing wrong with having it activated all the time, since a lot of videos have low-light scenes that are noisier than outdoor scenes. It was my understanding that the adaptive filtration mode would accommodate different noise levels - or am I looking at it the wrong way?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Sun Jun 01, 2014 8:44 pm    Post subject: Reply with quote

Please check which one setting is triggering the problem: the CPU-only mode or Adaptive Filtration.

Adaptive Filtration should only be used when noise is actually changing within the clip. It is the same across the whole timeline of the clip then it is better (from the standpoint of stability of noise reduction results) to keep it disabled. If that option was universally positive in all imaginable cases then we would just enable it and not make it an user-adjustable option to begin with. So it is best to use it responsibly. Smile

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group