Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Video scan type
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Neat Video community Forum Index -> Improvements, new features
View previous topic :: View next topic  
Author Message
barney



Joined: 08 Jun 2012
Posts: 28

PostPosted: Sun Aug 11, 2013 5:26 pm    Post subject: Reply with quote

Vlad,

I appreciate the fact that you recognized my explanation of the most likely reason that the mode gets toggled as unexpected behavior, and prioritize the fix for that, but don't think that once that's fixed it can't inadvertently be toggled for another reason.

When you have 3 monitors each of which can be in 1 of 2 orientations, and a fourth (HDTV) that may or may not be enabled, the amount of different combinations and desktop sizes possible is more than I care to do the math on. Suffice it to say, anytime the desktop is reconfigured, there's going to be some reaching for title bars and dragging on occasion, even if they're positioned properly relative to the desktop change. I'd still appreciate a little "Change? y/n" if possible. It's also why I'd just as soon NV forgets where it last was and just opened relative to where the VD filter window is.

I don't mean to belabor the point. If it helps with the bugfix, it appears to be a 17 pixel shift north. I don't see what that corresponds to (maybe 1/2 your title bar height?) and I have yet to find anything to alleviate it. Thanks again.
Back to top
View user's profile Send private message
barney



Joined: 08 Jun 2012
Posts: 28

PostPosted: Sun Aug 11, 2013 7:01 pm    Post subject: Reply with quote

O.K., I found what's causing the problem. You seem to be placing the center of your window at the center of the screen. When the font size is increased to 125%, I believe it adds one more line of text above your "Configure" button. That must shift whatever your reference for the center of your window is. Your registry key at VidoFilterWin is saved as 6e 04 db 01 when holding the control key. But the top edge of your window is actually 16 pixels closer to the top edge of the screen than the bottom edge of your window is to the bottom edge of the screen.

I measured what I thought was 17 pixels off, but I see the registry value decrementing by 16 with each iteration. The coordinate originally db goes to ca then b9, etc. I thought I tried the reverse of this by increasing the font size on my Vista machine, but I think that was to maybe 120% instead of 125%, and maybe that didn't add another line of text. I'll leave that for you guys to play with. Maybe use the top edge of the window for window placement? And may want to rename that key (how about VideoFilterWin) ?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2238

PostPosted: Mon Aug 12, 2013 11:39 am    Post subject: Reply with quote

You are right, there seems to be a bug in one of the third-party GUI libraries we use. It shows up in situations where the Windows scaling is used. Thank you for helping us localize that trouble spot. We now have a fix: please re-download and re-install the updated plug-in and check if it works correctly on your machines.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
barney



Joined: 08 Jun 2012
Posts: 28

PostPosted: Mon Aug 12, 2013 1:58 pm    Post subject: Reply with quote

NVTeam wrote:
You are right, there seems to be a bug in one of the third-party GUI libraries we use. It shows up in situations where the Windows scaling is used. Thank you for helping us localize that trouble spot. We now have a fix: please re-download and re-install the updated plug-in and check if it works correctly on your machines.

Thank you,
Vlad


Yes, it works fine now, Vlad. My preference for color scheme also seems to be saving correctly now. Thanks much.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Improvements, new features All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group