Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

NV with FCP X v10.0.8 is causing audio sync problems

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
mistaluv2006



Joined: 24 Apr 2013
Posts: 1

PostPosted: Wed Apr 24, 2013 8:24 pm    Post subject: NV with FCP X v10.0.8 is causing audio sync problems Reply with quote

It seems that every time I add the NV plugin to a compound clip, it makes the audio fall horribly out of sync...I have deleted the render files, re rendered the timeline or selected clips, even deleted the entire project, started over with a brand new project, re-edited the project totally different than the original...and still audio falls out of sync when the movie is exported. If I delete the filter from the clips and export everything works fine. But if I export with the filter on the compound clips, the movie is exported with parts of the movie out of sync, ironically it's where the filter was added. This so far happens when I export to a Master file with H.264 or Apple ProRes 422 codecs...What is going on?
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Wed Apr 24, 2013 9:12 pm    Post subject: Reply with quote

We could also reproduce such a problem. It looks like FCPX 10.0.8 has yet one more bug that makes FCPX serve incorrect frames (frames from a slightly different part of the clip) to the plug-in in certain conditions and that results in the whole clip being shifted after rendering. It looks like one necessary condition for this problem to show up is a presense of a transition before that clip. Perhaps using a compound clip is another alternative, we are going to check that.
In any case, that bug makes FCPX misbehave and send incorrect frames to the plug-in. We are going to report this FCPX bug to Apple for further investigation.

I think this problem will also affect any other plug-ins that do temporal processing in FCPX.

Until Apple find a solution, some possible workarounds I can think of:
- not using transitions before clips where NV is used;
- not using compound clips;
- pre-denoising the original clips in an ad-hoc project and using cleaned versions of the clip in your regular project;
- manual pre-shifting the clip itself to fool FCPX (it will shift it due to that bug and the net result will be a zero shift - the clip will be in the right place after rendering).

Hope this helps,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Imdomnotstupid



Joined: 03 May 2013
Posts: 1

PostPosted: Mon May 06, 2013 3:25 am    Post subject: Reply with quote

Any new workarounds to this issue?

Vlad, has there been any word from Apple on a fix or another solution?

Its pretty frustrating having such a powerful product but having to take such time consuming steps to get to the finished project.

I understand the bug is on Apple's end, I just hope this issue can be resolved or a trick or fix can be found sooner rather than later.
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon May 06, 2013 10:17 am    Post subject: Reply with quote

Yes, they thanked us for letting them know about the problem and for providing a reproducible test case. They promised to look into that issue. They can directly reproduce the problem and identify the cause. No word on the timeframe though.

In my experience, they usually fix bugs like this in the next regular update of FCPX, but sometimes it can take longer (like it was with that frame corruption issue). What important is to report the issue as soon as possible. So it is good that we could quickly prepare those materials and submitted them to Apple. Now we all need to wait for their action.

Kind regards,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
GKH_HNL



Joined: 10 May 2013
Posts: 2

PostPosted: Sat May 11, 2013 10:47 pm    Post subject: Reply with quote

Thank you for jumping on this with Apple. I have also submitted a bug report since I could say for certainty, after reading this thread, that it is an FCPX bug. You saved me HOURS of trying to determine what I might have done to cause the problem.

I'm a new user of Neat Video so I already struggled with the transition and render problems.

I'll keep watch on this although I may need to do the work-arounds if the fix is not available before I need to complete my project.
Back to top
View user's profile Send private message
robronyeadon



Joined: 13 May 2013
Posts: 2

PostPosted: Mon May 13, 2013 10:45 am    Post subject: Same problem Reply with quote

GKH_HNL wrote:
Thank you for jumping on this with Apple. I have also submitted a bug report since I could say for certainty, after reading this thread, that it is an FCPX bug. You saved me HOURS of trying to determine what I might have done to cause the problem.

I'm a new user of Neat Video so I already struggled with the transition and render problems.

I'll keep watch on this although I may need to do the work-arounds if the fix is not available before I need to complete my project.



I am also experiencing the same problem with the audio sync. I have just bought Neat and love the way it is cleaning up my 550d footage for music videos. I have just tried it on one camera angle so far but it shifts the footage 23 frames later than the audio. I have a new job to edit 5 cameras with multicam in Final Cut Pro X and am dreading to see what it does to it all!
Back to top
View user's profile Send private message
robronyeadon



Joined: 13 May 2013
Posts: 2

PostPosted: Mon May 13, 2013 10:46 am    Post subject: Same problem Reply with quote

GKH_HNL wrote:
Thank you for jumping on this with Apple. I have also submitted a bug report since I could say for certainty, after reading this thread, that it is an FCPX bug. You saved me HOURS of trying to determine what I might have done to cause the problem.

I'm a new user of Neat Video so I already struggled with the transition and render problems.

I'll keep watch on this although I may need to do the work-arounds if the fix is not available before I need to complete my project.



I am also experiencing the same problem with the audio sync. I have just bought Neat and love the way it is cleaning up my 550d footage for music videos. I have just tried it on one camera angle so far but it shifts the footage 23 frames later than the audio. I have a new job to edit 5 cameras with multicam in Final Cut Pro X and am dreading to see what it does to it all! Please keep me updated of any new findings.
Back to top
View user's profile Send private message
GKH_HNL



Joined: 10 May 2013
Posts: 2

PostPosted: Mon May 13, 2013 6:58 pm    Post subject: Received feedback from Apple Reply with quote

Hi Vlad,

After seeing your post, I, none the less, submitted a feedback reporting this problem to Apple. I just received a response asking whether I checked with NeatVideo first. I specified in my feedback that I saw this post with Apple already acknowledging the problem. Here's the incident number: FCP X Issue [13875256]

Can you follow up to see why Apple doesn't seem to know about the problem?

NVTeam wrote:
Yes, they thanked us for letting them know about the problem and for providing a reproducible test case. They promised to look into that issue. They can directly reproduce the problem and identify the cause. No word on the timeframe though.

In my experience, they usually fix bugs like this in the next regular update of FCPX, but sometimes it can take longer (like it was with that frame corruption issue). What important is to report the issue as soon as possible. So it is good that we could quickly prepare those materials and submitted them to Apple. Now we all need to wait for their action.

Kind regards,
Vlad


Thanks for your help!
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon May 13, 2013 7:22 pm    Post subject: Reply with quote

We received a message from an Apple employee recently, I guess that was the person you communicated with. We have described the current status of the problem and the fact we already submitted it to Apple a few days ago. We submitted it directly to the technical department, while the person who contacted us today was, as far as I understand, from a bit different group within Apple. He confirmed that we were on the right track when we submitted the issue to the engineers. The issue currently remains open and we are waiting for Apple's engineers to investigate and find a fix for FCPX.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
MrGralich



Joined: 20 May 2013
Posts: 1

PostPosted: Mon May 20, 2013 1:13 pm    Post subject: Reply with quote

First of all (to the moderator): shouldn't this thread be moved in Bugs/Issues topic? It's more visible and the people would be less prone to be surprised when facing this issue...

My experience: strange thing is that, by using compound clips, I can WORKAROUND this problem.

I mean that I have the same exact issue described by the opener when adding the NV effect on a clip on the timeline that has a transition before it.
But, if I
- make a compound clip out of
* the clip itself,
* the transition before it
* and the other clip before the transition
- AND apply the NV effect to the compound clip,
I have no out-of-sync problem when exporting the video.
I must say, though, that I've exported just a range of the whole video and that the audio is INSIDE the compound clip. I didn't try, yet, with audio outside the compound clip.

Hope this helps
MrGralich
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon May 20, 2013 3:55 pm    Post subject: Reply with quote

Yes, this thread would better be in the Bugs/Issues. I will move it now.

Thank you for posting your workaround too. Hope it is effective and can help those who are affected, before Apple addresses the problem in FCPX.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group