Neat Video community Forum Index
www.neatvideo.com
Neat Video community
support - help - questions and answers - sharing experience and opinions - feedback - suggestions - backup contact
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

NeatVideo and Matrox graphic cards

 
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues
View previous topic :: View next topic  
Author Message
squitzad



Joined: 16 Oct 2006
Posts: 3
Location: SWEDEN

PostPosted: Mon Oct 16, 2006 12:48 pm    Post subject: NeatVideo and Matrox graphic cards Reply with quote

Hi there,

Using premiere Pro 2.0 (PAL) and Matrox RT.X100

I have read some threads of the issuses with NeatVideo like, no support for interlaced video, crashing when used together with other effects like colour correction and the need to re register the plugin.

1. To get around the problem of interlaced video one should change the project sttings to "No fields".This is not possible when working on a PAL or NTSC project in SD with Matrox. It's grayed out so there is no posibility to change it. I tried to render a sequence to DV AVI progressive but when imported in the project again I still only get 720x288 resolution when tryingto apply he filter. I don't have the posebility to change my field options to "Deinterlaced".

2. In the case with "when used together with other effects". I used Matrox real time effect "Colour Correction" and Premiere crashes and another consequence of this is that I need to re-register the filter. It doesn't matter if I put the effect on before or after NeatVideo.
I then tried to render out a file with MatroxColour Correction applieid to it, import it and applied Neat video. This time it works but I get strange banding like there are not enough colours in the video, or there is something wrong with the grey-scale. I guess this has something to do with the lack of support for interlaced video!?

I will soon upgrade to an RT.X2 card and I really like NeatVideo (been using NeatImage for quite a while now) and what you can achieve with the filter. So I'd like to think I spent my money well and that there is/will be a solution for this.
Rolling Eyes Question
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon Oct 16, 2006 1:12 pm    Post subject: Reply with quote

Hi there,

I am not sure what exactly is the problem of interlaced video and why you want to see more than 720x288 frame in the plug-in. The plug-in shows what frame size Premiere is going to render so if you are comfortable with Premiere rendering 720x288 then it is normal that NV shows 720x288 as well. This is normal for an interlaced workflow.

So, NV does support both interlaced and progressive workflow. In interlaced workflow it shows and filters individual fields. In progressive workflow it shows and filters progressive frames.

Regarding the problem with Matrox real time effect, I am not sure what is causing the problem here, probably it is Matrox-specific issue. Does it die immediately after adding NV, or immediately after preparing a preview, or during rendering?
Please try to find (using the Windows search) the following file in your computer: drwtsn32.log. This file should be generated by Windows' debugger (Dr.Watson) when a crash occures. It could be useful to see that file to read the description of the crashes. We will try to reproduce the crashes, but this may be not easy, so analyzing crash logs may help find a solution.

Regarding banding, you may want to send to support a sample video clip corrected by MatroxColour Correction and then we will try to directly reproduce the effect in our copy of NV. Please also send us a sample frame showing the banding, just in case the effect is not immediately reproducable.

Thank you,
Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
squitzad



Joined: 16 Oct 2006
Posts: 3
Location: SWEDEN

PostPosted: Mon Oct 16, 2006 2:31 pm    Post subject: Reply with quote

Hi Vlad,

A silly question, the 288 lines second field, are they also filtered but It's just that I can't see them in the previev window?

The answer to the question why I want to see more than 720x288 is that it is distorted, I would preffer to see the picture as it is supposed to look. It would also give me more surface to build the profile on. No big deal though! Wink


Regarding crashes: It doesn't crash when just adding the effects but either rendering or previewing it gives the same result (freeze and error: "Premiere has encountered an unexspected problem and needs to shut down"). Confused
I will check Dr.Watson.

Just to clarify: I applied NV both before and after the Matrox colourCorrection with the same banding as a result.

I'll try to send you a clip and a pic of the problem.

Thanks for the support Exclamation
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Mon Oct 16, 2006 2:59 pm    Post subject: Reply with quote

squitzad wrote:
A silly question, the 288 lines second field, are they also filtered but It's just that I can't see them in the previev window?
Yes, NV filters both fields, but shows only one. It would be strange if it filtered only one. Smile

squitzad wrote:
The answer to the question why I want to see more than 720x288 is that it is distorted, I would preffer to see the picture as it is supposed to look. It would also give me more surface to build the profile on. No big deal though! Wink

If you build a profile using some kind of combination of two fields (which must be prepared to show you a "normal picture") and then use the resulting profile to filter individual field then what will happen is inaccurate filtration: filtering 720x288 data with a 720x576 profile. So, it is a matter of accuracy. You either get an accurate profile for your video data by building it using one field, or you get a nice frame in the viewer but inaccurate filtration caused by using a non-matching profile.

squitzad wrote:
Regarding crashes: It doesn't crash when just adding the effects but either rendering or previewing it gives the same result (freeze and error: "Premiere has encountered an unexspected problem and needs to shut down"). Confused
I will check Dr.Watson.

Yes, this could help identify the offending piece of code.

squitzad wrote:
Just to clarify: I applied NV both before and after the Matrox colourCorrection with the same banding as a result.

I'll try to send you a clip and a pic of the problem.

I am looking forward to receive them and reproduce the effect.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
squitzad



Joined: 16 Oct 2006
Posts: 3
Location: SWEDEN

PostPosted: Thu Oct 19, 2006 7:38 am    Post subject: Reply with quote

Strange!

I did another test and now it works perfectly. But there seems to have been something with the first clip I added the NV filter to, or maybe it is a bug in Premier?
I could not access the NV settings at all so I deleted the effect and added it again and now it works. Shocked

I eaven forced it by adding Matrox CoulorCorrection at the same time as NV and then rendered it simultaniously and it didn't crash. Twisted Evil

It did however still get the bandig in the firts clip. Could this be because the clip is so dark and NV togehter with Matrox ColourCorrection causes this phenomena? Feels kind of unstable... Confused

I'll try to send a pic of a frame or a screendump. The material is kind of sensitive so I don't know if I can send a clip. Neutral
Back to top
View user's profile Send private message
NVTeam



Joined: 01 Sep 2005
Posts: 2237

PostPosted: Thu Oct 19, 2006 9:01 am    Post subject: Reply with quote

Please try to reproduce it using another clip.

Vlad
_________________
Neat Video team
noise reduction for video and photos
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Neat Video community Forum Index -> Bugs, issues All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group