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1. Introduction 

1.1. Overview 
Neat Video is a filter designed to reduce noise and grain in digital video. 

Neat Video detects, analyzes, and reduces noise. The quality of noise reduction provided by Neat Video 
is higher than that of other methods because Neat Video incorporates the most advanced noise reduction 
algorithms in the industry and takes into account specific characteristics of particular video capturing 
devices – video camera, camcorder, computer TV-tuner, etc., – making the filtration customized and 
more accurate. 

In addition, Neat Video can make video clip look sharper without any degradation of quality. The 
combination of the sharpening and noise filter makes such an effect possible. 

Neat Video plug-in for Final Cut (Mac OSX) is currently produced in three editions: Demo, Home, Pro. 

• Demo plug-in is a free edition of the software with limited functionality 
• Home plug-in supports video data with up to DVD-size frames 
• Pro plug-in provides all features without limitations: supports any frame size 

1.2. Features 
Noise Reduction and Smart Sharpening 

• Advanced noise filter to reduce noise and grain in digital video 
• Temporal filtration to reduce more noise and better preserve true details 
• Complete control over the noise filter to achieve the desired level of noise reduction 
• Smart sharpening filter to make video look sharper without amplification of noise 

Device Noise Profiles 
• Custom noise profiles to make noise reduction device-specific and more accurate 
• Automatic noise analyzer to build noise profiles for your video-capturing device 
• Profile viewer to inspect noise profiles 

Some features are only available in the Home or Pro plug-in. Detailed feature map (page 27) explains 
the differences between Neat Video Demo, Home and Pro plug-ins in details. 

1.3. Requirements 
Recommended system configuration is: 

• Intel Core / Core 2 or PowerPC G4 / G5 processor, single or multi-processor 
• Mac OSX 10.4+ 
• 1 GB RAM or higher 
• True color display with 1024x768 resolution or higher 

System requirements for practical use of Neat Video depend on frame size and length of video clips 
because processing larger frames and longer clips takes proportionally more time than smaller ones. 
The processing speed is determined primarily by the processor number-crunching power and memory 
speed. 

The Neat Video plug-in can process any RGB video supported by Final Cut. 

Neat Video plug-in for Final Cut (Mac) is compatible with the following plug-in hosts: 

• Final Cut Pro 7 / 6 
• Motion 5 / 4 / 3 
• Final Cut Express 4 
 

The plug-in may be compatible with other hosts as well. 
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2. Key concepts 

2.1. What it can do – functionality of Neat Video 
Neat Video is a digital video filter. Its main function is to reduce noise in digital video footage. 

Neat Video can work with video clips produced by any video recording devices – video cameras, 
camcorders, computer TV-tuners, film digitizers, etc. The software can be adjusted to a particular 
device by means of a device noise profile, which describes the noise characteristics of the device 
working in a certain mode. 

A device noise profile is built by analyzing those areas of a video frame that contain no visible or 
important details. Usually, Neat Video can find such featureless areas completely automatically. In a 
difficult case, you can assist it and select a featureless area manually. Finding such areas is very easy for 
human eyes but may sometimes be a bit difficult for software. 

By analyzing featureless areas in a frame, Neat Video’s noise analyzer builds a profile which describes 
the noise in these areas. With this profile, Neat Video can efficiently reduce noise in the frame and in the 
whole video clip. 

The noise filter processes video data in several spatial frequency ranges. This makes possible reducing 
noise in one frequency range even if details are present in other ranges. The filter can also selectively 
process any of the color channels of video data. 

Besides the intra-frame filtration, Neat Video also applies temporal (inter-frame) filtration to video 
data. Neat Video uses several consequent frames to better reduce noise and preserve more true details in 
each frame. This improves the overall quality of noise reduction. 

In addition to the noise filter, there is the smart sharpening filter, which only sharpens important details 
without increasing the level of noise. This filter also uses the noise profile to tell noise from details, so 
applying the noise and sharpening filters together saves time and produces better overall results. 

2.2. When it works – types of noise 
Neat Video is designed to reduce noise in video footage produced by video cameras, camcorders, 
computer TV-tuners, film digitizers and can also be used to process video from other sources. To be 
efficiently processed, a video clip should satisfy the following requirements: 

• Noise must be uniformly distributed throughout each frame, i.e., there should be no strong 
surges of noise intensity in some areas of one frame or significant changes of noise characteristics 
across the frame. 
 
Neat Video works fine, for example, with video clips produced in high sensitivity modes of a 
digital video camera (digital noise) or with footage captured on highly sensitive film (film grain). 
However, traces of dust particles on a sensor or film do not satisfy the uniformity condition and, 
therefore, are not efficiently removed by Neat Video. 
 
Another possible source of noise is video compression. The compression noise is approximately 
uniform when high compression quality is used. Low compression quality makes noise 
non-uniform. Therefore, we recommend using the highest quality levels whenever possible. Try to 
avoid visible compression artifacts in video data beginning from the early stages of your 
post-processing workflow. 
 

• Noise should be concentrated in high and medium spatial frequencies. This condition is 
usually met by most video clips produced by modern digital video capturing devices. 

 
 
 
 
 
 
 
 



User Guide Neat Video plug-in for Final Cut (Mac OSX) 
  

  
Neat Video © 1999-2011 Neat Video team, ABSoft. All rights reserved. 5 8-Jul-11 

3. Installing the plug-in 
To install the Neat Video plug-in into Final Cut (Mac) 

1. Close Final Cut; 

2. Download (from the Neat Video website: http://www.neatvideo.com/download.html ) one of 
the DMG packages that matches your version of Final Cut; 

3. Click the downloaded file to mount the DMG volume; 

4. In the mounted volume, double-click NeatVideoFC.Intel.pkg  
(or NeatVideoFC.PowerPC.pkg) to start the installer; 

5. Follow the steps of the installer wizard to complete the installation process; 
(you may be prompted to enter the Name / Password of the OSX administrator account); 

6. Start Final Cut and find in the Effects > Video Filters menu: Neat Video > Reduce noise. 
 

4. Running Neat Video on a sample video clip 
There is a test-kit prepared to help you start using Neat Video. You can download the test-kit from the 
Neat Video web page: http://www.neatvideo.com/files/testkit.zip (2 MB). Having downloaded, unzip it 
to a new folder on the hard disk. 

The test-kit contains a sample video clip: the SampleClip.mpg file. This clip is a part of typical video 
clip captured by a digital camcorder. Detailed information about the sample clip is available in the 
SampleClipInfo.txt file. 

Please start Final Cut, create a new project and go through the stages below to see how Neat Video can 
improve the clip: 

4.1. Stage I. Add the clip to the project 
1. Adjust the settings of a new sequence in the project 

 Use the Sequence > Settings… menu item in Final Cut to open the Sequence Settings dialog. 
Set the Aspect Ratio to NTSC (4:3) to make the Frame Size show 640x480 pixels. 
Set the Pixel Aspect Ratio to Square, the Field Dominance to None, and the Editing Timebase to 30 fps. 
Then press OK to apply the changes. 

2. Add the sample clip file to the project 

 Use the File > Import > Files… menu in Final Cut to import the SampleClip.mpg file into the project. 

3. Add the sample clip to the sequence 

 Select the sample clip in the project panel in the Browser window and drag-n-drop the clip into the 
sequence in the Timeline window. 
 
You will see that there is noise in the sample clip (see the clip preview in the Canvas window). The 
task of Neat Video is to reduce this noise. 

4.2. Stage II. Add Neat Video effect to the clip 
 1. Select the sample clip in the Timeline window; 

2. Use the Effects > Video Filters > Neat Video > Reduce Noise… menu item to add the Neat Video effect 
to the clip; 
3. Open the Filters panel in the Viewer window in Final Cut to see all filters added to the clip. 
You will see that Neat Video has been added to the list of filters in this clip. 

http://www.neatvideo.com/download.html?9�
http://www.neatvideo.com/files/testkit.zip?9�
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4.3. Stage III. Configure Neat Video 
1. Open Neat Video plug-in window 

 Open the Neat Video plug-in window using the Options… button in the Neat Video section in the Filters 
panel; 
The Neat Video plug-in window will open and show the currently selected frame from the clip. 

2. Load noise profile 
To reduce noise in this frame and in the whole clip, Neat Video generally needs a noise profile 
describing the noise properties of the clip. We have prepared such a noise profile in advance. The profile 
is supplied with the test-kit in the SampleProfile.dnp file. Using the noise profile, Neat Video can 
efficiently reduce the noise in the clip. 

 1. In the Device Noise Profile tab:  
click    (the Load Profile button); 
 
2. In the Open Device Noise Profile dialog, navigate to the folder where the sample device noise profile 
has been unzipped and select the SampleProfile.dnp file. 

The sample noise profile is now open and Neat Video is almost ready to filter the sample clip. Usually, 
you would adjust the filter settings at this stage. To make things easier for the first run of Neat Video, we 
have prepared a sample preset file that stores ‘good’ filter settings suitable for the sample clip. 

3. Load filter preset 

 1. Switch to the Noise Filter Settings tab:  
and click    (the Load Filter Preset button) in the Filter Settings box; 
 
2. In the Load Filter Preset dialog, navigate to the folder where the sample filter preset has been 
unzipped and select the SamplePreset.nfp file. 

Now the sample filter preset is loaded and the filter settings are adjusted to process the sample clip. 

4. Apply the settings 

 Click    in the bottom of the plug-in window. 

The plug-in window will be closed and the plug-in will automatically save the device noise profile and 
filter preset in the Final Cut project your work with. 

4.4. Stage IV. Render the clip 
 Use the Sequence > Render Selection > Both menu item. 

This will automatically apply Neat Video noise reduction to the whole sample clip so that you could 
evaluate the filtration and adjust the filter settings if necessary. You will see that the noise in the 
rendered clip is significantly reduced while the true details are preserved. You can also find that the 
resulting noise-free clip can be compressed better (the file size is smaller) than the original noisy clip 
(provided you use the same video codec in both cases). 

The sample noise profile and filter preset supplied with the test-kit are suitable only for the sample clip 
and similar clips produced by the same capturing device working in the same or similar mode. Neat 
Video can perform similar noise reduction on video clips captured or acquired by any other devices 
working in any mode. To be able to do that Neat Video needs device noise profiles that describe the 
noise characteristics of those devices. With Neat Video you can easily build these profiles yourself. The 
software can completely automatically build a profile once you give it a suitable frame from a clip. 

The next sections – Filtration process details, page 7, and Device noise profiles, page 16,– contain 
detailed descriptions of the filtration and profiling processes. 
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5. Filtration process details 
This section explains how to apply the Neat Video noise reduction to a video clip in a Final Cut project. 

5.1. Stage I. Add the Reduce Noise effect 
To apply the Neat Video noise reduction to a video clip in a Final Cut project: 

 1. In the Timeline window, select a clip to be filtered. 
 
2. Select the Effects > Video Filters > Neat Video > Reduce Noise… menu item 
or  
use the Effects tab (drag and drop the Neat Video > Reduce Noise… effect to the clip). 

5.2. Stage II. Select a frame for noise analysis 
Neat Video filter uses a frame (or a field1) from the video clip to analyze noise and build a noise profile 
necessary to reduce noise in the clip. This frame should include flat featureless areas that contain no 
visible details. To build a noise profile you have to manually find such a frame in the video clip using 
the Final Cut timeline controls. If there are many frames that contain flat featureless areas then select 
one with largest and most noisy flat featureless areas without visible details. 

 In the clip in the Timeline window, use the Current Time Indicator to select a frame with large flat 
featureless areas; the selected frame will be used for noise analysis in the next stages. 
 

5.3. Stage III. Open Neat Video plug-in window 
Open the Neat Video plug-in window: 

 Click the Options… button in the Neat Video section in the Filters panel. 

The Neat Video plug-in window will open and show the selected frame (for progressive video) or one field 
(upper or lower; for interlaced video) from it. This frame or field will be used to build a noise profile 
necessary to filter the whole clip. 

To scroll and pan the frame 
• press the spacebar and drag the frame with the left mouse button. 

To change zoom level 
• use the mouse wheel when mouse is over the viewer; 
• use the zoom controls under the viewer; 
• use the Cmd+Plus, Cmd+Minus, Cmd+0 (zero), Cmd+Alt+0 (zero) keyboard shortcuts. 

5.4. Stage IV. Prepare a device noise profile 
To filter the noise in the clip, Neat Video needs to know the characteristics of noise produced by the 
input device (video camera, TV-tuner, etc.) that the video comes from. The noise characteristics of a 
device working in a certain mode constitute a device noise profile. 

There are two ways to get a device noise profile for the video clip: 

• To build a new profile using the selected frame from the clip; 
• To select a suitable profile from a pre-built set of profiles. 

The first option is often the easiest one provided the selected frame contains sufficiently-large uniform 
featureless areas that include noise and no visible or important details. Neat Video can try to 
automatically find such areas in the frame and analyze noise in them to build a noise profile. When the 

                                                           
1 We will use the term “frame” to refer to both variants: frame (in progressive video) or field (in interlaced video). 
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selected frame contains featureless areas suitable for analysis, this way of preparing a noise profile is the 
most accurate and therefore recommended. 

The second option is available once you have already built and saved several profiles for various modes 
of your video capturing device. 

To build a new profile using the selected frame from the clip 

 Make sure you use the Device Noise Profile tab:  

 Click    (the Auto Profile button). 

Neat Video will find and select the area selected by Auto Profile for main analysis. Neat Video will 
then automatically analyze the noise in that area (and then in the whole frame too) to build a new 
noise profile. 

In difficult cases, Neat Video may be not able to find a large enough uniform featureless area in the 
frame. You will notice that the selected area, for example, will contain some important details, not 
just noise. In such cases, Neat Video also warns you that the area is not suitable for analysis. It may 
say that the selected area is not uniform in one or more channels, or is too small, or contains 
clipping in one or more channels. In such a case, move the selection (or resize, or draw a new one) 
to an area that does not contain any visible details and then click the same Auto Profile button again. 

After the profile is built, check the Quality indicator in the Device Noise Profile box. A profile built 
using a uniform and featureless area will usually show a high value in this indicator. If the profile 
quality is high (for example, higher than 60%) then you can be sure that the noise profile is 
accurate. In this case, proceed to Stage V. Adjust intra-frame filter settings, page 9. 

If the quality is not high, try to select another uniform and featureless area and use Auto Profile again. 
That may not help still, especially if the selected frame contains only small featureless areas. In this 
case, consider building a noise profile using another frame from the same clip: close the Neat Video 

plug-in window and return to Stage II. Select a frame for noise analysis, page 7. 

You can also try to build a profile in manual mode. However, this will anyway require some 
featureless areas to be available for analysis. You can find more details on automatic and manual 
profiling in the Device noise profiles section, page 16. 

To select a noise profile from a pre-built profile set 

 Click    (the Load Profile button). Then select a profile in the Open Device Noise 

Profile dialog. 
 
or 

 Click    (the drop-down button) in the Device Noise Profile box to open the popup menu with all 
available profiles and then select one of the available profiles. 

Please note that you have either to build your own profiles or download some pre-built profiles and 
place them to the Neat Video’s Profile folder to make this drop-down button and popup menu truly 
work. By default, the Profile folder is located in your home folder1: 
  /Users/<username>/Documents/Neat Video for Final Cut/Profiles/ 

If you build or download some pre-built profiles, save them to that folder and Neat Video will show 
those profiles in the popup menu to help you quickly re-open any of the profiles. 

To additionally fine-tune the loaded profile 
You may want to additionally fine-tune the profile you have just opened. Fine-tuning usually makes 
the profile more accurate and better matching the noise in the current clip. 

 Click    (the Auto Fine-Tune button) to fine-tune the loaded profile to the current 
clip. 

                                                           
1 You can check and adjust the location of that folder in menu: Tools > Preferences > Folders > Profile folder. 
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There is no need to select any area in the frame because the Auto Fine-Tune automatically analyzes 
the whole frame. 

Please note that you do not need to fine-tune a profile if you have just built it using Auto Profile. Auto 

Profile automatically applies fine-tuning so you do not need to repeat it. 

5.5. Stage V. Adjust intra-frame filter settings 

 Make sure you use the Noise Filter Settings tab:  

The Neat Video noise reduction and sharpening filters have several settings that you can adjust. Default 
noise filter settings are based on the noise analysis provided by the noise profile; these settings usually 
produce good filtration results if the noise profile is accurate. You may want to additionally vary the 
filter settings to achieve the filtration results that look best to your eyes. 

5.5.1. Use intra-frame preview when adjusting filter settings 
The viewer in the Noise Filter Settings tab shows a part of the frame processed by the noise and sharpening 
filters. If you change any filter settings then the preview is automatically updated (provided the Preview 
button in the toolbar is depressed). You can zoom in and out, drag, scroll, pan the frame in the Preview 
box to see how the filtration affects different parts of the frame. If you manually select an area in the 
frame then only the selected area will be processed for preview. 

When the preview is ready (the preview area shows “Filtered”), click inside the preview area to 
temporarily switch back to the original for comparison. 

5.5.2. Standard and Advanced modes 
Neat Video has two sets of filter controls, they are available in the Standard mode and Advanced mode 
(you can select the mode using the Tools > Standard mode and Advanced Mode menu items). The Standard 

mode provides a simple control set, recommended for beginners who just start using Neat Video. The 
Advanced mode provides the most complete control set with maximum manual control over noise 
profiling and filtration processes. The Advanced mode is recommended for power users. Adjusting filter 
settings is described below separately for the Standard and Advanced mode. We recommend to start with 
the part about the Standard mode and then proceed to the part about the Advanced mode if you are going to 
use the complete control set. 

5.5.3. Adjust filter settings in Standard mode 
There are two main filters in Neat Video: noise reduction filter and sharpening filter. These two filters 
can be used together and each of them can be used independently. You can enable, disable and adjust 
these filters using the guidelines in the subsections below. 

Adjusting noise filter settings in Standard mode 
When you work with a color clip, two components of the video information can be distinguished: the 
luminance and chrominance component. This distinction is very useful from the standpoint of noise 
reduction because it allows processing luminance and chrominance information separately by the noise 
filter. 

Some color clips are represented in color spaces that enable direct separation of the luminance and 
chrominance components (for example, the YCrCb / YUV / YPrPb color spaces). Other clips (including 
RGB data that Neat Video usually takes as input) have to be converted to another representation to 
enable separation of the luminance and chrominance components. 
Neat Video applies an internal color space conversion to achieve 
that (by default, Neat Video converts an RGB input frame to the 
YCrCb working color space). Once luminance and chrominance 
components of the video information are separated, Neat Video 
can treat them individually. Neat Video provides separate 
luminance and chrominance settings in the noise filter (see on the 
right). 

In the Standard mode, the noise reduction applied to one video 
component (either luminance or chrominance component) is 



User Guide Neat Video plug-in for Final Cut (Mac OSX) 
  

  
Neat Video © 1999-2011 Neat Video team, ABSoft. All rights reserved.  10 8-Jul-11

controlled by the corresponding noise reduction amount setting. 

A noise reduction amount tells the filter how much of the detected noise should be reduced. For 
example, if the noise reduction amount is set to 50% then all elements that are considered (by the filter) 
to be noise are reduced (made weaker) in half. The noise reduction amount value of 100% tells the filter 
to remove the detected noise completely. 

The default noise reduction amounts usually produce good filtration results provided the noise profile is 
accurate1. By default, the noise filter removes 60% of detected noise in the luminance channel and 
100% of noise in the chrominance channels. Our experience shows that the default noise reduction 
amounts usually provide a good balance between noise removal and preserving natural (not 
over-processed) appearance of filtered footage. 

Adjust noise reduction amounts2 

 Use the Noise Reduction Amounts: Luminance and Chrominance sliders. 

You can vary the noise reduction amount for each frequency and channel component of the video 
clip. The higher a certain noise reduction amount, the more of the detected noise is removed in the 
corresponding component. Be careful, setting the noise 
reduction amounts too high, especially in the luminance (Y) 
channel, may lead to loss of fine details and unnaturally 
looking (over-smooth, plastic-like) results. Too low amounts 
may be not enough to sufficiently reduce the objectionable 
part of the noise. You have to balance the noise reduction 
amounts (most importantly, the amount of noise reduction in 
the luminance channel, Y) to get the result that looks best to your eyes. 

Use intra-frame preview 

 Use the intra-frame preview when adjusting the noise filter settings. 

After you have made changes to the noise filter parameters, do not forget to check the preview. Use 
the preview on different parts of the frame to get a better feeling for the results of noise reduction. 

If the noise filtration looks too strong try to decrease the noise reduction amounts for appropriate 
components. If the noise filtration is not sufficient then increase the amounts. 
 

Adjusting sharpening settings in Standard mode (optional) 
The sharpening filter in Neat Video increases sharpness of the video clip without increasing the noise 
strength. 

The sharpening filter is disabled (sharpening amount is set to 0%) by default. Increase the sharpening 
amount to sharpen the video. Like with any sharpening method, you have to balance the sharpening 
amount to avoid over-sharpening. 

Use the preview when adjusting the sharpening. 

Adjust sharpening amount 

 Use the Sharpening: Amount slider. 

Specify how much sharpening should be applied to the frame. 

Use intra-frame preview 

 Use the preview when adjusting the sharpening setting. 

As you make changes to the sharpening setting, do not forget 
to check the preview. Use the preview on different parts of the frame to get a better feeling for the 

                                                           
1 Use the Quality indicator in the Device Noise Profile box to estimate the accuracy of the profile. The indicator shows 

how accurate and complete is the noise analysis itself. Higher values usually lead to more accurate noise reduction. 
2 We recommend disabling the sharpening filter when adjusting the noise filter. To disable the sharpening filter, set the 

Sharpening: Amount to 0%. 

As human vision is not very 
sensitive to variations of colors, 
strong filtration in the chrominance 
component does not noticeably 
distort video clip, but efficiently 
removes color noise. 
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results of sharpening. 

As soon as you are happy with the preview results regarding both noise reduction and sharpening, 
proceed to save the filter settings into a preset (see page 14), or directly to Apply intra-frame filter 
settings, page 14. 

5.5.4. Adjust filter settings (Advanced mode) 
As said above, Neat Video has two sets of filter controls, that are available in the Standard mode and 
Advanced mode (you can select the mode using the Tools > Standard mode and Advanced Mode menu items). 
The Standard mode described above provides a simple control set, recommended for beginners who just 
start using Neat Video. The Advanced mode provides the most complete control set with maximum 
manual control over noise profiling and filtration processes. The Advanced mode is recommended for 
power users. If you want to use the Advanced mode then please read this sub-section. 

As compared with the Standard mode, the Advanced mode offers a more extensive set of filter controls. 
There are also two filters – noise reduction filter and sharpening filter – but these have more settings 
now. Please follow the guidelines below to adjust both filters. 

Adjusting noise filter settings in Advanced mode 
In Advanced mode, the noise filter has separate settings for all (spatial) frequency and channel 
components of the video data. There are also pairs of noise level - noise reduction amount controls for 
each of these video components. The meaning of each noise level 
- noise reduction amount pair is the following: 

• a noise level control adjusts the threshold that determines 
which elements are considered noise in the corresponding 
video component and which elements are considered details; 
 

• a noise reduction amount control determines how much 
reduction is applied to the elements identified as noise in the 
same video component. 

In Advanced mode, you can adjust the noise levels as well as noise 
reduction amounts for each video component. The noise levels are 
adjusted relative to the noise levels of the current noise profile that 
have been measured during profiling. 

For example, the noise level of the Y (luminance) channel could be 
measured in the noise profile at 8.55 units.1 This number tells the 
noise filter which elements should be considered noise and which 
– details: the elements that are weaker than 8.55 units are 
considered noise and reduced by the noise filter; the elements that 
are stronger than 8.55 units are considered details and preserved. 

 

If you do not change the default noise filter settings (Noise Levels: Y: +0%) then noise reduction in the Y 
channel is completely determined by the measured number from the noise profile (8.55 units). 
However, if you do adjust the filter setting for the Y noise level then this adjustment is also taken into 
account. For example, if you set the Noise Levels: Y control to +15% then what is considered by the noise 
filter as the actual noise level is: 

 8.55 * (100% + 15%) => 9.83 units 

With this adjustment, the elements in the Y channel that are weaker than 9.83 units are considered noise 
and reduced, and elements that are stronger than 9.83 units are preserved. 

Thus, with a noise level - noise reduction amount pair of settings you can adjust what should be 
considered noise in a component of the video data and how much of this noise should be reduced. You 
have access to six such pairs – three for channel components (Y, Cr, Cb) and three for spatial frequency 
components (High, Mid, Low) of the video data. 

Because the noise level controls are relative to the device noise profile, the default filter settings usually 

                                                           
1 All measured noise levels are shown in the Profile Viewer (use the menu Profile > Profile Viewer to open it). 
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produce good results when the noise profile is accurate1. The noise level defaults are 0%, which means 
the noise levels are completely determined by the noise profile. When you adjust the level controls, the 
noise level estimations are raised or lowered accordingly. A noise level control can be in the range from 
–100%, which means no elements are considered noise, and therefore, no noise reduction is applied in 
the corresponding component; to +150%, which means noise reduction is applied to the elements that 
are weaker than 250% of the profile’s noise level. 

Noise reduction amounts can be in the range from 0% (none of the detected noise is removed) to 100% 
(all the detected noise is removed). By default, the noise filter removes 100% of detected noise in all but 
the luminance (Y) channel where only 60% of detected noise is removed. 

Decreasing the noise reduction amounts can have a positive effect if the video clip contains some 
natural noise. For example, when you filter a clip including asphalt, sand, or anything else that contains 
fine natural noise-like features, it may be helpful to reduce amounts down to 30-50%. Our experience 
shows that these values generally provide a good balance between preserving video details and noise 
removal. 

Adjust noise reduction amounts2 

 Use the Noise Reduction Amounts: High, Mid, Low; Y, Cr, Cb sliders. 

You can vary the noise reduction amount for each frequency and channel component of the video 
data. The higher a certain noise reduction amount, the more of the detected noise is removed in the 
corresponding component. Be careful, setting the noise reduction amounts too high, especially in 
the luminance (Y) channel, may lead to loss of fine details and 
unnaturally looking (over-smooth, plastic-like) results. Too 
low amounts may be not enough to sufficiently reduce the 
objectionable part of the noise. You have to balance the noise 
reduction amounts (most importantly, the amount of noise 
reduction in the luminance channel, Y) to get the result that 
looks best to your eyes. 

Adjust additional filter settings (optional) 

 If the clip contains strong low frequency3 noise then you may want to enable the Very low freq option 
in the Noise Filter Settings box. 

 Check the Smooth edges option to make edges and lines in the clip look smoother. 

 Check the High quality option to enable higher-quality noise reduction filter. This will slightly slow 
down processing but will deliver the most accurate results in return. 

 Check the High resolution option to enable the higher-resolution noise filter. This may be useful when 
processing clips with very fine details that should be better preserved by the filter. 

Use intra-frame preview 

 Use the intra-frame preview when adjusting the noise filter settings. 

After you have made changes to the noise filter parameters, do not forget to check the preview. Use 
the preview on different parts of the frame to get a better feeling for the results of noise reduction. 

If the noise filtration looks too strong try to decrease the noise reduction amounts for appropriate 
channel or frequency components. If the noise filtration is not sufficient then increase the amounts. 
 

                                                           
1 Use the Quality indicator in the Device Noise Profile box to estimate the accuracy of the profile. The indicator shows 

how accurate and complete is the noise profile itself. Higher values usually lead to more accurate noise reduction. 
2 We recommend disabling the sharpening filter when adjusting the noise filter. To disable the sharpening filter, 

uncheck all channels in the Sharpening Settings box. 
3 See “what is frequency” question in page 25. 

As human vision is not very 
sensitive to variations of colors, 
strong filtration in the chrominance 
channels (Cr, Cb) does not 
noticeably distort video clip, but 
efficiently reduces color noise. 
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Adjust noise levels (only when necessary) 

Usually it is not necessary to change the noise levels if the noise profile is accurate. You only have to 
adjust the noise levels if you see that some noise elements are not reduced even if you set the noise 
reduction amounts to 100%. Such residual noise elements are usually caused by an inaccurate noise 
profile providing inaccurate noise level estimations to the noise filter. This may be compensated by 
adjusting (increasing) the noise levels in the filter settings. 

 Use the Noise Levels: High, Mid, Low; Y, Cr, Cb sliders. 

The noise filter has access to three frequency components and three channel components of the 
video data. Corresponding sliders adjust the estimated noise levels for each of these components. 

The higher a certain noise level, the more elements in the corresponding component are considered 
noise. Be careful, setting a noise level setting too high can lead to removal of important details. 
Setting a noise level setting too low can lead to incomplete filtration: residual noise and 
compression artifacts can stay in the filtered clip. 

As a rule, if the device noise profile has been built properly, it is not necessary to increase the noise 
levels by more than 50%. If the clip contains strong surges of noise in the high frequency range, it is 
recommended to increase the high frequency noise level up to +20 to 40%. 

If the clip contains strong color noise, it is recommended to increase the Cr and Cb noise levels to 
+30%. In some cases, it may be useful to increase these noise levels up to +100%. 

If adjusting noise levels still does not help and some noise elements remain in the filtered clip, 
probably the device noise profile is not good at all. Return to Stage IV, page 7, and additionally 
fine-tune the device noise profile or simply rebuild the profile from scratch. 

 

Adjusting sharpening settings in Advanced mode (optional) 
The sharpening filter is designed to increase sharpness of the clip without increasing the noise strength. 

The default values of the sharpening settings should produce satisfactory results (when sharpening is 
enabled for any of the channel components) but you are encouraged to vary the settings to find values 
that produce the desired level of sharpness. Zero sharpening amounts will not sharpen the clip at all. The 
non-zero sharpening amounts will apply sharpening of the specified strength. Use sharpening controls 
for different frequency components to sharpen fine, medium or large details. As with any other 
sharpening method, you have to balance the amounts to avoid over-sharpening. 

Use the intra-frame preview when adjusting the sharpening settings. 

Select color channels where sharpening should be applied 

 Use checkboxes in the Sharpening section. 

Usually you only want to sharpen the luminance channel – Y. 

Select sharpening mode 

 Check the Conservative checkbox to enable more accurate 
sharpening, which produces much less halo effect around 
sharpened details. 

Adjust sharpening amounts 

 Use the High, Mid and Low sliders in the Sharpening section. 

Specify how much sharpening should be applied to each frequency component of the clip. 

Use intra-frame preview 

 Use the preview when adjusting the sharpening settings. 

After you have made changes to the sharpening settings, do not forget to check the preview. Use the 
preview on different parts of the frame to get a better feeling for the results of sharpening. 
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As soon as you are happy with the preview results regarding both noise reduction and sharpening, 
proceed to save the filter settings into a preset (below), or directly to Apply intra-frame filter settings, 
page 14. 

 

5.5.5. Save intra-frame filter settings into a preset (optional) 
To save the filter settings into a preset 

 Click    (the Save filter settings as preset… button) in the Filter Settings box. 
 

In the Save Filter Preset dialog box, specify the name of the file to save the preset. The filter presets 
are stored in *.nfp files. 

Saved filter preset includes the noise filter and sharpening settings. By re-opening a preset, you can 
reproduce exactly the same intra-frame filter settings later on. Together, a device noise profile and a 
filter preset can be used to accurately reproduce the filtration results. 

To open a previously saved filter preset 

 Click    (the Load filter preset… button) in the Filter Settings box. In the Load Filter Preset dialog box, 
specify the name of the filter preset to be opened. 

or 

 Click    (the drop-down button) in the Filter Settings box to open the popup menu with all 
available presets and then select one of them. 

There are several pre-written filter presets in your home folder1: 
  /Users/<username>/Documents/Neat Video for Final Cut/Presets/ 

Please explore these presets to see what combinations and values of the noise and sharpening filter’s 
settings can be used to solve typical tasks (names of the presets explain these tasks). 

 

5.5.6. Apply intra-frame filter settings 
After you have prepared a noise profile and adjusted the intra-frame filter settings, you have to apply 
these changes. 

To apply intra-frame filter settings 

 Click    (the Apply button in the bottom of the plug-in window). 

The Neat Video plug-in window will be closed and the plug-in will automatically save the device 
noise profile and filter preset in the Final Cut project your work with. If you later re-open the Neat 

Video plug-in window, the plug-in will automatically pick up saved noise profile and noise filter 
settings. 

5.6. Stage VI. Adjust temporal filter settings 
Besides the intra-frame filtration (that you configured in the previous section) Neat Video also applies 
temporal (inter-frame) filtration to the video clip. Temporal filtration allows Neat Video to improve the 
overall quality of noise reduction. Neat Video uses several consequent frames to better reduce noise and 
preserve more true details in each frame. 

You can adjust the temporal filter settings using the Neat Video controls available in the Filters panel in 
Final Cut. 

                                                           
1 You can check and adjust the location of that folder: use the menu Tools > Preferences > Folders > Preset folder. 
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To adjust temporal filter settings 

Adjust Temporal filter radius 

The Temporal filter radius setting determines the number of consequent frames used for temporal filtration. 
Higher values of this setting lead to more aggressive (and slower) temporal filtration. Lower values lead 
to less aggressive (and faster) filtration based on a small number of consequent frames. Zero value 
disables temporal filtration completely. The default value is 1, which means three consequent frames 
(the current one, one before and one after the current one) are used for temporal filtration. 

 Use the Temporal filter radius control in the Effect Controls window. 

Adjust Temporal filter threshold 
The Temporal filter threshold setting determines how sensitive the filter is to changes (for example, motion 
of objects) in consequent frames. Higher values of this setting lead to more aggressive filtration with 
less attention to temporal changes (lower motion sensitivity). Lower values lead to less aggressive 
filtration with more attention to temporal changes and better preservation of moving details (higher 
motion sensitivity). 

 Use the Temporal filter threshold control in the Effect Controls window. 

Use preview 

While adjusting the temporal filter settings, use the Final Cut preview facilities (use the Sequence > 

Render Selection menu) to get better feeling for the results of Neat Video filtration. Try to render a part of 
the clip to see the effect of both intra-frame and temporal filters. 

 

5.7. Stage VII. Adjust adaptive filtration 
Enable or disable adaptive filtration 

The noise properties of the video data may vary in different parts of the clip. Neat Video can 
automatically adjust its filters to the changing noise when this option is enabled. If the noise is the same 
in different parts of the clip then this option can be left disabled. 

 Enable the Adaptive filtration option to let Neat Video automatically adjust its filters to the changing 
noise in the clip. 

 

5.8. Stage VIII. Render the clip 
To apply Neat Video noise reduction 

 Render the clip in Final Cut in the 
regular way. This will automatically 
apply Neat Video noise reduction to the 
clip.

Neat Video is a processor-intensive filter, and the 
processor's speed is the most critical. On Core 2 Duo 3.26 
GHz, Neat Video v2.x processes a 352x288 video clip at 
the speed of 16-25 fps depending on filter settings. On a 
computer of typical configuration, the processing time is 
linear with respect to the length of the clip. 
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6. Device noise profiles 
A device noise profile (or noise profile, or simply profile) describes the properties of visible noise 
produced by a video capturing device (e.g., a video camera, camcorder, computer TV-tuner, film 
digitizer, etc.) working in a certain mode. Several noise profiles corresponding to different modes of a 
device constitute a profile set for this device. Neat Video can use a profile from a profile set to process a 
video clip produced by a device working in the corresponding device mode. 

You can easily build noise profiles for your video capturing device. Learn how to build and use device 
noise profiles in Neat Video in the subsections 6.1-6.3 below. 

6.1. Building a profile for a device mode (standard 
profiling procedure) 

This subsection explains how to build a single noise profile for a video clip produced in a certain device 
mode. 

Building a new noise profile using the current version of Neat Video plug-in includes three stages: 

Stage I. Building a profile; 
Stage II. Documenting the profile; 
Stage III. Saving the profile. 

 

6.1.1. Stage I. Building a profile 
To build a noise profile for a video clip you have to take these steps: 

Step 1. Selecting a frame suitable for noise analysis; 
Step 2. Analyzing the noise. 

 

Step 1. Selecting a frame suitable for noise analysis 
To build an accurate noise profile, Neat Video has to analyze a specific frame from the video clip. This 
frame should include uniform featureless areas containing only noise without real details. 

A uniform area (with minor variation in all color channels) may be overcast sky, clear sky (without 
clouds and birds), or any other part of a suitable frame, where there are no visually perceptible details 
(except the noise). Neat Video needs to analyze a uniform featureless area of around 128x128 pixels 
(the minimum size is 32x32 pixels). 

In Final Cut, find a frame in the video clip that contains flat featureless areas and use this frame to build 
a noise profile: 

 1. In the Timeline window, use the Current Time Indicator to find a frame with large flat featureless 
areas; selected frame will be used for noise analysis in the next steps. 

2. In the Filters panel, click the Options… button in the Options section of Neat Video filter settings. 

The Neat Video plug-in window will appear and will show the currently selected frame. 

 

Step 2. Analyzing the noise (profiling) 
Analyzing noise (profiling) is the main part of building a noise profile. This version of Neat Video 
offers three ways of conducting the noise analysis (profiling): automatic, semi-automatic and manual 
one. Using automatic profiling is easier and therefore recommended for beginners. In difficult cases (for 
example if Neat Video cannot automatically find a uniform featureless area in the analyzed frame), 
automatic profiling may not work or produce less than perfect results. You can always override 
automatics and use semi-automatic or manual profiling. 

 Make sure you use the Device Noise Profile tab:  
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Case of automatic profiling 

To analyze the noise properties of the video clip, Neat Video uses uniform areas of the frame. Such 
areas should contain noise but no visible or important details. With automatic profiling, Neat Video 
tries to find one such area automatically and then uses this area to analyze noise. 

 Click    (the Auto Profile button). 

Neat Video will automatically find and show the frame area selected for analysis and will analyze it 
automatically. If the selected area shown in viewer indeed contains no visible details then the 
resulting noise profile will be accurate. 

In difficult cases, Neat Video may have trouble finding a uniform featureless area in the frame. You 
will notice that the selected area, for example, will contain some important details. In such a case, 
use the semi-automatic profiling instead (see below). 

If you see that the area automatically selected for analysis is indeed uniform and featureless, then 
the resulting noise analysis is accurate. To be sure, check the Quality indicator in the Device Noise 

Profile box. A profile built using a uniform and featureless area will usually show a high value in this 
indicator. 

If the profile quality is high (for example, higher than 75%) then you can be sure that the noise 
profile is accurate. In this case, proceed to Stage II. Documenting the noise profile, page 18. 

If the quality is not high, try to use the semi-automatic profiling instead (see below).  
 

Case of semi-automatic profiling 

1) Find a uniform featureless area 

 Manually find and select an area that contains no visible details.1 
 
The area should be at least 32x32 pixels large. That is the minimum size; the recommended size is 
128x128 pixels or more (you can resize the selection frame). 
 
Scroll, pan, zoom the frame to find a uniform area. Set the selection to the found uniform area. 
 
If you cannot find a uniform area in the frame, try to use another frame from the same video clip.  
 

2) Analyze selected area 

 Click    (the Auto Profile button). 

Neat Video will automatically analyze the selected area and build a noise profile. 

At this point the profile is ready. Proceed to Stage II. Documenting the noise profile. 
 

Case of manual profiling 

1) Find a uniform featureless area 

 Manually find and select an area that contains no visible details.  
 
The area should be at least 32x32 pixels large. This is the minimum size; the recommended size is 
128x128 pixels or more (you can resize the selection frame). 
 

2) Analyze selected area 

 Click    (the Auto Profile button). 

Neat Video will automatically analyze the selected area and build a noise profile. 

                                                           
1 You can see some examples of uniform featureless areas in the Examples section, page 23. 
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3) Additionally manually fine-tune the profile 

Fine-tuning uses additional flat featureless frame areas to make the noise profile more accurate. 
You have to manually select and analyze several such areas one after another. 

1) Find and select a uniform featureless area 

 Scroll, pan, zoom the frame in the viewer in the Device Noise Profile tab to find a new uniform area. 

The size of an area may be from 16x16 to 256x256 pixels. Using larger areas makes fine-tuning 
more accurate. The selection edges will change their thickness according to the selection size. 
 

2) Analyze selected area with Manual Fine-Tune 

 Click    (the Manual Fine-Tune button) or select the Profile | Fine-Tune Using Selected Area menu item. 

The analysis results will be shown in the noise profile equalizer: the graphs of the equalizer will 
change some of the values (see the picture on the right). You 
can switch from one channel to another in the equalizer to 
better see a specific channel’s graph, or select to show them all 
together. 

The goal of manual fine-tuning is to fill the equalizer with 
measured values (shown as graph-color knots) in all points of 
the graphs. The previous steps (specifically, the Auto Profile 
function) may have already filled some of the values. Manual 
fine-tuning can further improve the analysis by filling out the 
still missing or interpolated values (shown as yellow knots) 
and/or making some of already measured values more precise. 
 

3) Repeat 1-2 above with other uniform areas of different brightness 

To make a device noise profile more accurate, fine-tune it using several uniform areas of the frame. 
Select areas of different brightness for best results. Try to choose and analyze uniform areas to 
cover all or most elements of the equalizer in all its color channels. The more elements of profile are 
analyzed, the higher is the quality of the profile. 
 

4) Complete fine-tuning using Auto Complete 

 Click  (the Auto Complete button) or select the Profile | Auto Complete menu item to automatically 
complete the fine-tuning by adjusting the unmeasured values using interpolation based on the 
measured data. 

At this point the profile is ready. Proceed to Stage II. Documenting the noise profile. 

 

6.1.2. Stage II. Documenting the noise profile 
At this point the noise analysis is done and all important noise 
characteristics are gathered in the profile. However, you may still 
want to manually document the profile by describing the video 
capturing device and its mode. 

 Use the Device Name and Mode fields in the Device Noise Profile 
box to specify the model of the video capturing device and 
describe the device mode used to capture the profiled clip. 

It is highly recommended to specify these details to keep 
record of devices, device modes, and corresponding device 
noise profiles that you use. 

The noise characteristics of any two devices can be extremely 
different. Even a single device in different modes can produce 
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significantly different noise. Therefore, it is always better to use separate noise profiles for different 
devices and device modes to avoid inaccurate filtration and artifacts. Commenting on the device 
name and device mode parameters will help you re-use a noise profile later on when you will look 
for a suitable profile to process a video clip. 

There may be many device parameters but not all of them influence noise and those that do differ by 
the strength of their influence. It makes sense to document those parameters only that appreciably 
affect noise. In the tables below, those parameters are described that usually appreciably affect 
noise characteristics (from the most to the less important ones) for video capturing devices: 
 

Video capturing device parameters in the order of decreasing importance 

Sensitivity of 
light-capturing 
device 

Film type and sensitivity (for 
digitized analog video), 
effective sensor sensitivity 
(for digital video), etc. 

More sensitive light-capturing devices / media 
usually produce stronger noise. 

Compression 
of video clip 

Video compression method / 
mode used 

Stronger compression typically produces more 
artifacts and destroys details; weaker 
compression preserves more details. It is 
preferable to use the lowest amount of 
compression possible for the best results. 

Resolution/ 
frame size 

1920x1080, 1366x768, 
1280x720, 720x576, 
512x384, 352x288, etc. 

Video clips in different resolutions usually 
have very different noise characteristics. 

 
If two video clips were produced by the same device in the same or similar conditions (most of the 
above device mode parameters are the same) then the noise of these two clips should be very 
similar. If you have built a device noise profile using one of these clips, you can use this profile to 
filter both clips with good results. If however, the conditions were different then the noise in two 
clips could be significantly different. In this case, cross-use of the noise profile is not 
recommended. Instead, two different profiles should be built and used to filter these two clips. 

6.1.3. Stage III. Saving the noise profile 

 Use    (the Save Device Noise Profile As… button) in the Device Noise Profile box. 

 
In the Save Device Noise Profile As… dialog box, specify a meaningful file name and save the profile to 
the hard drive. Device noise profile are saved in *.dnp files. 

File naming considerations 

If you are going to re-use the device noise profile, select a good file name explaining the device 
name and mode so that you could easily recognize this profile by its file name later on. 
Alternatively, you can use special folder structuring to keep many device noise profiles arranged 
according to their device modes. 

Saved noise profile includes a complete noise analysis. Therefore, by re-opening the noise profile 
with another clip, you can reproduce exactly the same conditions for noise reduction later on. 

6.2. Using noise profiles 
When you have a set of profiles for your video capturing device, you can directly use these profiles to 
process clip in Neat Video. Usually the set contains only one profile that is most suitable to process a 
given clip. Therefore it is very important to select the right profile, which would provide good match 
between profile and clip. Profiles in a profile set usually have been built for different device modes and 
to make a perfect match between a profile and a clip, the device mode of this profile should be the same 
or very close to the device mode used to capture this clip. In the current version of Neat Video, you have 
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to manually select a device noise profile that matches the video clip based on profile descriptions and 
file names. 

Obviously it is preferable to build a new noise profile for each clip, because such a profile would 
perfectly match the noise of that clip. Nevertheless, any noise profile can, with some degree of 
accuracy, be used to process other clips captured by the same device working in the same or similar 
mode. This is less accurate than building a profile for each clip but saves time because building a new 
profile usually takes more time than re-using a ready-made one.
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7. Preferences 
There are several preferences that adjust the behavior of the Neat Video plug-in. 

Use the Tools > Preferences menu item to open the Preferences dialog box. 

7.1. General preferences 
On opening plug-in window 

Do not change viewer zoom and window size 

Use this option to not let Neat Video automatically modify the window size and zoom level when 
opening the Neat Video plug-in. The Neat Video window will remember its size from the last time and 
will not try to adjust its size and viewer zoom to show the whole frame. The initial zoom level will be 
100%. 

Adjust viewer zoom to fit frame to window 

Use this option to make the Neat Video viewer automatically adjust the zoom level to fit the whole 
frame into the viewer window, without modifying the window size. The Neat Video window will 
remember its size from the last time. 

Adjust window size to accommodate whole frame 
Use this option to make the Neat Video windows automatically adjust its window size (and if necessary, 
the viewer zoom level as well) to accommodate the whole frame when opening the Neat Video plug-in. 
 

Show hints over interface controls 
This option switches on/off the hints explaining the purpose of Neat Video controls (like a button, 
slider, etc.). The hints are displayed when the mouse pointer is placed over controls in the Neat Video 
interface. 
 

7.2. Profiling preferences 
Save noise samples in profiles 

Enable this option to make Neat Video save a noise sample from the analyzed frame area into device 
noise profile (*.dnp file). This will increase the size of the *.dnp file but will also improve the 
compatibility with the future versions of the software (Neat Video will be able to re-build the profile 
using the saved noise sample). 

Show warnings about selected frame areas 
Enable this option to let Neat Video display warnings about selected frame areas during profiling. For 
example, Neat Video may warn you about clipping or non-uniformity detected in the selected area, thus 
helping you select a better area for profiling. 
 

7.3. Performance preferences 
CPU: Number of used cores 

This option adjusts the number of cores used by Neat Video for processing. The number of used cores 
can go up to the total number of cores in all CPUs in your computer (like 2 cores in Core Duo, 4 cores in 
Core Quad, 8 cores in a desktop version of i7 with enabled hyperthreading, etc.). If the computer 
includes two physical CPUs then the number of cores is correspondingly higher. Ideally, using all cores 
should provide the best overall performance. In some cases however, processing speed may be even 
higher if fewer cores are used (especially on CPUs with hyperthreading). For example, using fewer than 
all 8 virtual cores in i7 is in some cases faster, so you may want to test different values of this setting. 
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7.4. Folders preferences 
Profile folder 

Select the folder where Neat Video will store device noise profiles. This should be the topmost folder of 
all the (sub)folders with device noise profiles. Neat Video will display all profiles (stored in all 
subfolders of the specified folder) in the popup menu in the Device noise profile panel of the plug-in 
window and in other parts of Neat Video. 

By default, the Profile folder is located in your home folder: 
  /Users/<username>/Documents/Neat Video for Final Cut/Profiles/ 

You can select another location to store and use your Neat Video profiles if you prefer. 

Preset folder 
Select the folder where Neat Video will look for filter presets. This should be the topmost folder of all 
the (sub)folders with filter presets. Neat Video will display all presets (stored in all subfolders of the 
specified folder) in the popup menu in the Filter Settings panel of the plug-in window and in other parts of 
Neat Video. 

By default, the Preset folder is located in your home folder: 
  /Users/<username>/Documents/Neat Video for Final Cut/Presets/ 

You can select another location to store and use your Neat Video presets if you prefer. 
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8. Examples 

8.1. Building a noise profile 
See the picture below for examples of areas that are good and bad for building device noise profiles. 
Here, the areas suitable for profiling are highlighted in green; those that should not be used are 
highlighted in red. Note that a frame area suitable for building a device noise profile should be at least 
32x32 pixel large (preferably more than 128x128 pixels). 

 
Additional comments regarding these areas are available in the next page. 
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These areas can be used to build device noise profiles, as they contain no visible details: 

 

– GOOD, because this area contains no important details 

  

 

– GOOD, no important details (this area is from another frame) 

 

The following areas should not be used to build device noise profiles, because they contain details: 

 

– BAD, because this area contains a detail: corner – junction of 
wall and ceiling 

  

 

– UNACCEPTABLE, because this area contains many details 

  

 

– BAD, because this area contains some details: clouds (this area 
is from another source) 

 

 

8.2. Filtration results 
Please see examples of noise reduction applied to video clips in the Neat Video web page: 
http://www.neatvideo.com/examples.html 

 

http://www.neatvideo.com/examples.html�
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9. Questions and answers 

9.1. General questions 
Q What is the difference between Neat Video Demo, Home and Pro plug-in? 

A The Demo plug-in has some functional limitations. For example, it can only process short video clips 
with limited frame size. Please see the Detailed feature map, page 27, for more details. 

Q Should I uninstall Demo plug-in prior to installing the Home / Pro plug-in? 

A This is not necessary. You can install the Home / Pro plug-in over the Demo plug-in. 

Q Should I uninstall the older version of Neat Video prior to installing a newer one? 

A This is not necessary. You can install a newer version of Neat Video over the older one. 

Q I think I have found a bug. How can I submit a bug report? 

A Please use the online bug report form: http://www.neatvideo.com/brf.html  
Please fill it out to let us know all the details necessary to reproduce the problem. 
 
See more information about bugs in the Known issues section in Neat Video webpage 
( http://www.neatvideo.com/bugs.html ) and about bug fixes in the WhatsNew.txt  file supplied with 
the software (also see the history section on the web page for the most up to date information: 
http://www.neatvideo.com/history.html ). 
 

9.2. Filtration-related questions 
Q Why do I receive some crystal-like artifacts in the filtered frame? 

A The crystal-like artifacts (usually these are the residual compression artifacts or residual noise) look 
like thin lines in the filtered frame. They can be easily eliminated by increasing the high frequency 
noise level in the filter settings. 
Note: presence of many residual artifacts is usually a consequence of using a poorly built, inaccurate 
noise profile or a profile built for another device and/or device mode. 

Q Filtered frame looks 'plastic'. Why? 

A The reason is that too much filtration was applied. Let Neat Video keep some noise to have 
natural-looking results. Adjust the noise reduction amounts; for example, reduce the noise reduction 
amount in the luminance (Y) channel to 50-70%. Also, make sure the device noise profile does match 
the video clip processed. Using an incorrectly chosen or poorly built profile can either produce 
plastic-looking results or leave residual artifacts (see the previous question). 

Q What is frequency? 

A The term (spatial) frequency is used in Neat Video to denote elements of a video clip (both important 
details and noise/grain) of certain size. 
High frequency corresponds to elements of smallest size. Medium (mid) frequency corresponds to 
elements of medium size. Low frequency corresponds to elements of (relatively) large size. 

Q The filtration process is not very fast, is this normal? 

A This is normal, because the filtration algorithm is quite complex. We work on further optimization to 
provide better performance. 

Q How to filter only the color noise (not the brightness noise)? 

A Set the value of the luminance (Y) channel noise reduction amount to 0%. This will disable filtration in 
the luminance (brightness) channel. 
 

http://www.neatvideo.com/brf.html�
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Q What is YCrCb? 

A YCrCb is the name of a family of color spaces widely used in digital imaging, television, video, etc. In 
'YCrCb', 'Y' corresponds to the luminance channel, 'Cr' - to the Cr chrominance channel covering the 
red to blue-green color range, 'Cb' - to the Cb chrominance channel covering the blue to yellow color 
range. Because this space enables easy separation of the luminance and chrominance information, it is 
very suitable to conduct noise reduction. 

Q Is processing via Neat Video best done before or after any other processing (i.e. tonal/color 
correction)? 

A Such operations as tonal/color correction are quite conservative from the standpoint of noise, i.e., they 
do not significantly change the noise characteristics of the video clip. Therefore, filtering before or 
after makes little difference – as long as the noise profile is built and applied at the same stage of your 
workflow. For example, don’t use a device noise profile built with an unprocessed (the color correction 
is not yet applied) clip to filter the same clip with the color correction applied. 
 
On the other hand, certain effects, like sharpening or resampling, applied to a noisy video clip may 
considerably change its noise properties. In this sense, it is generally better to use Neat Video filtration 
before applying such effects. 
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10. Information 

10.1. Issues and bugs 
Please report any bugs or issues you encounter while working with Neat Video. Use the online bug 
report form: http://www.neatvideo.com/brf.html. 

Your feedback will greatly help us to improve the software and provide you with newer and better 
versions of Neat Video. 

10.2. Plans 
The current version of Neat Video is the result of our ongoing research on noise filtration. We continue 
to work on the core noise reduction algorithms to improve the quality and speed of noise reduction. 

Please let us know if you have ideas that can make Neat Video better. Participate in the discussion on 
the Neat Video message board, express your opinion, make suggestions, and ask questions. 

10.3. Detailed feature map 
Neat Video 

Features Demo plug-in Home plug-in Pro plug-in 
File formats supported all formats supported by plug-in host 
8 bits/channel (24-bit RGB) rendering + 
Higher-bitdepth rendering – – + 

Maximum size / length of filtered video data 640x480 pixels
30 minutes 

720x576 pixels 
unlimited length 

unlimited size 
unlimited length 

Video data 

Neat Video label added to filtered clip added not added 

Intra-frame and temporal filter + 

Channel-wise (Y, Cr, Cb) + Noise 
reduction Frequency-wise (High, Mid, Low, Very low) + 

Channel-wise (Y, Cr, Cb) + Smart 
sharpening Frequency-wise (High, Mid, Low) + 
Device noise 
profiles 

Automatic and semi-automatic profiling of 
any video-capturing device + 

Filter presets (reusable filter settings) + 

10.4. Contacts 
We really appreciate your opinion of Neat Video. Please let us know what you think about the software. 
Feel free to ask questions regarding Neat Video. You can contact us using the following means: 

E-mails 
 info@neatvideo.com    — for general inquiries about Neat Video 

 finalcut@neatvideo.com   — for any inquiries regarding use of Neat Video for Final Cut 

 sales@neatvideo.com    — for any inquiries regarding purchase of Neat Video software 

Forum 
Register in Neat Video community forum ( http://www.neatvideo.com/nvforum/ ), and participate in 
discussions on the use and development of Neat Video. Such topics are covered in the forum as: 

• announcements of new and updated version of the software; 
• questions about use of Neat Video; 
• examples of using Neat Video with comments and suggestions; 
• feedback from the users: suggestions of new features and improvements; 
• contacts and general comments. 

http://www.neatvideo.com/brf.html�
mailto:info@neatvideo.com�
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Web page 
http://www.neatvideo.com/ 

10.5. Legal information 
Copyright 

Neat Video © 1999-2011 Neat Video team, ABSoft. All rights reserved. 

License agreement 
By downloading and/or in any way using the Neat Video plug-in for Final Cut (Mac) (called “Neat Video” 
hereunder in this agreement) software you indicate that you do accept this license agreement. If you are unable or 
unwilling to accept this license agreement then you may not use the Neat Video software and must return and/or 
destroy all copies of Neat Video in your possession. 

You may 
Use the Demo edition of Neat Video free of charge for non-commercial purposes only. 

Copy and distribute the Demo edition of Neat Video. 

Run the Home or Pro edition of Neat Video on one (or more, up to the number specified in your license) computer 
(computers) at a time for commercial and other purposes provided you are a registered user and you have a valid 
license for the corresponding edition of Neat Video. 

You may not 
Sublicense, rent, lease and sell any version of Neat Video or any portion of it including the license data without the 
explicit written permission from the Neat Video team, ABSoft. 

Copy, share and distribute the Home and Pro edition of Neat Video or any portion of it including the license data 
without the explicit written permission from the Neat Video team, ABSoft. 

Decompile, disassemble, reverse engineer, modify, clone and emulate any version of the Neat Video software or 
any portion of it including the license data. 

Use the Home and Pro edition of Neat Video if you are not registered user. 

Term and termination 
If you are a registered user of the Home or Pro edition of Neat Video and you have purchased a license for specific 
major version of Neat Video then you may use this major version (including all minor updates of the same major 
version) and edition of the software without time limitations provided you observe this license agreement. 

A license for a certain major version of Neat Video may be extended to a higher major version. By decision of the 
Neat Video team, ABSoft, this extension may be automatic and free or may involve an upgrade fee. 

You may terminate this license agreement at any time by returning or destroying all copies of Neat Video in your 
possession and notifying the Neat Video team. 

This license agreement will terminate immediately if you infringe upon the Neat Video team, ABSoft’s copyrights 
or breach this agreement. Copyright infringement or breaching this agreement may also result in criminal or civil 
prosecution. 

Disclaimer of warranty 
The authors make no warranty or representation, either express or implied, with respect to this software, its quality, 
accuracy, merchantability, or fitness for a particular purpose. This software is provided "as is", and you, its user, 
assume the entire risk as to its quality and accuracy. 

Distribution 
The Demo edition of Neat Video may be distributed unmodified provided any charge is to cover distribution costs 
only. 

The Demo edition of Neat Video may be placed on magazine CDs as long as the Neat Video team is informed. 
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10.6. Registration 
To become a registered user and to get a fully functional edition of Neat Video Home or Pro plug-in for 
Final Cut (Mac) you have to purchase a license (a single- or multi-user license). This can be done 
through an online software shop. Please find the detailed information in the purchase section of the Neat 
Video web page: http://www.neatvideo.com/purchase.html 

After you have purchased a license, you will receive an e-mail from the Neat Video team with detailed 
download and registration instructions. These instructions will help you download and become a 
registered user of the Neat Video software. 

By becoming a registered user of Neat Video Home or Pro plug-in for Final Cut (Mac) you will: 

• Encourage the authors to further develop and improve the software; 
• Get access to all functions of Neat Video Home or Pro plug-in for Final Cut (Mac) 

(see the Detailed feature map, page 27); 
• Be able to use Neat Video Home or Pro plug-in for Final Cut (Mac) for commercial and other 

purposes; 
• Get free updates of the software (minor modifications with the same major version number, for 

example, updates from the version v2.0 to any newer v2.x); 
• Enjoy reduced upgrade prices for new major future modifications of Neat Video Home or Pro 

plug-in for Final Cut (Mac) or will get a free upgrade; 
• Receive the primary attention of Neat Video support group; 
• Receive the primary attention of Neat Video development group 

(tell us what you want to see in the next version). 

 

Message from Neat Video team 

By becoming a registered user you are helping us to further develop and improve the software. 

Become a registered user and we will make Neat Video better for YOU! 
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